Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Denied permission to access folders

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 31-05-2007
Jack K
 
Posts: n/a
Denied permission to access folders

I recently purchased a new external hard drive and I set about transferring
files from my old XP computer to my new hard drive that I then connected to
my Sony Vaio laptop. Most files on the new hard drive are accessible on my
Vista laptop, but a large group (100 Gig) of video editing folders and files
are not accessible. I get these messages:

"You don't currently have permission to access this folder. Click "continue"
to gain access."

Then "You have been denied permission to access this folder - To gain access
you will need to use the security tab."

I have tried to follow the instructions on the help file: "Take ownership of
a file or folder", but although I have at least managed to get the video
files visible, Windows Media Player cannot play them. I can't do anything
with these files, not even delete them or copy them!!

Can anyone give me some advice please, this unexpected problem is driving me
nuts!

Thanks, Jim


Reply With Quote
  #2  
Old 31-05-2007
Jimmy Brush
 
Posts: n/a
Re: Denied permission to access folders

Hello,

This is a common problem with files that you created from another
installation of Windows.

This has to do with the security settings that Windows XP applied to
these files. Since they were created from your user account in XP,
they do not apply to your user account in Vista, and so you are denied
access in some circumstances.

To fix this, you can follow these steps:

- Click Start
- Type: cmd
- Right-click cmd when it appears
- Click Run As Administrator
- Change location to the folder you need access to (e.g. cd e:\folder)
- Type: takeown /F . /R /A /D Y > NUL
- Type: icacls . /grant USER:(OI)(CI)(F) /L /T /Q
(Where USER is your username - you will only have access from your
XP and Vista machine in this case)
(Or, replace USER with Users if you want anyone [on any computer
your hard drive is plugged into] to have full access to these files)
Reply With Quote
  #3  
Old 01-06-2007
Jack K
 
Posts: n/a
Thanks very much Jimmy for this information, I will give this a method a
try, but I'm a bit nervous about doing this! Is there a method that can be
used without resorting to programming techniques? The folder and files are
still accessible from the external drive on my old XP computer, even though
I can't get access to them on my Vista laptop.

Incidentally, I tried copying one of the folders again from my XP computer
to a new folder on my external hard drive, and this time it was accessible
on my laptop Vista machine. So it seems that it's just one particular folder
that Vista has problems with, it's not a consistent problem, so this is
rather odd.
Reply With Quote
  #4  
Old 01-06-2007
Jack K
 
Posts: n/a
Re: Denied permission to access folders

Thanks Jimmy for your help with this frustrating problem. On this occasion,
I have taken the "easy" way out, which was to open a new folder on my
portable hard drive and redo the whole copying job from my XP computer into
this folder. Fortunately, my Vista laptop has recognised all the files in
this new folder on the portable hard drive without any problems so far. But
I can see that, if you understand, and are confident using your direct
programming method, you would get the permission altered faster than using
the explorer interface, which I found most difficult to work with. However,
if you use this programming method, will you have a problem when you connect
your portable hard drive to an XP computer?

I am now wondering whether my Vista computer somehow corrupted just one
folder on my portable hard drive, even though my XP computer could still
access the portable hard drive without difficulty. It was time consuming to
recopy all the 100 gig of files into a new folder, but at least it has
worked.
Reply With Quote
  #5  
Old 01-06-2007
Member
 
Join Date: Oct 2008
Posts: 3
The Vista computer did not corrupt the folder. The problem is that XP set
the permissions on the folder to only Administrators. That works well on XP
because virtually every user is member of Administrators and so can access
it. On Vista, even if you are a member of Administrators you cannot actually
access resources as them without jumping through certain hoops. Jimmy's
work-around basically just jumps through the hoops for you. This is how Vista
is designed. if you are interested in why, Mark Russinovich's UAC article is
a good, although very technical, read:
http://www.microsoft.com/technet/tec...C/default.aspx.
You may find the book below useful too.my alley.

I'm having similar issues similar to this. I created my own topic since all scenarios that I've looked up are different and don't seem to work. This one might work, but I think I'm doing something wrong. I'm using Windows XP Pro SP2.

I formatted my C: and 3 of 7 folders on my F: are now giving me issues, says Access is Denied. I used to fix it in the Security tab but there isn't one showing. I'm the only user and I'm logged in as the admin. The folder says that there's 0 files and 0 bytes, I only have 70gb free on a 465gb HDD but the folders only add up to 174gb. So there's a couple hundred gigs that are on the drive but are not counting.

I tried the solution given here by going to the cmd prompt, switching to the F: (by typing F: and hitting enter. When I try the commands listed it says that 'takeown' is not recognized as an internal or external command, operable program, or batch file. The folder in question is at this path: F:\desktop. I cannot access that folder through the command prompt either. I can access other folders on the drive, just not the 3 in question.

There is another thread at Access is Denied - No security tab that I created originally. Any help is appreciated.
Reply With Quote
  #6  
Old 01-06-2007
Steve C-R
 
Posts: n/a
Re: Denied permission to access folders

Hi, I had the exact same problem after importing my files and settings from
an old XP install, now, I find after resetting permissions, I can no longer
download emails, I am assuming this is an off-shoot of this, as it happened
right at the same time as sorting permissions.

Thanks.

0x80070005 report from windows mail
Reply With Quote
  #7  
Old 01-06-2007
Jesper
 
Posts: n/a
Re: Denied permission to access folders

It has to do with the permissions on that folder. XP set them to allow only
Administrators full access. That works on XP, but not on Vista.

Without going into a very long explanation, this has to do with how
permission inheritance works. Any new file you add to the folder gets the
permissions the folder specifies to put on it, which is usually, but not
always, the same as the permissions on the folder. The longer description is
in the book.
Reply With Quote
  #8  
Old 29-08-2007
 
Posts: n/a
I am having a similar problem to the OP but with one difference.

I am trying to run an exe file from a CD. I tried running it from the run
window but receive the message "you don't have permission to open this file.
Contact the file owner or administrator to obtain permission".

I have full admin rights and the CD is a standard commercial program (i.e. I
purchased it).

I tried using explorer and am unable to even right click on the file (i.e. I
right click on it but the menu does not appear). I am able to right click on
other files (non-apps) but not on the exe file.

I tried the commands in your post but:

1. There was no choice to "run as administrator" when right-clicking on the
box. However, the title on the cmd box did indicate "Administrator c:\...

2. I could not get the drive to change to d:\setup (the directory the file
is in) but assume this is because the CD is read only.

Any suggestions as why Vista won't let me run the file?
Reply With Quote
  #9  
Old 12-09-2007
Seth
 
Posts: n/a
Re: Denied permission to access folders

That's because none of the commands you typed tell the machine to go to
drive E:, just to change the current directory on drive E:.

Try simply...
E: [Enter]
....to change your current drive to E: Then you can "cd" around the E: drive
all you want.
Reply With Quote
  #10  
Old 10-03-2008
remon
 
Posts: n/a
Re: Denied permission to access folders

Just wanted to drop by to say that the instructions and commands worked
beautifully.

I restored the primary [C:] hard drive from an old computer running
Windows XP to a new one as a secondary/additional hard drive on Windows
Vista, and got a "You have been denied permission to access this folder"
message.

Code
--------------------

- Click *Start*
- Type: cmd
- Right-click cmd when it appears and select *Run As
Administrator*.
- Change location to the folder you need access to (e.g. cd
e:\folder).
- Type: takeown /F . /R /A /D Y > NUL
- Press the Enter key and wait for the command to complete.
- Type: icacls . /grant Users:(OI)(CI)(F) /L /T /Q
- Press the Enter key.
--------------------
Should come in handy for future visitors. :)
Reply With Quote
  #11  
Old 16-11-2008
gjgerber
 
Posts: n/a
Re: Denied permission to access folders

I just tried Jimmy Brush's suggestion and it worked fine, except for the
little error created by the insertion of the sad face in the command
string.

I tried every combination of letters and characters I could think of
until I googled the search string and saw that it should read:

Type: icacls . /grant USER:(OI)(CI)(F) /L /T /Q

So, since my user name was owner-pc, the correct string to type in the
command line would be:

icacls . /grant owner-pc:(OI)(CI)(F) /L /T /Q

Once I typed in that string, it immediately granted me access to all
the files in the folder.

Another trick is to find your real user name. I always assumed it was
my screen name, but it wasn't. To find your user name in Vista, click on
Start, Control Panel, User Accounts and Family Safety. Then click on
User Accounts again.

You will see your screen name, user type and picture on the far right.
On the far left, you'll see a list of options. Click on Configure
Advanced User Profile Properties and a new window will open showing your
"official" user name. In my case it was Owner-PC
Reply With Quote
  #12  
Old 14-04-2009
Member
 
Join Date: Apr 2009
Posts: 1
Re: Denied permission to access folders

i have the same problem. occured while trying to set up a network. now i cant access drive c i keep getting access is denied. but i cant run cmd prompt as administrater as it wont let me. i get the message c:\windows\system32\cmd.exe the parameter is incorrect. i dont think anybody knows how to cure this as ive been trying for days. i just seem to get stupid questions like is your copy of vista legal.
Reply With Quote
  #13  
Old 27-05-2009
fogjuice
 
Posts: n/a
Re: Denied permission to access folders

Just wanted to say this worked perfectly for me. I had a bunch of old
folders on an old hard drive that I needed to regain permissions to. I
plugged it into my Windows 7 x64 machine, ran this command, and it
worked! :)

Now the scary part is, if this can regain permissions to folders that
users aren't supposed to have perms on, how can one truly prevent users
from gaining access to a windows folder?
Reply With Quote
  #14  
Old 13-01-2010
Member
 
Join Date: Jan 2010
Posts: 1
Re: Denied permission to access folders

Didn't Work For Me...

I've attatched an image of what I typed; i cant see anything wrong, i've re-checked a few times.
I amy have done the 'change location of the folder' part as i was unsure. i tried as many ways as i could think of.

Thanks for any help; all my backed up important files are locked away in there lol.

im on Windows 7 Home Professional

Thanks
Jethro
Attached Thumbnails
untitled.png  
Reply With Quote
  #15  
Old 26-02-2010
acesilver
 
Posts: n/a
Re: Denied permission to access folders


easy fix for when I needed to delete a folder that I could not because
of permission problems.

This is for people who still need help with this, I'm kinda late on
helping the original person but here it is....

Run cmd prompt as administrator, then type in....
net user administrator /active:yes

that opens up a new admin account and gives you access to everything. I
was able to delete the folder then =) i hope this helps!:D


--
acesilver
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Denied permission to access folders"
Thread Thread Starter Forum Replies Last Post
When try to take ownership of folders getting message “Access is denied” WYNNn Windows Software 3 23-01-2011 05:23 PM
Access denied: Require permission from Administrators.. etc, etc... HumbleSage Windows Security 3 11-11-2010 02:50 AM
Offline folders Access Denied when not connected DaffMan Operating Systems 1 06-07-2010 11:20 PM
Scheduled tasks - access denied, no permission Don Culp Windows x64 Edition 8 23-04-2009 01:39 PM
destination folder access denied you need permission to perform this action CapCity Vista Help 4 13-01-2009 05:36 PM


All times are GMT +5.5. The time now is 08:28 AM.