Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Host Process for Windows Services stopped working and was closed

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 08-04-2007
Danno111
 
Posts: n/a
Host Process for Windows Services Stopped Working and was Closed

After my computer has been idle for a few hours I find a dialog box with the
message saying the Host Process has stopped working. When I click the close
button, I see a help ICON in my system tray. When I click, up pops a Windows
Help and Support box. It's open to a section titled "What is Data Execution
Prevention?". It gives an explanation of DEP.

Does anyone know why this is happening? It's more of an annoyance than a
major problem, but I wonder if there's something wrong that I need to
address, or if this happens because something tries to execute while my
computer is in sleep mode.

Reply With Quote
  #2  
Old 13-04-2007
markeydsl
 
Posts: n/a
I have been getting this message a lot on windows vista. I notice that it
pops up at any given time. I have not been able to effectively determine what
it causing it. It just randomly happens.
wondering how to notify microsoft of this. I have also goodled this query
several times and it appears that many people are having this issue. I even
spoke with tech support about this issue and they have not ideas.

would be nice if someone knew something about this issue

any help with this would be greatly appriciated.

these are the events that occured just before I got the message. They are
the only system events that occured to be warnings or errors. Unfortunalty
I do not understand any of this information.
Reply With Quote
  #3  
Old 13-04-2007
Joe Guidera
 
Posts: n/a
Re: Host process for windows services stopped working and was closed

Unfortunately the host process (or svchost) is a generic shell for various
windows services (including third party installed services). By chance do
you have an HP printer installed? If so, that's a likely candidate. Some
of the HP services that the HP installer installs don't seem to play too
nicely with Vista just yet.

If you check the event viewer (start button and type event viewer) and look
under either the system or application logs, is any additional information
provided?
Reply With Quote
  #4  
Old 14-04-2007
Kayla
 
Posts: n/a
I just purchased a new computer with Vista and am
getting the same message when windows starts.
How can we fix this?

i had this same thing happen. the first time i ignored it but i could not use my fingerprint reader about the same time. the program ran but i could not get it to read the fingerprint to get on to anything. after reloading the software for the fingerprint it worked.

then i got the host process error again. and again the fingerprint read would not work. so i turned off the protection that causes the problem and rebooted and now the fingerprint reader worked without reloading the program.

so why would microsoft think that the fingerprint read software is mal-ware? hope this helps. i found the cmd statement to turn off the protection on another site.

This has only started today. Yet, I have not installed anything new
today...possibly an update?

Anyway, I am using my Windows Vista Home Premium Laptop (HP dv2058ea) and
suddenly a message pops up saying:

"Host Process for Windows Services stopped working and was closed"

Clicking 'OK' results in some movement in the screen windows before these
changes:
- Tabs in IE7 look old style and all the address bar and search are stripped
of the Aero feel. The minimise and close section remains Aero. All web pages
use old style buttons.

- Microsoft Office 2003 looks like version '98 (as in like its running on
old PC not a XP/Vista) in that the coloured areas have gone.

- Windows Live Messenger chats get a full window with the old close/minimise
buttons.

Any ideas? From looking around I'm getting that this due to Windows Defender
which I believe was the last update that was downloaded. But nobody seems to
have a fix for it.

It's becoming rather annoying.
Reply With Quote
  #5  
Old 14-04-2007
rapierau
 
Posts: n/a
Use your event logs in the Admin tools and try to trace back and find
the culprit/culprits. I have had this happen once and it was due to a
faulty driver.

You need need to provide us with more info. The Event log will help.
Use the Problem Reports and Solutions inside the control panel to give
you a rough date and time and then back track through the Event Log.

You can uninstall any update that you think that's causing you problems.

You need to ask Dell which update are they talking about. I don't know what
it's going to roll back too, if it rolls back to a previous setup. Maybe,
you can ask Dell about that too or MS.

I have been having the same annoying problem with this when i have tried to play videos from my media center library,same message (run dll32) stopped working etc,then closedown of media center (windows vista home premium by the way) tried everything but the kitchen sink on this one ,I have eventually solved it during a search through various forums ,found out in my case it was nero7 causing the problem ,so I was instructed to try the following and up to now its worked,here,s what I did,went into local disc( c:)>program files>common files>select folder Ahead>select folder DSFilter>then rename folder NeVideo.ax to 1NeVideo.ax I have not got a clue what this has done cos I am certainly no technical wizard on a pc but it (media center) does now play videos from the library instead of me having to use VLC player etc,I hope this can work for some of you .

The first thing you should do is get that Caps Lock key fixed! You keep
yelling like this and no one will pay attention to you.
Reply With Quote
  #6  
Old 11-05-2007
Natalie
 
Posts: n/a
I had my network wiped out due to this host process error took 2 days with
Dell and Linksys to get my internet service wireless on one computer and the
other will only connect through the modem. I paid money to dell and was told
it is due to a bad hot fix that went through a couple of nights ago. I was
told I may have to reboot the computer and have to much information to do
this on the computer. I emailed Microsoft really upset to let them know that
everything was fine up until this hot fix was sent. Please Help!!!! Anyone????

My problem occurs at startup.

I have Vista on a Dell Inspiron 1720, running Windows Vista.

Upon startup, I get the following message boxes:
1) c:\windows\system32\config\systemprofile\desktop location unavailable...
2) Host process for Windows Services topped working and was closed
3) Failed to connect to a Windows Service. Could not connect to Group
Policy Client service.

When trying to review the System Event Log, as indicated, I get a
"Dependency Service or Group failed to start".

Not sure what brought this on - have not installed anything new recently.
Right now, I am (slowly) finding my data files and doing a final backup, in
anticipation of having to reinstall Vista. Would prefer not to do that - all
of my business software will need to be reinstalled.

Looked at some of the other posts, and they look familiar, but not 'exactly'
the same, so checking to see if anyone else has had the same problem.

Hello friends I have same problem with my sony vaio on windows vista.
My internet connection gets slow down with host processor error & I need to restart. The startup is also very slow.
It has to be something with vista & windows defender IMO so do you guys have any idea regarding this?
Reply With Quote
  #7  
Old 29-08-2009
Member
 
Join Date: Aug 2009
Location: nj
Posts: 2
I had this same problem suddenly...

checked just about everything to do with networking...

a. couldn't access the lan on hardwire...
b. windows diagnostics advised THEY COULDN'T FIX AND TO CALL MY ISP.
c. I knew that was "bull!"

HERE'S THE SOLUTION THAT FIXED EVERYTHING:

a. first, just a point...I had a HP printer on the network... that DID WORK...but I couldn't access any folders or directories on the network (previously had been able to).

b. the CULPRIT: HP SmartUpdate ... THIS IS SOME NEW PKG THAT HP CAME UP WITH... that obviously has a problem with Vista... this program installed, I guess because HP noticed I didn't HAVE IT when I checked for an update or whatever of my printer software... so I probably gave them permission and downloaded and installed it...anyway

c. I went into CONTROL PANEL... and "add remove programs" is no longer there... IT IS NOW IN A FOLDER ICON CALLED..."Programs and Features" (Msft ...my rec: "if it ain't broke... don't fix it!")...anyway

I DELETED "HP SMARTUPDATE" AND "VOILA" ...ALL MY NETWORK LOCATIONS FILES/FOLDERS WERE "BACK!"

so, just get rid of HP SmartUpdate...I of course didn't delete any of the other HP software for my printers/scanners, etc.

sure a lot of people have HP printers so hope this help a lot!

c.

also... still had some problems occasionally... so I deleted "all my HP software" ...except for the ACTUAL DRIVER PROGRAMS FOR THE PRINTER AND SCANNER, on all computers.

also... got a win DEP msg and had to reactivate that... now all is well on my network...(DEP data execution prevention, it seems when that somehow became deactivated I couldn't see the network...etc.) ...sorry, I can't be clearer... I just got the laptop... and have little experience with Vista... though I can say their security level is CUMBERSOME... Msft ought to have a "disable the whole thing" thing... after-all...I'm just a home-user and DON'T NEED "ARMOR PLATED SECURITY" LIKE SOME BIG COMPANY...

one other thing: when I tried to access the "vista network" from an "xp machine" ...it couldn't find the vista computer...but then I specified the exact "path" like: \\vista laptop\public on the xp machine...and it found the vista network (after considerable time) and IT ASKED ME FOR THE "COMPUTER NAME AND PASSWORD." ...WHICH I ENTERED AND THEN GOT ACCESS...

...this surprised me because on another XP desktop...it found the network right away without a fuss, and not sign-in.

the caps are for emphasis

you should pay more attention to the substance instead of the delivery

since a google search for the problem came up with this site... even though the thread is old... others with the same problem will probably show up here... because their are no new posts DOES NOT MEAN PEOPLE AREN'T LOOKING AT THE PAGE...

update: Vista has a problem with older routers ... the link below helped ... I reset the registry entries as indicated in the fix on the page...IN THE FINAL SUBSET OF THE REGISTRY TREE ...I had 3 items for network cards ... I couldn't identify any cards, so I found the code indicated and SET THE VALUE TO "0" for all the items ...which is the last reccommendation on the page...I also made sure both by lan adapter and wireless adapter were both set to DHCP in their respective properties boxes.

http://support.microsoft.com/kb/928233/en-us

this seemed to work, as I got my hard-wired network showing...

one other issue THAT I TESTED ...don't have you're wireless receiver ENABLED when you're using a hard-wired lan connection... my network locations kept disapearing and re-appearing every few minutes... stopped after I disabled the wirelesss connection... IT WAS NOT GOOD ENOUGH TO SHUT OFF THE WIRELESS RADIO SWITCH... you could leave that on... but you had to ACTUALLY DISABLE THE wireless CONNECTION.
Reply With Quote
  #8  
Old 21-05-2010
Member
 
Join Date: May 2010
Posts: 1
Re: Host Process for Windows Services stopped working and was closed

I recently encountered this same situation and I disabled Windows Defender and it stopped. Don't know if this is answer to all but worked for me!
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Host Process for Windows Services stopped working and was closed"
Thread Thread Starter Forum Replies Last Post
Fix for "Host process for windows services stopped working and was closed" MattyBoy Tips & Tweaks 3 20-11-2011 02:29 AM
Windows host process (Rundll32) has stopped working Luc Vista Help 15 14-01-2010 02:43 PM
Windows host process Rundll32 has stopped working Duck Operating Systems 4 19-02-2009 07:35 PM
MICROSFT WINDOWS Host process for windows services stopped working Amir Pasha Windows Update 19 20-08-2008 03:39 PM
Windows Host Services has stopped working Scratch Vista Help 13 29-02-2008 01:38 AM


All times are GMT +5.5. The time now is 09:09 PM.