Results 1 to 13 of 13

Thread: Window blocked startup programs

  1. #1
    Tim Guest

    Window blocked startup programs

    When I start Vista, I always get a popup that says Windows blocked some
    startup programs. When I go into Windows Defender to find out what is
    being blocked, I get the list of programs loaded at startup, and each is
    either designated "Permitted" or "Not yet classified." Even the "Not yet
    classified" programs are being loaded. So how do I find out which ones
    Windows is blocking?


  2. #2
    Dave Guest

    Re: Window blocked startup programs

    Have you used msconfig to stop some programs?
    I have, and that's what causes the message, not Defender.

  3. #3
    Anthony Wieser Guest

    Re: Window blocked startup programs

    There's a menu item on the icon that lets you start blocked programs.

    It was msconfig in my case as well, which I used to turn off a bunch of junk
    that came bundled with my Dell.

  4. #4
    Rock Guest

    Re: Window blocked startup programs

    Click on the icon on the notification area and select the option to have it
    display the blocked program(s) so you can give it permission to run. Any
    program that runs at startup that either needs admin privileges or for which
    you marked it as Run as Administrator will be blocked at startup until you
    give permission.

    So you need to ask yourself, first do you need that program to run at
    startup? If so does it have to have admin privileges? Is there an update
    for it that allows it to run without admin privileges? Is there another
    program that will do the trick that doesn't need admin privileges.

    This happens with msconfig when you make a change in it and then reboot.

  5. #5
    Tim Guest

    Re: Window blocked startup programs

    Yes, it was apparently msconfig that is causing this. Since I don't need to
    be notified every bootup of this condition, how do I turn off the popup?

  6. #6
    Rock Guest

    Re: Window blocked startup programs

    Just like you did in XP when it popped up with the one added step. First
    unblock it so it can. Do this by an option from clicking on the icon in the
    notification area. Then when msconfig comes up check the box to not have it
    display. It won't until the next time you make changes with msconfig and
    reboot.

  7. #7
    Tim Guest
    No, that's doesn't solve the problem. I have always checked the box to not
    have msconfig display after I have made changes. But I still get the popup
    box saying Windows blocked some startup programs.

  8. #8
    Olly Guest

    RE: Window blocked startup programs

    Have you been into msconfig ? type msconfig in search click on the file look
    in start
    up programes make sure they are all checked.

    "Tim" wrote:

    > When I start Vista, I always get a popup that says Windows blocked some
    > startup programs. When I go into Windows Defender to find out what is
    > being blocked, I get the list of programs loaded at startup, and each is
    > either designated "Permitted" or "Not yet classified." Even the "Not yet
    > classified" programs are being loaded. So how do I find out which ones
    > Windows is blocking?
    >
    >


  9. #9
    LoneStar Guest

    Re: Window blocked startup programs


    "Rock" <Rock@nospam.net> wrote in message
    news:uv16pSzdHHA.4172@TK2MSFTNGP05.phx.gbl...
    >
    > Just like you did in XP when it popped up with the one added step. First
    > unblock it so it can. Do this by an option from clicking on the icon in
    > the notification area. Then when msconfig comes up check the box to not
    > have it display. It won't until the next time you make changes with
    > msconfig and reboot.
    >
    > --
    > Rock [MS-MVP User/Shell]


    I have the same situation. Your solution does no good and I've tried
    (almost) everything to keep the pop-up from appearing and staying in the
    notification area: right clicking, msconfig, etc. Or perhaps I don't get
    exactly what you're saying.

    Of course, I didn't have this notification after I first got my new Vista
    computer, but after I disabled several garbage entries in msconfig, the
    notification about "some items have been blocked..." keeps coming back every
    bootup and stays during the entire up-time.

    Nevertheless, Vista is excellent!

    EW




  10. #10
    Join Date
    Dec 2007
    Posts
    1
    If youíre like me, you may block some of the programs that normally want to run at startup so they donít eat all your RAM and processor. After doing this, you may consistently get notifications reminding you that a program is being blocked. Hereís why you might be getting them, and how to make them stop.

    Hereís the message that I receive:


    Windows has blocked some startup programs: Windows blocks programs that require permission to run when Windows starts. Click to view blocked programs.

    Now youíre probably thinking that Vista is reminding you that you blocked some programs, but if you did what I did, youíd be wrong. Ironically, Vista is letting you know that it is blocking the program that you used to block those programs! You likely used MSCONFIG to block your startup programs or services. When the computer starts up, the changes you made with MSCONFIG are handled as you chose, but then MSCONFIG wants to show you a dialog window that reminds you that you made those changes. Problem is, UAC wonít let MSONFIG open to show that dialog because it requires elevated privileges.

    Thankfully this is easy to fix, but is evidence of how the many pieces of Vista donít always cooperate with each other.

    Click on the Blocked Startup Programs icon and from Run blocked programs choose System Configuration Utility.

    You will be prompted to approve the elevation of privileges (if UAC is active) and then youíll see the friendly warning dialog that is causing all the trouble. Check the box and click OK to tell the System Configuration Utility not to try and show the dialog again.

    Thatís it! Now if you didnít see System Configuration Utility in the Ďblocked programsí list, then it might be some other program that is trying to run. If thatís the case, you can use MSCONFIG to tell that program not to run, or you can use the Show or remove blocked startup programs option from that same menu to ĎDisableí the program.

  11. #11
    Jim Guest

    Re: Window blocked startup programs

    This information was right on. Got rid of that startup program reminder!
    Thank you!

  12. #12
    chrhon Guest

    Re: Window blocked startup programs

    I have seen several sites all mention "Click on the Blocked Startup Programs
    icon and from Run blocked programs choose System Configuration Utility. "

    I have something I installed that is trying to run in the system tray on
    startup that vista blocks... weird thing is I have it installed on several
    computers and only one blocks it. From the "run blocked programs" I only
    have the program that is blocked.. no system configuration utility.

  13. #13
    Join Date
    Jan 2008
    Posts
    11
    i think i may have found a possible solution to stop windows blocking programs. i had tried many different ways ie, turning defender off, using msconfig,etc..etc. Software Explorer did not give me the option to enable blocked programs within defender(greyed out) but finally after several days i think i cracked it. Disable UAC (user account control) here's how;



    Turning off UAC reduces the security of your computer and may expose you to increased risk from malicious software. We do not recommend leaving UAC disabled.


    To turn off UAC

    1.

    Click Start, and then click Control Panel.
    2.

    In Control Panel, click User Accounts.
    3.

    In the User Accounts window, click User Accounts.
    4.

    In the User Accounts tasks window, click Turn User Account Control on or off.
    5.

    If UAC is currently configured in Admin Approval Mode, the User Account Control message appears. Click Continue.
    6.

    Clear the Use User Account Control (UAC) to help protect your computer check box, and then click OK.
    7.

    Click Restart Now to apply the change right away, or click Restart Later and close the User Accounts tasks window.
    This worked for me, i feel in control again (until the next problem anyway) hope this helps some-one, it's my first post ever!

Similar Threads

  1. Replies: 4
    Last Post: 30-03-2011, 01:44 AM
  2. Replies: 4
    Last Post: 24-12-2010, 05:17 PM
  3. Blocked Internet Access For Updated Programs
    By ch33ks in forum Networking & Security
    Replies: 6
    Last Post: 14-09-2009, 09:49 PM
  4. UpdateUtil Application Startup Program Blocked
    By Michael G in forum Vista Help
    Replies: 1
    Last Post: 29-08-2008, 05:18 AM
  5. Windows Has Blocked Some Startup Programs
    By Haydon in forum Vista Help
    Replies: 17
    Last Post: 18-06-2008, 02:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •