Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Help me undo what caused the "Run a legacy CPL elevated" prompt...

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 09-03-2007
vassago
 
Posts: n/a
Help me undo what caused the "Run a legacy CPL elevated" prompt...

Today from the control panel I ran the "NVIDIA Control Panel" program. After
I closed the program Windows asked me if the program opened correctly (which
it did). I ACCIDENTALLY chose the equivilent of "no", and now each time I
run the program I get prompted to "Run a legacy CPL elevated" before it opens
the program. Is there a way to un-do what I did so it opens without the
prompt like it used to?

The program is also available by right-clicking the desktop and clicking
"NVIDIA Control Panel" from the shell menu. When I launch it this way it
doesn't do the "legacy" prompt, it's only when I launch it from the Control
Panel.

I know it doesn't make a difference since the app opens and closes just fine
either way, but I'd like to make it the way it was. Thanks!

Reply With Quote
  #2  
Old 11-03-2007
grnemo
 
Posts: n/a
RE: Help me undo what caused the "Run a legacy CPL elevated" prompt...

I have done the same with Java Control Panel...Grrrrrrrrrrrrrrr
Reply With Quote
  #3  
Old 11-03-2007
Gary VanderMolen
 
Posts: n/a
Re: Help me undo what caused the "Run a legacy CPL elevated" prompt...

Right-click on the executable file, Properties, Compatibility.
Reply With Quote
  #4  
Old 11-03-2007
grnemo
 
Posts: n/a
Re: Help me undo what caused the "Run a legacy CPL elevated" promp

Thx, but for the java platform the problem solved slightly different
http://bugs.sun.com/bugdatabase/view...bug_id=6485081
Its ok now. :D
Reply With Quote
  #5  
Old 12-03-2007
vassago
 
Posts: n/a
Re: Help me undo what caused the "Run a legacy CPL elevated" promp

OK, I found the file. It's located at C:\Windows\System32\nvcpl.cpl

I tried right clicking and looking around but I can't find anything that I
can "un-check" to get it to no longer need the "run a legacy CPL elevated"
prompt. It only needs this prompt when launched from the control panel, not
when it's launched directly or from right-clicking on the desktop.

Is there a way to re-set it back to how it was when it's launched from
control panel?
Reply With Quote
  #6  
Old 12-03-2007
Gary VanderMolen
 
Posts: n/a
Re: Help me undo what caused the "Run a legacy CPL elevated" promp

Sorry, I was looking at a .exe file. It seems that a .cpl file lacks the
compatibility settings that .exe has. I don't have any further advice on this.
Reply With Quote
  #7  
Old 09-11-2007
WEA WEA is offline
Member
 
Join Date: Nov 2007
Posts: 1
Search the registry looking for the primary part of the CPL name (ex: sample.cpl - use only sample).

You will probably find the name numerous times but one will have an entry in the right-hand panel with a data value of RUNASADMIN.

Click on the name entry in the right-hand panel to highlight it and delete this entry.

You should no longer receive the message.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Help me undo what caused the "Run a legacy CPL elevated" prompt..."
Thread Thread Starter Forum Replies Last Post
Unable to Undo Changes from "Optimize Service" on AVG PC Tune-up -ADDISON- Windows Software 4 06-08-2011 10:23 PM
Error message "Explorer caused an invalid page fault in PDM.DLL." Aadeshh Operating Systems 4 13-11-2009 06:17 PM
Stop IE8 prompt "Download Windows Search to improve..." Dwarner Technology & Internet 3 02-09-2009 05:37 PM
Vista: getting "elevated status" ? joey2000 Operating Systems 1 27-07-2009 09:37 AM
"Undo Send" Feature For Gmail Arzaan Technology & Internet 3 20-03-2009 11:04 PM


All times are GMT +5.5. The time now is 01:28 PM.