Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Cannot view png files in Internet Explorer 7

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 06-03-2007
Member
 
Join Date: Sep 2004
Posts: 75
Cannot view png files in Internet Explorer 7

I am not able to see .png files in Internet Explorer 7. I was visible before. I just received a update popup and I accepted the same. My browser was updated. Now when I open some site projects the .png files does not load. There is a small x. How can I restore the old settings back. I had checked the help option and tried to find answer on this, but as nothing is mentioned over there related to this stuff. It is a very basic issue and I know there is a option available on Internet Explorer to fix this things. Thanks.

Reply With Quote
  #2  
Old 06-03-2007
Member
 
Join Date: Sep 2004
Posts: 119
re: Cannot view png files in Internet Explorer 7

You can do that by modifying the file association. For that go on Control Panel and then click on Program Defaults. In that for the image file png setup Internet Explorer. Next time when you open up any .png image file it will open in IE. There can be some issue with this browser. But you can reset it by going in Internet Options. It will restore the old settings back. If still this does not work then re-install the web browser. I hope it will be fixed. Sometime the popup blocker does not allows images to load up. Disable the same and then check one more time.
Reply With Quote
  #3  
Old 06-03-2007
Member
 
Join Date: Sep 2004
Posts: 113
There is a small fix that worked for me. I had too updated the browser and after that it was not able to load png files. For that click on Start and in the Run box type regsvr32 c:\windows\system32\pngfilt.dll. Click on OK. Just reboot your system once and then check back. There another thing that you can try. You have to right click on the image file and then click on open with > internet explorer. There is a small check box below which will set IE as the default program for png files. It works now. You can check the file association also but that does not help much.
Reply With Quote
  #4  
Old 06-03-2007
Member
 
Join Date: Sep 2004
Posts: 133
It looks like a basic issue by annoying. I am hoping to find a solution for the same. The graphics on IE is not able to display properly. Is the issue lies only with png files. Check others also. Go on Tools > Internet Options and click on Advance tab. There below you can see an option called as Multimedia. In that click on Show image download placeholders. Ensure that this option is disabled. Because if this is checked you will not see the images. Re-installing the web browser will help you much. Because that is the only way to restore all the settings back. I am using Firefox and it work better than Internet Explorer. Check your browser security settings also. They might also be responsible for this issue.
Reply With Quote
  #5  
Old 25-03-2007
Member
 
Join Date: Sep 2004
Posts: 136
I have a similar issue here. In my system also I cannot see the png file in IE7. I had used that regsvr32 c:\windows\system32\pngfilt.dll trick. But it gave me a strange error. The error was something related to entry-pion cannot be loaded or found. So I manually downloaded the dll files and copied the same to system 32. But that too does not helped much. My friend owns a Dell laptop in which he is using Windows Vista. We had updated that recently and similar problem appeared. This issue does not exist is any other browser we have. I had tried to modified the file association of png file to IE7. That did not really helped much. It looks lie a bug with IE only. Just for checking purpose I disabled the firewall and uac. It started working. I had seen that if you are logged in a limited user account or if you have security services running in your system, the images will not be displayed. It is associated some security settings of IE.
Reply With Quote
  #6  
Old 13-04-2007
Member
 
Join Date: Sep 2004
Posts: 208
I had tried to create a new account on and then logged in with that. It works fine. IE7 is showing up png files. So it looks there are some settings related to the login id. But how can I find that. Also I can keep on using the new account, but there is no way to migrate the document and settings of old account to new. It would make IE to behave same as it was before. I had tried to run the updates back again, but does not helped out much. I am hoping to find a much appropriate solution for the same.
Reply With Quote
  #7  
Old 17-04-2007
Member
 
Join Date: Sep 2004
Posts: 129
re: Cannot view png files in Internet Explorer 7

It worked for me. Just right click on Internet Explorer and click on Run As > Administrator. It will display the png files. It looks there is some issue with file permission on IE. While other browser really does not worry much about that. I had tried to find a fix for that, but this is the only option left. Or else you can try using some other browser like Firefox. It is far more better and offers you better surfing features. Another thing I had tested which also worked. I downgraded my IE version. I removed the current one. I gives me popup of new updates, but simply ignore that.
Reply With Quote
  #8  
Old 18-04-2007
Member
 
Join Date: Apr 2007
Posts: 2
There is acually a plugin for firefox, called IE Tab. It allows you to open tabs in firefox using the IE engine instead of the Firefox one. No need to start another browser just switch in firefox.

But i still have the same poblem in IE7 as you guys have. and for me none of the fixes displayed on this site helps, not even creating another user. Now its just a waiting game.
Reply With Quote
  #9  
Old 18-04-2007
Member
 
Join Date: Sep 2004
Posts: 127
re: Cannot view png files in Internet Explorer 7

Reported the issue to Microsoft. But yet there is no clear response available. This is a very old bug which still exist. Type regsvr32 %WinDir%\system32\pngfilt.dll in run box. You must execute this only if you are logged in as administrator or else it will not work. If you are having Quicktime installed in your system then you have to make changes to the player preferences also. Try this also. Right click on the image file and then click to open with IE. Then again right click and click on open with Windows Photo Gallery. I found some IE PNG fix exe files on web. But I do not really trust it.
Reply With Quote
  #10  
Old 02-06-2007
Member
 
Join Date: Jun 2007
Posts: 1
[quote=Dean-Dean;2635706]Try this:

Start -> Run... -> regsvr32 c:\windows\system32\pngfilt.dll (and click OK).

omg it worked for me. thank you so much. but I already took apart half my files tryna figure this out. I went through system restores, made a new administrator account, undeleted files, registry editors, all my personal files are gone now but I am so happy I finally got the problem fixed. Thank You!
Reply With Quote
  #11  
Old 27-07-2007
Member
 
Join Date: Sep 2004
Posts: 150
re: Cannot view png files in Internet Explorer 7

It is a much annoying problem in Windows Vista. At start no one has noticed this. I have two systems at my home. Once is a laptop that has Vista and the second one is Desktop running on Windows XP. I had checked in both. Windows XP pc shows the png file wellin IE while Vista does not. This all happened after running a update. I think system restore can help a bit here. I cannot understand the relation between this png issue and UAC. Does that really works. But when I turn that off it starts working.
Reply With Quote
  #12  
Old 24-09-2007
Member
 
Join Date: Sep 2004
Posts: 156
solution!!!(for xp ,and explorer 6, maybe will work in other cases)

I had wasted quiet nice number of hours to make this thing work. I have Vista on my system. At first when I tried to manage all the settings as mentioned above nothing worked out. Then I re-installed Windows vista, java, and other required update. In IE6 usually this bug exist. Along with png stuff I was also facing a error where I was not able to choose any text through mouse. So to some extent java is not behind the issue. After running Windows Update my browser version was updated and it started working well. I have only one account in the system which is the default admin account. I do not like UAC so keep it disabled by default.
Reply With Quote
  #13  
Old 26-11-2007
Member
 
Join Date: Sep 2004
Posts: 150
Run the browser in admin rights and it will work. I think IE works in different way. It will open a file if it has full permission to access it. This is a bit weird thing as this is entirely a different application. If you had messed with permission settings then the issue will appear for other file format also. There is no fix available for that neither there is any kind of update that can help you to fix the same. I had tried to find the same in Help & Support. But what I can see is general troubleshooting options. The images load well in other browsers, and only in IE I am not able to get that. The same red x is not clickable at all. I had checked everything in Internet Options.
Reply With Quote
  #14  
Old 26-11-2007
Member
 
Join Date: Sep 2004
Posts: 144
It would be a bit helpful if you can provide the screenshot of your issue. I am also using a similar system but the issue does not appear here. I can see all png file listed well. But after doing a number of research I found that the issue can be fixed through Windows Registry trick. You ned to make changes in a registry key which only admin can do. Sometime due to fresh updates the key is modified and the option is disabled for other user accounts. The png file will be only visible to admin not to the users. Now the click on Start > Run > type regedit. In that look for the following location HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/futuresplash. You have to reset the permission to default here. Once done reboot your system and then check back. As this is a bit longer process. You have to authenticate every user here one by one. Like right click on application/futuresplash > permissions > add > location. Then choose local computer > type the user and click on checknames. Click on Appy.

How do I restore security settings to a known working state?
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Cannot view png files in Internet Explorer 7"
Thread Thread Starter Forum Replies Last Post
Unable to view ftp site in Internet Explorer 8 Lennon Norris Technology & Internet 3 29-03-2012 05:06 PM
Compatibility View settings in Internet Explorer 9 pUNIM Technology & Internet 3 19-02-2011 05:44 PM
Unable to view thumbnail of .eps files in Windows Explorer Hajra Operating Systems 5 03-02-2010 11:58 AM
Internet Explorer 8 Compatibility view invisible Gagnesh Windows Software 3 16-10-2009 12:32 AM
How to view internet explorer history FELIPA Windows Software 3 29-06-2009 11:10 AM


All times are GMT +5.5. The time now is 07:07 AM.