Results 1 to 6 of 6

Thread: Spooler SubSystem App Stopped Working And Was Closed

  1. #1
    Join Date
    Aug 2006

    Spooler SubSystem App Stopped Working And Was Closed

    I have got myself a HP Photosmart 8250 Printer and am running Windows Vista on my computer. The drivers were automatically downloaded and installed by Vista and everything used to work fine but just past week this printer stopped working. So, I have already tried to remove all the Windows Update and every other application but still facing the same problem. I have even tried to enable Printer Spooler service, deleted printers, cached files, etc but nothing seems to be working for me. When I checked even viewer it gave me the following:

    Faulting application spoolsv.exe, version 6.0.6000.16386, time stamp 0x4549b734, faulting module localspl.dll, version 6.0.6000.16386, time stamp 0x4549bcf7, exception code 0xc0000005, fault offset 0x00070a15, process id 0x5e8, application start time 0x01c753cf82366c15.

    Can anyone help me out. Thanks

  2. #2
    Join Date
    Aug 2005
    Have you tried checking for an updated driver for the printer from the HP website? You can even try to delete the registry key for the printer which points to the driver that must be corruped. To do that you need to click on Start >> Run - Regedit >> HKEY_LOCAL_MACHINE >> SYSTEM >> ControlSet001 >> Control >> Print >> Environments >> Windows NT x86 >> Version -3 ->> Delete All Printers From Here. You can even try to go to C:\Windows\System32\spool\PRINTERS and delete everything from there and see if the problem gets resolved.

  3. #3
    Join Date
    Sep 2005

    Re: Spooler SubSystem App Stopped Working And Was Closed

    I agree that this thread is really useful, unfortunately I seem to have another problem. In addition to the message discussed in this thread, I get "Windows can't open Add Printer. The local print spooler is not running. Please restart the spooler or restart the machine." So I created the batch file above. Great idea. But the spooler aborts for some reason. I'm running the Windows OneCare Online Scanner in hopes of coming up with something. To make things more complex, I'm trying to add a network printer. Any ideas? Thanks!

  4. #4
    Join Date
    Apr 2011

    Re: Spooler SubSystem App Stopped Working And Was Closed

    Thanks Cavdude. This worked!

  5. #5
    Join Date
    Jun 2011

    Re: Spooler SubSystem App Stopped Working And Was Closed

    Vista user .... Great thread - had the same thing just before an important document had to be delivered. Googled the error message and got here. Looked like a plan - no dabbling in registers etc ...

    Deleted all the entries in the PRINTERS directory as suggested .. and ran the Microsoft FIX IT program for printers to restart the print spooler. All over in 10 minutes !!!

    Saved again by the power of collaboration.

  6. #6
    Join Date
    Jul 2011

    Re: Spooler SubSystem App Stopped Working And Was Closed

    The issue can be resolve quiet easily through a tiny software. It is in the link below. You have to click on that and download the tool. Then run it. This tool will resolve various printer spooler related errors. A number of errors can be easily fixed through this. Just try this tool and test back. I am quiet sure it will work really well.

    Microsoft Print Diagnostic Fix

Similar Threads

  1. Replies: 9
    Last Post: 27-08-2009, 07:12 AM
  2. Replies: 3
    Last Post: 08-08-2009, 09:55 AM
  3. Spooler SubSystem App stopped working and has closed
    By haritable in forum Vista Help
    Replies: 1
    Last Post: 07-08-2008, 01:05 AM
  4. Replies: 2
    Last Post: 28-12-2007, 04:58 AM
  5. Replies: 5
    Last Post: 13-12-2007, 08:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts