Results 1 to 7 of 7

Thread: Error 0x00000003 & 0x00000578 installing print driver

  1. #1
    Join Date
    May 2009
    Posts
    3

    Error 0x00000003 & 0x00000578 installing print driver

    Operating System = W2K8 Server Standard + SP1 and all updates (64-bit)

    I recieve the following two errors when attempting to install a Microsoft inbox print driver: (attached)

    Is there a solution?

    Thank you,

    - Tyler

  2. #2
    Alan Morris [MSFT] Guest

    Re: Error 0x00000003 & 0x00000578 installing print driver

    This is just the x64 print driver? What is the driver name? I assume you
    are installing the driver using the Print Management Console utility
    included with the Print Server role.

  3. #3
    Join Date
    May 2009
    Posts
    3
    Hi Allen - thanks for the quick response. Yes, the inbox x64 driver included with the OS & your assumption is correct; I am using the print mgmt. console included with the role. The driver is the last of the last. Scroll to the bottom of the list "Xerox" and then the bottom of that list... "Xerox WorkCentre Pro C3545 PS".

    The driver does exist there and I'm installing via RDP @ the actual print server. Is it a permissions or UAC issue possibly?

    Correct, only a driver install. No, I do not have any XEROX drivers installed on the system. I have attempted installing a multitude of drivers since posting earlier and am receiving the same issue across the board. I'm unable to install any drivers manually. The only way I've been able to get any installed has been to run an export from an existing print server and then import.

  4. #4
    Alan Morris [MSFT] Guest

    Re: Error 0x00000003 & 0x00000578 installing print driver

    error 3 is path not found

    I've installed this driver before without issue since we have the devices at
    Microsoft.

    Does the driver file exist under
    \system32\driverstore\filerepository\prnxx001....\amd64?

    Are you installing the driver from a path other than the local machine?

  5. #5
    Alan Morris [MSFT] Guest

    Re: Error 0x00000003 & 0x00000578 installing print driver

    I don't have local access to most of the servers I help the MS IT department
    with so the installs are in a TS session to the machine. UAC is enabled on
    all the machines I deal with. I am prompted for elevation when launching
    Print Management. Error 5 is access denied. You are only installing the
    driver at this point, correct. Is there a driver from Xerox.com already
    installed. I know they have one with the same name.


    The install requires files from \filerepository\ntprint.inf......\amd64 as
    well

  6. #6
    Alan Morris [MSFT] Guest

    Re: Error 0x00000003 & 0x00000578 installing print driver

    this is very odd.

    Take a look at setupapi.log , setuperr.log in \windows

    if the file is too big rename the current one and install the driver again

    I assume you currently have shared printers on this server and it's in use.

  7. #7
    Join Date
    May 2009
    Posts
    3

    Re: Error 0x00000003 & 0x00000578 installing print driver

    No shared printers... printers are not in use. This is a dev box; we're trying to get ready to move to W2K8 from W2K3. The setupapi.log has the following information in it. "The location of the SetupAPI log file has been changed.
    The new location is: D:\Windows\INF" The setuperr.log file is empty.

Similar Threads

  1. Replies: 3
    Last Post: 15-01-2014, 09:37 AM
  2. Error while installing driver on Windows 7
    By Fred Fruax in forum Operating Systems
    Replies: 4
    Last Post: 10-03-2011, 01:46 AM
  3. Error while installing sound driver in compaq
    By Caesar in forum Hardware Peripherals
    Replies: 3
    Last Post: 05-01-2009, 01:30 PM
  4. Replies: 7
    Last Post: 20-10-2008, 09:25 PM
  5. Error code 87 when installing remote print drivers...
    By MadKovalchuk17 in forum Windows Server Help
    Replies: 2
    Last Post: 29-01-2008, 08:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •