Results 1 to 4 of 4

Thread: restoring local area connection icon

  1. #1
    ripsnort Guest

    restoring local area connection icon

    Can one inform me as how to restore the local area connection in vista.

    I've done the normals, such as taskbar / properties / hiding /
    restoring icons etc, but this *local area connection* icon is no where
    to be seen.
    I'd appreciate help in restoring this little critter!!! Thanks!


  2. #2
    Chad Harris Guest

    Re: restoring local area connection icon


    Troubleshooting missing network and dial-up connections icons

    Good luck,


  3. #3
    ripsnort Guest

    Re: restoring local area connection icon

    Thanks for the response Chad. The only snag with the site you've given
    me, is that deals with Windows XP --- I've got Windows Vista Home
    I'm sorry I never mentioned that earlier. Having come onto a Vista
    Forum, I had thought that to be understood.
    If you've any further clues as to overcome this, I'd appreciate it. The
    problem given and dealt with on that site you gave is the same problem,
    but different instructions as to how to overcome this on Vista.


  4. #4
    Chad Harris Guest

    Re: restoring local area connection icon


    You actually can use either of the two options below--the KB or Ramesh's
    regedit or his automatic reg fix download to restore the Network icon IN

    I'm aware this is a Vista forum, but when appropriate directions and moves
    that work on XP work on Vista and Windows u7 and Windows 2K at times. This
    KB should be one of them.

    It was understood. The majority of XP MSKBs work for Vista; some don't..

    All the services referred to in this particular MSKB are present on a Vista
    box--and a Windows 7 box for that matter.

    The settings referred to in the first part of the directions are present in
    Win 2K, Win XP, Vista, and Win 7. That's 4 OS's.

    Did you try ose directions? You have no downside.

    It depends on the KB. MSFT sometimes doesn't designate a KB that works for
    a prior OS with the "works on" label for the new OS.

    If the directions in the MSKB I linked you don't work, this current regedit
    will, and it should unhide the network icon and also provied the option to
    make the network icon available on the control panel as well when you right
    click the start button>properties and have the option to show it. You can
    also show the network connections icon in the notificaiton area as I'm sure
    you know.;

    Network Connections icon is hidden by default from the Control Panel in
    Windows Vista. Here is a registry edit to unhide the Network Connections

    Add Network Connections icon to the Control Panel
    1. Click Start, type regedit.exe and press ENTER

    2. Navigate to the following branch:

    HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \
    Control Panel \ don't load
    3. In the right pane, right-click ncpa.cpl and choose Delete

    4. Exit the Registry Editor.

    You also have the option to download this Registry fix automatically from
    Ramesh's site. As always thanks to Ramesh Srinivasan MSFT Shell MVP for his
    excellent blog and sites over the years. See below:

    Good luck,

Similar Threads

  1. Local Area Connection Icon in Network Connections missing
    By Cheng-Gong in forum Networking & Security
    Replies: 5
    Last Post: 16-08-2010, 02:20 PM
  2. Local Area Connection
    By HamizMughal in forum Networking & Security
    Replies: 1
    Last Post: 27-07-2010, 10:38 AM
  3. No Local Area Connection
    By Jada0612 in forum Windows XP Support
    Replies: 5
    Last Post: 27-09-2009, 05:08 PM
  4. Local Area Connection > Local Only
    By Ashish Goenkar in forum Windows Vista Network
    Replies: 3
    Last Post: 29-01-2008, 12:19 AM
  5. Local Area Connection Problems
    By seaboyd in forum Vista Help
    Replies: 1
    Last Post: 26-09-2007, 06:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts