Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 14-10-2008
wadeb_21
 
Posts: n/a
The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the

For some reason I am getting this error code (Explorer.exe The
Application Failed to Initialize properly (0xc0000022). Click Ok to
Terminate the Application) whenever I try to log into my computer. I put
in my password and then this message comes up and nothing happens it
wont go to my desktop or anything. I then restarted and logged into my
machine through safe mode and everything works. I tried to run a windows
update to see if I was missing an update or something but in Safe Mode
it will not let me run Windows updates. I also went to add and remove
programs and tried to uninstall the most recent application I installed
to see if that was the problem but once again I can not uninstall
anything in safe. If someone could help me out with this problem I would
really appreciate it thanks.

Reply With Quote
  #2  
Old 15-10-2008
wadeb_21
 
Posts: n/a
Does anyone have any info, that can help me? I would really appreciate
it?

Try this:

*Start>>Run>>cmd.exe* and type

*CACLS %systemroot%\System32\*.dll /E /G BUILTIN\Users:R
**CACLS %systemroot%\System32\*.ocx /E /G BUILTIN\Users:R

*and restart

Thanks for getting back to me I really appreciate it. I just tried
this and it tells me access denied. Do you know why it would say that?
Reply With Quote
  #3  
Old 16-10-2008
wadeb_21
 
Posts: n/a
So I followed the instructions from the link you posted did the scan
and it did find errors but couldn't fix them so I opened up the log it
produced from the scan but I have no idea how to tell what files it
didn't repair. Do you know how to tell? Or no of another way to fix
this problem?

The log file is a text file is it not? So open it with Notepad or
something and copy/past the context in a post.

I am not saying I can help you, but maybe, or someone else can help you.
Reply With Quote
  #4  
Old 16-10-2008
Flavius
 
Posts: n/a
Re: The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the

Did you all in normal mode or safe mode?If you did in normal mode it
was fails because you have UAC turned on - you have to run *cmd.exe*
with administrative previlliges (right click on it>>run as
administrator) and then repeat my commands or repeat all from post 3 in
safe mode.I thought you can't log in normal mode
Reply With Quote
  #5  
Old 16-10-2008
wadeb_21
 
Posts: n/a
Re: The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the

I just tried both in Safe mode then restarted and I"m still having the
same problem. Man this is getting fustrating, I don't understand what
caused this problem. Do you have any other suggestions?
Reply With Quote
  #6  
Old 16-10-2008
Flavius
 
Posts: n/a
Try this command in *cmd.exe*

TAKEOWN /F C:\WINDOWS\SYSTEM32\JSCRIPT.DLL
ICACLS C:\WINDOWS\SYSTEM32\JSCRIPT.DLL /GRANT ADMINISTRATORS:F
if these commands also return "access denied" you will have really big
trouble...

I'll give those commands a try and let you know how it goes. Is it
possible I could have some sort of maleware that caused this?
Reply With Quote
  #7  
Old 16-10-2008
wadeb_21
 
Posts: n/a
ok I just ran both those commands. After I ran the first one it said

"C:\windows\system32\jscript.dll" Now owed by user "Michael-PC\Michael"

Then I ran the second command and it said this after

successfully processed one file

What do you think I should do now. should I restart and try and log in
normally to see if those commands fixed the problem?

In this case try this in *cmd.exe*

*takeown /f C:\windows
icacls C:\windows /grant administrators:F
*
and check does trouble gone...
Reply With Quote
  #8  
Old 16-10-2008
wadeb_21
 
Posts: n/a
Re: The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the

Ok I just ran both of those commands in safe mode and they were both
successful. I then restarted and tried to log into normal mode and the
same thing is still happening. Man I wish I new what caused this
problem. Do you know of anything else I can do?
Reply With Quote
  #9  
Old 16-10-2008
Mr. Arnold
 
Posts: n/a
Re: The Application Failed to Initialize properly (0xc0000022) ClickOk to Terminate the

One shouldn't get carried away trying to take ownership of C:\Windows

http://msdn.microsoft.com/en-us/libr...40(VS.85).aspx

Supported Resource Replacement Mechanisms
Replacement of protected resources is supported through the following
mechanisms.

Permission for full access to modify WRP-protected resources on Windows
Vista and Windows Server 2008 is restricted to TrustedInstaller with the
Windows Modules Installer service using the following mechanisms:

Windows Service Packs installed by TrustedInstaller.
Hotfixes installed by TrustedInstaller.
Operating system upgrades installed by TrustedInstaller.
Windows Update installed by TrustedInstaller.

Applications and installers attempting to replace a WRP-protected
resource by means other than these specified methods are denied access
to change the resource and generate an access denied error message.
Reply With Quote
  #10  
Old 16-10-2008
Flavius
 
Posts: n/a
try this also in cmd.exe

*icacls C:\windows /grant users:R
*if also no help try to use SystemRestore

I'll try this and let you know. The first thing I tried to do when this
problem started was a system restore but that didn't work either.

Choose>>Language>>Repair Computer>>System Restore?

Maybe, you need to contact MS for support via email or contact the
manufacture for software support of an OEM.

http://windowshelp.microsoft.com/Win...t/default.mspx
Reply With Quote
  #11  
Old 16-10-2008
wadeb_21
 
Posts: n/a
Yes I tried the restore and it went back to a earlier date but I still
was unable to log into my machine in normal windows mode. Man I just
want to throw this computer out the window.
Do you think I could have some kind of Maleware that changed the
settings around or something?

It is possible.Check your system any tool i suggest to use 'Index of
/devbuilds/RescueDisk/'
(http://dnl-eu10.kaspersky-labs.com/d...ds/RescueDisk/)

I'll scan my computer and see what it says.

The thing is I don't have my vista DVD it didn't come with my computer.
Reply With Quote
  #12  
Old 16-10-2008
wadeb_21
 
Posts: n/a
I down loaded the scan you told me to but I don't understand how to use
it? Can you explain it to me?

This is livecd with antivir.Burn *.iso image on DVD and boot it.

Where did you get the driver update? Was it Windows Update?
Reply With Quote
  #13  
Old 17-10-2008
Flavius
 
Posts: n/a
Re: The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the

@WADEB_21
I found another way to repair it. If you really have some trouble with
permission maybe help you,when you'll finish scan.I've exported DACLs
from my computer and try to import to you - I don't know this really
good idea but you have little to lose...
Download this file 'aclfileN.zip' ,unpack it and place i.e on
C:,then type in *cmd.exe*

*icacls c:\windows /restore C:\aclfileN*
Reply With Quote
  #14  
Old 17-10-2008
wadeb_21
 
Posts: n/a
Re: The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the

I haven't had a chance to run the scan yet that you told me to
yesterday. I will try and run the scan today then do the zip file above.

When I burn the scan to a disk do I boot my computer from the disk so
it scans when the computer first turns on?
Reply With Quote
  #15  
Old 17-10-2008
Flavius
 
Posts: n/a
Of course it is bootable CD/DVD (with mouse service of corse) and then
you boot it appear menu there click scan and will work.

PS.I will have no time for 2 days now so I have to leave you alone at
the moment.Probably in this time you'll count only yourself.Good luck!

Thanks allot with everything, I will do what you told me and post back
so you can see how its going for me when you get back. Thanks again.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the"
Thread Thread Starter Forum Replies Last Post
"The application failed to initialize properly (0xc000007b). Click Ok to terminate the application." error message in vista 64 elander Windows x64 Edition 7 07-04-2012 07:25 PM
Message while opening any application "The application failed to initialize properly(0XC0000142).Click on OK to terminate the application" Griffiths Windows Security 4 07-04-2012 07:19 PM
My DVD drive error "The application failed to intialize properly (0xc0000006). Click in ok to terminate the application gabru368 Hardware Peripherals 5 07-04-2012 07:12 PM
"The application failed to initialize properly (0xc0000006). Click on OK to terminate the application" Chucky Windows XP Support 10 19-08-2011 12:27 PM
Fallout 3 - The Application Failed to Initialize properly (0xc0000022) Click Ok to Terminate the Program Nelo Video Games 2 13-10-2010 06:29 AM


All times are GMT +5.5. The time now is 02:40 PM.