Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Age of Empires 2 Conquerors (AOE2) multiplayer LAN problem Vista-XP

Vista Help


Reply
 
Thread Tools Search this Thread
  #1  
Old 16-09-2008
Member
 
Join Date: Sep 2008
Posts: 2
Age of Empires 2 Conquerors (AOE2) multiplayer LAN problem Vista-XP

Nostalgic moments of going back to AOE2. :D Too bad I cannot seem to play multiplayer LAN with my friends.

Currently I have 3 Windows XP PC/Laptops, 1 Vista. I have googled, read most of TechArena's tips and helps. But still no good. All my WinXP machines can connect fine. But not Vista.

Problems:
- WinXP created game. Vista can join, but ALL XP machines cannot receive information from Vista machine. So if they change group number, new civs or whatever, or click READY, XP machine doesn't register anything
- Vista created game. XP tries to join but hangs at the "Joining Game" screen. Have to press ESC to cancel.
- So problem is XP cannot receive information from Vista. Vista cannot seem to "access" XP either.

Tested:
- Removed firewall
- Open up ports
- Disable UAC
- Installed LLTD in WinXP
- Disabled iPv6 and what not that's not in WinXP's network protocols
- Even regedit of HKEY_LOCAL_MACHINE -> SYSTEM -> CONTROL -> LSA -> restrictanonymous (change value to 1)

Can someone help please?

Reply With Quote
  #2  
Old 17-09-2008
Member
 
Join Date: Sep 2008
Posts: 2
did you check

I meant you would search the site for patches, they have them a pack for
multiplayer options.

Nope. If I could played over Internet I would. I just want to play it over LAN. My internet is not good enough to handle 4 PCs to join igzones.
Reply With Quote
  #3  
Old 05-01-2009
Member
 
Join Date: Jan 2009
Posts: 1
Just tried myself last week, it wouldn't work using Vista laptops.
So we used a Vista laptop & a XP laptop (both wireless) but used a cable. after a few tries the XP hosted the game and 2 Vista machines connected and played fine. We then somehow got the Vista m/c (when hard wired to the XP ) to host, both the other Vista m/c connected then we simply disconnected the XP m/c. and we all played a game.

It may not matter but we didn't uses the 1.0c patch (the previous attempt didn't work) we used the 1.0b + used the original disc and didn't use a NoCD crack.

ok i found a solution

the solution is:

in vista, goto your firewall exceptions list
(center network and shared resources> Windows Firewall >change config > exceptions Tab)

once there eliminate from that list :

-Age of Empires II Expansion
-Auxiliar file from Microsoft DirectPlay

make shure
you have checked Notify when firewall blocks a new program

Acept and close everything

then start the game, host a multiplayer using TCP(LAN)

THEN Alt+Tab (dont setup anything yet) and then wait until windows (wakes up from underground) and shows you your desktop, then where firewall you will be noticed about 2 programs

Unblock Both

return to the game

then join aoe from your others XP machines normally as should expected

ok thats all, everytime you want to host the game you'll have to do every step
Reply With Quote
  #4  
Old 06-06-2010
Member
 
Join Date: Jun 2010
Posts: 2
Re: Age of Empires 2 Conquerors (AOE2) multiplayer LAN problem Vista-XP

Solution for problem “Unable to play AOE2 over LAN”

Brief summary of Problem: Two laptops, one running on Windows Vista(SP1) and another on Windows 7 are unable to play Age of Empires 2 multi player game via Wireless LAN.

Note: The problems faced by you might be similar to this blog, however you can skip the steps if they are not applicable in your case.

Working Solution: We had this problem for 2 weeks, and couldn't find an exact solution anywhere. After a lot of search and consolidating all the suggested solutions from various blogs and by exploring ourselves we were able to solve this. We've been playing the game without any problems for the last few months.

First symptom and resolution: Able to get a response when the Vista machine was pinged from the Windows 7 machine but unable to get a response vice versa. Found that network discovery was disabled on the Vista Machine and for some reasons we were unable to change it. The Vista machine had kaspersky antivirus(KIS8.0) running, we stopped/disabled it.
We then started and set the following windows services to 'Automatic' ( Go to run --> services.msc and hit enter)
– SSDP Discovery
– dnscache
– fdrespub (functional discovery resource publication)
– UpnP device host

We were then able to enable network discovery on the vista machine and ping each others' machines.

Second Symptom and resolution: Able to host the game on one machine but unable to find it from the other. Found out that Kaspersky protection on the vista machine was automatically enabled which was again blocking the game's communication in one direction. We disabled kaspersky and were able find the game.

Third Symptom and resolution: Able to host the game and find it, but unable to join. Then we installed the microsoft patch from http://download.microsoft.com/downlo...US/Age2upA.exe

Fourth Symptom and resolution: After installing the patch we were unable to launch empires2.exe. We then replaced the file empires2.exe from an archive that was taken before installing the patch. It worked normally.

Fifth Symptom and resolution: After following the above steps, we were finally able to host a multi player game, find and join it. But when we start the game, we get an error message don't quite remember the exact message, but it suggested something like incompatible versions. As suggested in some forums, we looked at the compatibility options of empires2.exe. (Right click empires2.exe > Properties > Compatibility). In both the machine configure the compatibility settings as follows
Check “Run as Administrator” and “Run this program in compatibility mode for Vista”.

Ongoing Usage: Finally after the above troubleshooting steps we were able to play the multi player game via LAN. Felt proud ;) . But the last and important notes in strict order as:
1.Add age of empires to the firewall exceptions in the anti virus programs / Windows Firewall
2.Disable Kaspersky protection (or your antivirus protection).
3.Launch the game on the Vista machine first and later on the Windows 7 machine
4.Game has to be hosted on the Vista machine and the Windows 7 machine should join it

Have a look at the readme.txt shipped with the game. Some option there as well might help.
Reply With Quote
  #5  
Old 26-06-2010
Member
 
Join Date: Jun 2010
Posts: 1
Re: Age of Empires 2 Conquerors (AOE2) multiplayer LAN problem Vista-XP

Can anyone help me?
I have 2 PCs (windows XP) connected to eachother by Thomson (LAN). (firewall totaly/completly OFF) They can c each other. Status connected local area connection 100.0 mbps.
now......
when i create a game the other PC cannot find it.

What should i do.
Reply With Quote
  #6  
Old 28-06-2010
Member
 
Join Date: Jun 2010
Posts: 2
Re: Age of Empires 2 Conquerors (AOE2) multiplayer LAN problem Vista-XP

Try these:

1)try installing the patch that we have given in link on both PCs.
(I am assuming that you are able to PING each other)
2) Check antivirus settings on your (game host) system.
3) Check following services are set to Automatic
( Go to run --> services.msc and hit enter)
– SSDP Discovery
– dnscache
– fdrespub (functional discovery resource publication)

A restart comp is recommended.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Help
Tags: , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Age of Empires 2 Conquerors (AOE2) multiplayer LAN problem Vista-XP"
Thread Thread Starter Forum Replies Last Post
Incompatibility of Age of Empires 2 Conquerors with Alienware Jerry Portable Devices 5 14-09-2011 10:44 PM
Age Of Empires II Conquerors color issue on Windows Vista Dhruv Video Games 10 19-11-2010 03:46 AM
age of empires 2 tcp/ip multiplayer problem guntek Windows XP Support 7 14-11-2009 11:41 AM
Age of Empires: Conquerors and Vista Don Purvis Vista Help 5 08-07-2009 02:59 PM
Age of Empires 2: Conquerors Cannot host lan game Ruskets Vista Help 4 13-03-2007 08:24 PM


All times are GMT +5.5. The time now is 02:01 PM.