Results 1 to 2 of 2

Thread: External Hard Drive Enclosure not working in Windows

  1. #1
    Join Date
    Oct 2005
    Posts
    51

    External Hard Drive Enclosure not working in Windows

    I had bought a USB 2.0 hard drive enclosure. I have a laptop and a desktop. I purchased a additional internal hard drive and thought this would be the quickest way to copy data. The enclosure has usb 2.0 output. After fitting all well, when I started data backup I receive a error that the drive is not accessible -- parameter incorrect. It stopped. I have to re-plug the drive to access it again. I am bit irritated with the same. The laptop has Vista. I am not able to figure out where the problem lies.

  2. #2
    Join Date
    Sep 2004
    Posts
    144
    Go in Device Manager and then ensure that the en-closure is installed. This error appears due to two reason. The first is due to loose connection. While transferring the data, the connection is terminated due to that. There can be bad sector also. Check the enclosure and then reconnect it. This is not a driver issue. There can be problem with the bad sector.

Similar Threads

  1. Replies: 4
    Last Post: 22-06-2011, 07:38 AM
  2. Replies: 4
    Last Post: 14-12-2010, 02:30 AM
  3. External hard drive enclosure for laptop
    By Calusa in forum Hardware Peripherals
    Replies: 5
    Last Post: 29-03-2010, 02:40 PM
  4. External Hard Drive is working Slow in Windows Vista.
    By WaGoN in forum Hardware Peripherals
    Replies: 1
    Last Post: 22-01-2009, 12:27 PM
  5. 500GB Lacie USB 2.0 External Hard Drive not working on Windows Vista
    By Ascetica in forum Vista Hardware Devices
    Replies: 4
    Last Post: 20-05-2008, 10:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •