Results 1 to 4 of 4

Thread: Installing / Registering Canon Multipass F80 Vista Driver

  1. #1
    Join Date
    May 2008

    Installing / Registering Canon Multipass F80 Vista Driver

    I am having a Canon Multipass F80 printer and I am trying to install its driver in Windows Vista. First I have downloaded the F80_Vista32.exe driver and saved it on my desktop. Later on when I double click on it, I get the licence page where i accept it and the installation starts, but as soon as it finishes I get an error message that "An error occurred while files were being copied". I have tried several times but nothing is working, please help me out.

  2. #2
    Join Date
    Feb 2008
    Have you tried running the exe file of the printer with Administrator powers. To do the same right click on the setup.exe file and then select the "Run as Administrator" option and then try to install the same driver. It could be even that there might be no space left on the drive where you are trying to install the drivers, so free up some space on the hard drive and then try to install the driver.

  3. #3
    Join Date
    Dec 2007
    I was able to solve this issue by looking at the driver install log file where I found that the installation was qrongly searching for file "usbscan.sys" in the folder C:\Windows\Drivers and C:\Windows\Inf. So in my computer I was able to find the path C:\Windows\System32\DriverStore\FileRepository\sti.inf_727905e0 which may differ on others computer and even if it differs then try to search in the folder C:\Windows\System32 for it. On retrieving it copy the same to the below 2 folders:
    After that you just need to start the installation again and everything will be working find this time.

  4. #4
    Join Date
    Feb 2008

    canon mp560

    When I was searching for the usbscan.sys file, I found it in 4 different places. I was confused here which one to copy, so I just copied the new one tha was in the folder windows/system32/drivers to the windows/inf folder and also made a new folder called windows/drivers and copied here as well. But after rebooting the pc and starting to reinstall the driver, it was still not working. Is there any other way of installing the drivers for my canon mp560 on Vista?

Similar Threads

  1. Canon MultiPASS MP390 manual needed
    By Wappinger in forum Hardware Peripherals
    Replies: 6
    Last Post: 12-06-2010, 01:34 AM
  2. Canon MultiPASS C555 InkJet Printer Manual
    By Tajdar in forum Hardware Peripherals
    Replies: 4
    Last Post: 10-06-2010, 04:10 AM
  3. Problem installing Canon printer in Vista Ultimate 64 bit
    By Stephen Flanagan in forum Vista Help
    Replies: 4
    Last Post: 13-10-2008, 01:55 PM
  4. Driver for Canon LBP 2900 (Vista 64 bit)
    By Donnell in forum Vista Hardware Devices
    Replies: 1
    Last Post: 06-10-2008, 07:21 AM
  5. Replies: 1
    Last Post: 23-02-2008, 10:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts