Go Back   TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Hardware Devices
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Creative SB Live! Value (WDM) Sound card not working on Windows Vista

Vista Hardware Devices


Reply
 
Thread Tools Search this Thread
  #1  
Old 02-11-2006
Member
 
Join Date: Sep 2004
Posts: 74
Creative SB Live! Value (WDM) Sound card not working on Windows Vista

My system has Creative SB Live! Value (WDM) Sound card installed on my system. After upgrading to Windows Vista it stopped working. I installed Windows Vista RC1 on the same. I had wiped out Windows XP. I was having a disc with that card. When Vista was booted new hardware wizard appeared on the screen. It showed me a error that the hardware was not installed properly. It is the sound card. I need some help to find a proper driver for Vista only. Thanks.

Reply With Quote
  #2  
Old 03-11-2006
Member
 
Join Date: Sep 2004
Posts: 56
I am too having the same issue. I visited the official support website where I found driver available only for Windows XP. Not drivers were listed for Windows Vista. The link that I found is below. Just check it. The first is for Windows XP x64. So this is a kind of clear indication that this device does not support Vista. And if your Vista is able to use XP drivers then there are chances of making this thing work. Try some Windows Update and check back.

Creative SoundBlaster Live Driver
Reply With Quote
  #3  
Old 03-11-2006
Member
 
Join Date: Sep 2004
Posts: 102
I dropped out the idea of location drivers for this card. The best thing is I had dual boot my system. It is not at all worth to buy a new Vista disc which has this kind of driver problems. In Windows XP the drivers are installed automatically from the disc. It looks Creative is not interested in provided any kind of additional driver support for new edition of Windows.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Vista > Vista Hardware Devices
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Creative SB Live! Value (WDM) Sound card not working on Windows Vista"
Thread Thread Starter Forum Replies Last Post
No sound from Creative X-Fi Music sound card after restarting Windows 8 Jason Voorhees Hardware Peripherals 2 01-10-2012 12:38 PM
Bioshock not working on Windows Vista 32 bit with Creative Blaster X-Fi Xtreme Audio PCI sound card Cale Video Games 4 16-04-2011 11:38 PM
Creative SB0100 Sound Card on Win 7 & Vista Bower Hardware Peripherals 5 04-07-2010 02:08 AM
Creative SoundBlaster 7.1 Audio Sound card not working Julie Ghadawala Hardware Peripherals 5 27-01-2010 12:26 PM
Vista 64 & Creative Sound Blaster live Rambo Operating Systems 3 23-02-2009 11:47 AM


All times are GMT +5.5. The time now is 10:17 AM.