Results 1 to 6 of 6

Thread: Transformers: Fall of Cybertron wont launch at all, stuck at black screen

  1. #1
    Join Date
    Jun 2012
    Posts
    73

    Transformers: Fall of Cybertron wont launch at all, stuck at black screen

    My system specifications is as followed:
    Intel(R) Core(TM) i5 CPU 760@ 2.80GHz
    8GB RAM
    ATI Radeon HD 4870
    I have downloaded and have installed Transformers: Fall of Cybertron but when I am trying to launch the game then loading screen comes up and after sometimes process gets stuck at black screen. It stays like that and until I kill the process via task manager. I have found task manager reporting as “stopped working”. I have tried launching the game several times but no avail I get the same response from it. I am not able to make out what exactly is the issue all about.

  2. #2
    Join Date
    Nov 2011
    Posts
    126

    Re: Transformers: Fall of Cybertron wont launch at all, stuck at black screen

    Have you installed latest driver for your ATI Radeon HD 4870? If not then install it and see if game is running properly after that. If that doesn’t help then you can try uninstalling and reinstalling the game. Just make sure that you are installing latest driver for your video card and you are making clean installation of it. You can use driver sweeper for uninstalling and removing instance of old driver and proceed with installation of latest driver. Try out these things first and let me know if you find any of them to be helping.

  3. #3
    Join Date
    Jun 2012
    Posts
    73

    Re: Transformers: Fall of Cybertron wont launch at all, stuck at black screen

    I had tried installing latest driver for my graphics card previously but this time I have tried using driver sweeper for uninstalling old driver and making clean installation of latest one but no avail. I loading screen cannot get past black screen and gets stuck there, I have tried uninstalling and reinstalling video driver as well the game several times but no luck yet.

    My system components are fulfilling system requirement of Transformers: Fall of Cybertron and even after that I am running in to such weird issues. I don’t know what to do, it feels as if ive wasted my money getting this game. Is there anything that I can try out hence forth for getting the game working?

  4. #4
    Join Date
    Nov 2011
    Posts
    128

    Re: Transformers: Fall of Cybertron wont launch at all, stuck at black screen

    You can try running the game in compatibility mode, for running the game in compatibility mode right click on .exe file of the game and select properties. Now in propertied window click on compatibility tab, in there you will see a drop down box listing different compatibility modes for xp, vista etc.

    You can try using those compatibility modes and check out if any of them is helping you out in running the game. If you get luck with any of the compatibility mode then you will have to continue playing this game in same mode.

  5. #5
    Join Date
    Jun 2012
    Posts
    73

    Re: Transformers: Fall of Cybertron wont launch at all, stuck at black screen

    I have tried running the game in compatibility mode and have tried almost all of the compatibility modes that were present in the drop down box list but no luck. I was able to run the game with XP SP3 mode but the graphic was appearing weird and the game was lagging. I wanted to know why I should run the game in compatibility mode when my system is better as compared to the system requirement of the game. I will run this game in my friends system as he’s system specification is almost similar to mine to find out if there is actually something wrong with the game or in my system.

  6. #6
    Join Date
    May 2012
    Posts
    92

    Re: Transformers: Fall of Cybertron wont launch at all, stuck at black screen

    I wanted to know if you are having some other application running in background while running the game ? I think that there might be some application running in background interfering with the launcher. I am not that sure but you can try closing all applications in background including your security tools for testing purpose. Check it out and post back if game runs fine after that.

Similar Threads

  1. Transformers: Fall of Cybertron Multiplayer is boring
    By Oh Besnik in forum Video Games
    Replies: 8
    Last Post: 30-08-2012, 10:35 AM
  2. Replies: 9
    Last Post: 29-08-2012, 02:08 PM
  3. Replies: 9
    Last Post: 28-08-2012, 07:03 PM
  4. Transformers Fall of Cybertron Troubleshooting Guide
    By GaMeR-BoY in forum Guides & Tutorials
    Replies: 3
    Last Post: 28-08-2012, 04:22 PM
  5. Bugs in Transformers: Fall of Cybertron
    By Teelak in forum Video Games
    Replies: 3
    Last Post: 27-08-2012, 03:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •