Results 1 to 6 of 6

Thread: Error "Failed to run a required program (agent)" while running Diablo III setup

  1. #1
    Join Date
    Sep 2010
    Posts
    17

    Error "Failed to run a required program (agent)" while running Diablo III setup

    Hello friends recently I have downloaded Diablo III game from the internet and when I starting installing the game at that time it looks for the updates and then gives me error saying "Failed to run a required program (agent)". I don’t know what is causing this problem.

    My computer specifications are Asus motherboard, ATI Radeon HD 5670 graphic card, Intel Core i5 processor, 4 GB RAM. I have tried to solve this problem by checking all the setting in the Firewall, disabled all unnecessary services from the startup except Microsoft, but still the same error.

    I have also downloaded the latest version of framework in my computer and then installed it. Still no effect on the error. Please help me out to solve this problem. In my computer graphic card drivers and direct X is also up to date. Thank you in advance.

  2. #2
    Join Date
    Aug 2010
    Posts
    83

    Re: Error "Failed to run a required program (agent)" while running Diablo III setup

    Well, just try out the following steps, it should work. Open my computer, go to the C drive and open programs data folder. Scroll to the Battle.net folder and delete it. Also make sure you deleted the entire temporary files from your computer. Now run the Diablo III setup. Now you have to check whether you are getting same problem.

    If still you are facing the same problem, than run the setup and open taskmanager from the task bar. Find process named "Agent.exe". If it is there than it means that your internet explorer is in offline mode which is causing this problem. You should disable the offline mode in the internet explorer and now run the setup again.

  3. #3
    Join Date
    Jul 2010
    Posts
    50

    Re: Error "Failed to run a required program (agent)" while running Diablo III setup

    Yes you need to turn off offline mode in internet explorer. If you don’t know about how to turn off the work offline mode in the internet explorer then I will help you with it. Launch internet explorer, click on Tools button and deselect the "work offline" option.

    In many cases after turning off the work offline option also we get similar problem and that is why we need to do following changes in the internet options.

    • Open control panel and click on internet options.
    • Click on the tab called connections.
    • Choose “Never dial a connection.” option.
    • Now click on the LAN Settings button.
    • Now uncheck all the option form there.
    • Click on OK button. After doing that you have to check whether same problem is occurring or not?

  4. #4
    Join Date
    Aug 2010
    Posts
    74

    Re: Error "Failed to run a required program (agent)" while running Diablo III setup

    You should create new user account in your computer with Admin privileges and try to install the game. If you have already tried this and dint worked than run the setup, open task manager without quitting the setup, locate agent.exe and kill the process. Also did you tried installing Diablo III in compatibility mode ? If not, try it out with Windows Xp SP3 compatibility mode and check whether it helps you to solve the problem.

  5. #5
    Join Date
    Sep 2010
    Posts
    17

    Re: Error "Failed to run a required program (agent)" while running Diablo III setup

    Thank you all for your suggestions and attempt to help me out. But i have tried everything mentioned above, and noone of them worked for me yet. Now please tell me what should I do to solve this issue?

  6. #6
    Join Date
    Jul 2010
    Posts
    62

    Re: Error "Failed to run a required program (agent)" while running Diablo III setup

    Well, just try out this. Go to start menu, type regedit and press enter. This will open registry editor. In registry, go to the following location:

    HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > NT. After expanding the NT you have to go to the CurrentVersion and then open Image File Execution and then check whether there is Agent folder exist or not? if Agent folder is there then delete it and then reboot your computer. After restarting your computer you should try to install game again and then see what the situation is.

Similar Threads

  1. Replies: 6
    Last Post: 21-04-2012, 03:00 PM
  2. Replies: 2
    Last Post: 20-03-2012, 03:47 PM
  3. Diablo III Installation Error message:"Failed to Download"
    By Vijay.D.Chauhan in forum Video Games
    Replies: 3
    Last Post: 19-03-2012, 08:04 PM
  4. Replies: 3
    Last Post: 19-03-2012, 09:47 AM
  5. Replies: 3
    Last Post: 05-01-2012, 07:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •