Results 1 to 3 of 3

Thread: Installation of Diablo III beta is taking more time through "setup" portion

  1. #1
    Join Date
    Feb 2012
    Posts
    65

    Installation of Diablo III beta is taking more time through "setup" portion

    I have been trying to install Diablo III beta but then it is appearing to be taking a long time through the "setup" portion of the progress bar, I have been waiting really long I donít know what is the issue all about, so here I just wanted a quick reply whether I should restart the installation process or It does takes time??? Is there anyone who can help me clearing my doubt???

  2. #2
    Join Date
    Jan 2012
    Posts
    102

    Re: Installation of Diablo III beta is taking more time through "setup" portion

    I have been trying to install Diablo III beta but then it is appearing to be taking a long time through the "setup" portion of the progress bar, I have been waiting really long I donít know what is the issue all about, so here I just wanted a quick reply whether I should restart the installation process or It does takes time??? Is there anyone who can help me clearing my doubt???
    Yes it is taking a long time, I have waited for the process to get it completed for almost 2 hours, I had checked out after a solution for the same but then I had not got any help, I did not wanted to start the installation process so I waited and then after several hours I was able to install it successfully, anyways I have now installed the game without any issues but then I will like to know if it was some issue or it was normal. I doubt that the blizz might be having a lot of networking load for the BETA and there is a need to widen up the broadband for the Diablo III.

  3. #3
    Join Date
    Feb 2012
    Posts
    132

    Re: Installation of Diablo III beta is taking more time through "setup" portion

    Even I need some help regarding the same, not exactly but then I have found that the compatibility run program option is appearing to be greyed out for me, I have tried clicking on the same but then it is not making any difference, I donít think that I have missed out anything, does any body knows what is the possible cause for it??? Any help regarding this will be highly appreciated.

Similar Threads

  1. Replies: 5
    Last Post: 12-06-2012, 03:34 PM
  2. Replies: 6
    Last Post: 21-04-2012, 03:00 PM
  3. Replies: 6
    Last Post: 23-03-2012, 02:26 PM
  4. Diablo III Installation Error message:"Failed to Download"
    By Vijay.D.Chauhan in forum Video Games
    Replies: 3
    Last Post: 19-03-2012, 08:04 PM
  5. Replies: 3
    Last Post: 19-03-2012, 09:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •