Results 1 to 7 of 7

Thread: Crysis 2 not performing well on directx 11 ultra settings

  1. #1
    Join Date
    Jul 2005
    Posts
    33

    Crysis 2 not performing well on directx 11 ultra settings

    I have Crysis 2 which I am running on the windows 7. So when the game released by EA it doesnít have the direct support for directx 11 but now when the patch launched by crytek. After that I have installed it on the game. But now the game causing some performance issue on ultra settings. Game lags with the less frame rate problem can anyone suggest solution which can be useful to improve the performance.
    My system specification is:
    • Graphics card: Nvidia Geforce Gtx 570
    • Processor: Intel core i7 2600 processor
    • Ram: 8GB ram 1333Mhz
    • Hard Drive: 250GB solid state hard drive
    • power: coolermasters 750W.

  2. #2
    Join Date
    Jun 2009
    Posts
    3,960

    Re: Crysis 2 not performing well on directx 11 ultra settings

    Yes I am also getting less fps on the ultra setting. So actually this is causing due to directx 11 itself. Since directx 11 using high level of textures. So due to that the game textures takes more resources this causing the less frames per seconds. So itís not any issue or the problem with the game. If you want some improvement in the performance try to do this turn on the vsync after turning it on you can able to get more frames while playing. So enable the vsync.

  3. #3
    Join Date
    Jun 2009
    Posts
    3,859

    Re: Crysis 2 not performing well on directx 11 ultra settings

    Your system configuration is one of the best for the crysis 2. Yes the drop in the frames per second is due to the direct 11 itself. Still if you want to increase the performance of the game. Then try to update the drivers of the graphics card to the latest one that is 280.26.which will improve the performance of the game. Try to download and install it. it will give you slight more frame gain while playing the game.

  4. #4
    Join Date
    May 2008
    Posts
    4,041

    Re: Crysis 2 not performing well on directx 11 ultra settings

    I have crysis 2 and also applied patch 1.9 on it. After that when I tried to run the game on the ultra settings it is giving the problem. The game is lagging while playing which never happens to game before. So I have used the gpuz utility to check actually what the problem is. So when I cheked it is happening due to vram memory. It is using my graphics card complete vram memory which is 1 gb. So the game requires more memory while using the directx 11 in ultra setting.

  5. #5
    Join Date
    Aug 2009
    Posts
    2,881

    Re: Crysis 2 not performing well on directx 11 ultra settings

    This problem occurs with me also while using the ultra setting at high resolution .I am having the Nvidia Gtx 580 graphics card .so I have lowered the resolution and I am getting higher frames while playing. Also turned on the vsync which also improved the performance of the game. Try to lower the resolution it will help you to improve the performance and yes the game hogs vram memory completely so if you want to play game perfectly try to play it on high setting.

  6. #6
    Join Date
    Apr 2009
    Posts
    3,977

    Re: Crysis 2 not performing well on directx 11 ultra settings

    I am having crysis 2 steam version. And game was patched automatically few days back. And after update I have also used the setting ultra high. When first time I have run the game at this setting it is causing the problem. So I have done this settings in ultra high which makes my game running perfectly now. Do this settings make dx11 on and make high resolution texture off and also turn on vsysnc . And save the settings and turn off the game and start it. I am sure the game will give good frame rate while playing.

  7. #7
    Join Date
    Aug 2009
    Posts
    3,799

    Re: Crysis 2 not performing well on directx 11 ultra settings

    Yes the ultra high settings causing the frame rate to get lowered. Since I am also running the game on the ultra high settings since my graphics card supports direct x 11. I tried to come of the problem by doing this which helps me to improve the game performance in frame rates. So keep the setting to ultra high but disable the shadows or try to lower it to the medium or low. Also enable vsysnc and disable the high resolution texture. When I have done this I about 10 to 15 frames improvement in the game.

Similar Threads

  1. Bad performance of Crysis 2 using DirectX 11
    By Egmont in forum Video Games
    Replies: 9
    Last Post: 05-09-2011, 10:46 PM
  2. Enabling DirectX 10 on Crysis 2 Beta
    By OCTAVE in forum Video Games
    Replies: 6
    Last Post: 08-04-2011, 10:35 AM
  3. DirectX 9 and DirectX 10 support for crysis 2
    By The$Tourist in forum Video Games
    Replies: 5
    Last Post: 26-03-2011, 10:39 AM
  4. Directx 11 patch for Crysis 2
    By Innocent User in forum Video Games
    Replies: 5
    Last Post: 25-03-2011, 10:11 AM
  5. how to play crysis 2 beta in directx 11
    By Cappuccino in forum Video Games
    Replies: 3
    Last Post: 20-02-2011, 02:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •