Go Back   TechArena Community > Technology > Video Games
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Disabling Steam In-Game in Non-Steam games

Video Games


Reply
 
Thread Tools Search this Thread
  #1  
Old 03-07-2011
Member
 
Join Date: Jun 2011
Posts: 13
Disabling Steam In-Game in Non-Steam games
  

I am having some problem in disabling the Steam In-Game. I searching for the solution from long time and have not found any solution for it. In Steam games, the In-Game overlay can be disabled very easily from the Steam properties. But there is no such benefit for the non-steam games. The only solution that I have got is to completely disable the Steam in-game which is much more irritating. Can anyone help me to find a proper solution for it? Is there any command or anything else that can disable in-game steam overlay?

Reply With Quote
  #2  
Old 03-07-2011
Member
 
Join Date: Nov 2008
Posts: 3,952
Re: Disabling Steam In-Game in Non-Steam games

Even I am having the Steam In-game, and sometimes I really need to disable the steam Overlay for some of my games. It is very easy to do this and not of much difficulties. All you need to do is just go to the Steam library and then right click on the game that you are having and go to the properties option. In the properties window you can find the Enable Steam Community in-game and then uncheck on it. This will really help you out.
Reply With Quote
  #3  
Old 03-07-2011
Member
 
Join Date: May 2009
Posts: 3,613
Re: Disabling Steam In-Game in Non-Steam games

I have not tested myself but heard that you can do this in few simple steps. When you open the steam window, you need to go to the settings option and in that you will find the In-game potion. All you need to do is just remove the tick mark from the Enable Steam Community In-Game. This must probably disable the in-game overlay from all the games that are non-Steam games. So I think this is the only method that you can do
Reply With Quote
  #4  
Old 03-07-2011
Member
 
Join Date: May 2008
Posts: 4,041
Re: Disabling Steam In-Game in Non-Steam games

Hey but if you are using the non-steam games then this property is not available in those games. So every time you just need to enable/disable the overlay option. But you can disable the in-game steam overlay just by going to the registry value of the EnableGameOverlay. You can find the registry value from the location:
Code:
HKEY_CURRENT_USER\Software\Valve\Steam\Users\<user number>\system
.
Once you get the registry open the appropriate file and then change the value to zero for disabling it.
Reply With Quote
  #5  
Old 03-07-2011
Member
 
Join Date: Apr 2009
Posts: 3,968
Re: Disabling Steam In-Game in Non-Steam games

I would be agreed with option but, for launching many of my applications like 3DSMAX, Unity, and Visual Studio and many other applications I use Steam and also for many of my games. And I like the option that is there for disabling overlay for the in-game community as per the game that I play. I just untick the Enable Steam Community In-Game option as some of the games that uses multiple view ports does not work well.
Reply With Quote
  #6  
Old 03-07-2011
Member
 
Join Date: Jun 2009
Posts: 3,859
Re: Disabling Steam In-Game in Non-Steam games

I have seen many of the games that does not support the Steam overlay option. It is odd for the games that really run on the steam and cannot get disable them. But the games that are not from the Steam will not be able to disable this overlay option. So it really a question that how can one change the steam overlay for the games that non-steam games. I have no idea about, how to disable the overlay for the games that are not form steam.
Reply With Quote
  #7  
Old 06-07-2011
Member
 
Join Date: Jun 2011
Posts: 13
Re: Disabling Steam In-Game in Non-Steam games

Thanks to everyone for their response. I was really disappointed with disabling the steam overlay for non-steam overlay games. I just tried to change the value of the EnableGameOverlay from the registry folder to zero and it really helped me out. So I think anyone else who is facing the same problem can try this method, this really worked for me.
Reply With Quote
Reply

  TechArena Community > Technology > Video Games
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Disabling Steam In-Game in Non-Steam games"
Thread Thread Starter Forum Replies Last Post
“Steam is having trouble connecting to the steam servers” error message while login to steam Kedar!nath Video Games 5 03-01-2012 10:32 AM
Which one is a better retail game or steam games or games for windows live? Farzana Video Games 7 07-07-2011 10:32 PM
Error playing game: Steam is not running. You must start steam in order to play this game Harin$Akshi Video Games 6 06-07-2011 09:21 PM
Getting Error message‘Disconnect: This Steam account does not own this game. ‘On Steam Angee Video Games 6 05-07-2011 10:26 AM
Is Steam account Worth For Large Steam Game? Depo Video Games 4 03-12-2010 10:41 PM


All times are GMT +5.5. The time now is 11:28 PM.