Go Back   TechArena Community > Technology > Video Games
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Lord of the Rings Online OpenAL crashes under Vista x64

Video Games


Reply
 
Thread Tools Search this Thread
  #1  
Old 15-04-2011
Member
 
Join Date: Feb 2011
Posts: 69
Lord of the Rings Online OpenAL crashes under Vista x64
  

Hi all, I want to know if Creative is aware of this problem. The game The Lord of the Rings Online hangs when using OpenAL mode in Windows Vista x64. The most common error message is a blue screen with PAGE_FAULT_IN_NON_PAGED_AREA. Here are a couple of links in the forum: This one comes from the European forums, and this is from the U.S. forums. All people are using Windows Vista x64 and X-Fi card, the game makes the whole operating system crash. By switching to software sound, all accidents are gone. It happens to PCI and PCI Express X-Fi cards, with the two CPU cards from ATI or nVidia, Intel or nVidia chipsets, Intel or AMD.

Reply With Quote
  #2  
Old 15-04-2011
Member
 
Join Date: Jun 2009
Posts: 3,960
Re: Lord of the Rings Online OpenAL crashes under Vista x64

Lord of the Rings Online supports X-RAM, but not the cause. I've tried beta drivers for Unreal Tournament III and I have disabled X-RAM in the registry, but I still have accidents. Accidents are more frequent from the mines of Moria expansion. None of the turbine (game developers) and Codemasters (European managers) has posted anything but I wonder if they are in contact anyone here and whether they are aware of this annoying problem. We have to play with the stereo software, for now, that's the only way the game is not locked.
Reply With Quote
  #3  
Old 15-04-2011
Member
 
Join Date: Jun 2009
Posts: 3,859
Re: Lord of the Rings Online OpenAL crashes under Vista x64

You have Vista x64 with SP1 and there's nothing X-Fi accidents and LOTRO? What X-Fi card you have. What version of drivers? Are you running DX9 and DX10? The two tracks I've posted before that are full of people with that problem. By the way accidents are much more frequent since the Mines of Moria update, has played since the update? It also depends on the area, I played for 5 hours last week without an accident in Eregion, and as soon as I entered Moria I fell in less than 10 minutes. It seems that the insides of mine accidents are much more frequent, especially when done on horseback (goat), travel or the ability to travel fast hunter.
Reply With Quote
  #4  
Old 15-04-2011
Member
 
Join Date: Nov 2008
Posts: 3,952
Re: Lord of the Rings Online OpenAL crashes under Vista x64

I am having same problem. Until the mines of Moria release update without problems, now BSOD within 15 minutes. up to 4 hours. More frequently in memory of Eriador and the instant when fasttravelling to densely populated areas in the country. I would like to see a creative work together with the turbine and Codemasters to solve this problem. There have been problems with creativity and lord of the rings from the first version of the game so far; some problems solved by driver updates creative, others by the lord of the rings online data updates. I think the only way to find a solution is if you help turbine creative because it definitely does not seem to know how to get GAMESOUND work correctly in your sound card X-Fi.
Reply With Quote
  #5  
Old 15-04-2011
Member
 
Join Date: May 2009
Posts: 3,613
Re: Lord of the Rings Online OpenAL crashes under Vista x64

So the driver tried beta and seems to be working with Lotro? Did you disable XRAM well? No problem brother. Indeed, the response of the leadership team put me in one of the author's research. I put on the thread of UT3. Here is the link. Beta driver applies to any game that supports OpenAL X-RAM. However, if you still have problems, even after using the beta driver? Anyway, I've sent this issue and am awaiting a response. I'm leaving.
Reply With Quote
  #6  
Old 15-04-2011
Member
 
Join Date: Aug 2009
Posts: 2,880
Re: Lord of the Rings Online OpenAL crashes under Vista x64

Yes, I installed the beta driver and disabled X-RAM and the problem still happens (twice to verify that it was disabled with OpenAL viewer tapas). The Lord of the Rings Online accident is not related with X-RAM, because if you look at the two issues linked in first post happens to users of any X-Fi card, with or without X-RAM. Do you know if the turbine is in contact with the pilot of the creative team and are aware of the problem?
Reply With Quote
  #7  
Old 16-04-2011
Member
 
Join Date: May 2008
Posts: 4,041
Re: Lord of the Rings Online OpenAL crashes under Vista x64

I do not know the time it was just luck or the service pack that was held yesterday by the turbine actually solved anything in regard to this issue, but last night played six hours straight, without any BSOD with sound hardware mode, I haven 't been for a couple of weeks. It also did not experience any lag at all. I'll probably be playing all weekend so it will be a good test.
Reply With Quote
Reply

  TechArena Community > Technology > Video Games
Tags: , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Lord of the Rings Online OpenAL crashes under Vista x64"
Thread Thread Starter Forum Replies Last Post
The Lord of the Rings: War in the North Crashes at Barrow Downs Tawnie Video Games 3 13-11-2011 06:29 PM
Why to have class other than RK in The Lord of the Rings Online: Rise of Isengard? Small!Earth Video Games 8 03-10-2011 07:37 AM
About Lord of the rings Online Leslie f Video Games 4 01-09-2011 12:11 AM
XFX Radeon HD4670 for Lord of the rings online aFRODITA Monitor & Video Cards 3 14-12-2010 07:51 PM


All times are GMT +5.5. The time now is 07:49 PM.