Go Back   TechArena Community > Technology > Video Games
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Dragon Age 2 error "failed to initialize Physx"

Video Games


Reply
 
Thread Tools Search this Thread
  #1  
Old 11-03-2011
Member
 
Join Date: Feb 2011
Posts: 110
Dragon Age 2 error "failed to initialize Physx"
  

I have recently started playing the dragon age 2 game on my laptop which is having the windows 7 operating system and also on the Intel core i3 processor. In the initial period the game was doing well and also was without any error associated with it. But now the case is different. Whenever I am playing this game I am getting the error message saying that "failed to initialize Physx" and the main thing is that this error creeps up in the start up of the game and which is very much irritating so please let me know what I can do to solve the issue here .

Reply With Quote
  #2  
Old 11-03-2011
Member
 
Join Date: May 2009
Posts: 1,080
Re: Dragon Age 2 error "failed to initialize Physx"

Well the error that you are getting is the most common error associated with any ne and if you have to solve this one then you have to just see whether the installable PhysX is installed properly on your system and if you find anything fishy there then you have to just make sure that whether you are able to uninstall it if yes then immediately uninstall the PhysX and then you have to install it back I hope that doing this will definitely help you to solve the issue and then you will be able to play the game.
Reply With Quote
  #3  
Old 11-03-2011
Member
 
Join Date: Jul 2009
Posts: 1,113
Re: Dragon Age 2 error "failed to initialize Physx"

Actually the error clearly says that you are unable to start the game since the system is failing to initialize the PhysX and if this is the case then what I want you to do here is that just try and uninstall the same and see how it goes and if doesn’t work then you have to install a software called driver Sweeper. You have to search in Google the same and then download it from the original site and then make the appropriate installation. And I hope that doing the same will definitely remove the error out of the equation and will allow you to get rid of the problem that you are facing.
Reply With Quote
  #4  
Old 11-03-2011
Member
 
Join Date: Jul 2009
Posts: 1,174
Re: Dragon Age 2 error "failed to initialize Physx"

Well I tried both methods and I have the game to start after reinstalling the drivers for NVIDIA PhysX and both the new version and the one that camewith the game. But only starts on the first play and when you exit the game immediately has the error again forcing me to uninstall and reinstall the PhysX driver only to run the game again - both display solutions have only been a temporary solution me and not solve the problem permanently. I'm running the game through Steam 64-bit Windows 7. If anyone finds a permanent solution please let me know. Once again I have tried everything up to date and drivers and the drivers that came with the game.
Reply With Quote
  #5  
Old 11-03-2011
Member
 
Join Date: May 2008
Posts: 1,304
Re: Dragon Age 2 error "failed to initialize Physx"

As said by you that you have started to play the game and initially there was no problem, and also the two basic provided solutions also din worked for you and to solve this what you have to do in this case is that just uninstall the game itself and then you have to install the game back on the system and see hoe it goes. I am sure that if you are able solve the issue and then you will be definitely able to have a control on the game without the err messages that you are getting.
Reply With Quote
Reply

  TechArena Community > Technology > Video Games
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Dragon Age 2 error "failed to initialize Physx""
Thread Thread Starter Forum Replies Last Post
error "Failed to Initialize Engine" when starting Dark Game Forever Video Games 3 08-07-2013 12:53 PM
"failed to initialize renderer" error in Skyrim sfr020 Video Games 3 05-05-2012 03:43 AM
getting "failed to initialize renderer" error while playing Skyrim through bootcamp Euansmith Video Games 4 05-05-2012 02:28 AM
"Failed to initialize the physics system. Please ensure you have an updated... " error while launching Mass effect 3 demo Arup Singh Video Games 3 22-02-2012 09:44 AM
getting "PDF Library failed to initialize" error adobe CS4 Oriole Windows Software 2 12-11-2011 10:10 PM


All times are GMT +5.5. The time now is 12:42 PM.