Go Back   TechArena Community > Technology > Video Games
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Dead Space 2 PC Multiplayer issue with NAT Type :Strict

Video Games


Reply
 
Thread Tools Search this Thread
  #1  
Old 28-01-2011
Member
 
Join Date: May 2008
Posts: 255
Dead Space 2 PC Multiplayer issue with NAT Type :Strict
  

Hello my friends , I just started playing DeadSpace 2 a few days back , tll date I was playing in the single player mode , but now I wish to play in the dual player mode , but for some reasons I am not able to do this I can not play DS2 multiplayer .the game demonstrate "Your NAT Type : Strict" on the screen. When I search the quickmatch it for all time states like "Failed to join quickmatch", "You has lost connection from lobby" .And I attempt to obtain support from support.ea.com for help but nothing on it , Please tell me how I can get my issue resolved , I do not want to play in single mode any more.

Reply With Quote
  #2  
Old 28-01-2011
Member
 
Join Date: Jun 2009
Posts: 3,859
Re: Dead Space 2 PC Multiplayer issue with NAT Type :Strict

You were successfully able to play it while you were playing it in the single mode but somehow were unable to play it online , and l as you said that your games belong to EA games , these manufacturers , I believe are best in the business , I think they will have the exact solution for your issue , os if you ask me rather than going anywhere for help you should ask the EA Games for further assistance , either you can visit their website or you can call them directly and explain your core issue in order to get your issue resolved . Anyways thank you for posting your question in our forum. I think this was a little bit of help for you, please post bck your comments as well .
Reply With Quote
  #3  
Old 28-01-2011
Member
 
Join Date: Aug 2009
Posts: 3,764
Re: Dead Space 2 PC Multiplayer issue with NAT Type :Strict

Well I think I can provide you a solution for this issue , as you had said that you your NAT type was Strict , if you do it open , you will be able to play multiplayer mode and get your desired results , if ayou have a router and have just enable the NAT settings from Strict to Open:-
  • You will have to Log into router's IP address (192.168.1.1) and there enter the credentials . Choose "Advanced Setup".
  • Click on Advanced that will be in the left hand menu and choose from that menu UPnP
  • All three boxes in that window should be checked and click on Apply
  • Shut router configuration window and then give it a try again , I think your issue will get resolved .
Reply With Quote
  #4  
Old 28-01-2011
Member
 
Join Date: May 2009
Posts: 1,945
Re: Dead Space 2 PC Multiplayer issue with NAT Type :Strict

Well I had the same issue when I was playng with my Xbox system . so think but this issues and their resolutions are all and the same , no matter what the make of the console be. There are generally four techniques to defeat a Strict/Moderate NAT setting when making use of a router. I am not aware of all of them though I have not shown all of them but there is certain order of preference:If you have an router, make use of the certified firmware for your router
Reply With Quote
  #5  
Old 28-01-2011
Member
 
Join Date: May 2009
Posts: 2,103
Re: Dead Space 2 PC Multiplayer issue with NAT Type :Strict

This issue is regarding thexbox as well but I am quite sure it will work with Sony’ s PS3 Make use of UPnP. If your router supports this. Switch it on. The router will function the ports it requires to open for Xbox live. If your router does not contain this characteristic, verify the manufacturers website for the latest firmware. (also ensure portforwarding and/or DMZ is switched off as they obstruct with UPnP)Make use of a DMZ (De-militarized Zone).The DMZ (De-militarized Zone) is area that remains outside of your routers firewall. Do not be anxious though your not at threat with your gaming console .
Reply With Quote
  #6  
Old 06-03-2012
Member
 
Join Date: Mar 2012
Posts: 1
sad Re: Dead Space 2 PC Multiplayer issue with NAT Type :Strict

I got same issue with the dead space 2 multiplayer. I have same story as nat type strict and searched up on the internet how to fix that issue, followed the steps and etc still no succes (lost connection, failed t join a match, couldnt find quick match and so go on) I tried everything. And most anoying of all is next: That when i enter the lobby i wait for players for more then 20 mins and i finaly get in the game and bam connection lost. Not to mention that when i enter a game room with 4 players of lvl 60 against 2 or 3 ppl including me who are lvl 5 or 1 the game doesnt shows any connection lost. Its like a curse XD. Well never mind does anyone have solution? I opened even the UPnp so i am out of solutions. Someone any ideas? And sorry for long post. Its 5th day like this and it only get worse ... ps its on xbox 360

Last edited by vova1tessie : 06-03-2012 at 10:09 AM. Reason: forgot to write gamingplatform
Reply With Quote
Reply

  TechArena Community > Technology > Video Games
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Dead Space 2 PC Multiplayer issue with NAT Type :Strict"
Thread Thread Starter Forum Replies Last Post
Dead Space 2: how to start multiplayer Coin DR Video Games 7 18-02-2011 04:28 PM
Dead Space 2 xbox freezing issue Arram Hoin Video Games 5 31-01-2011 05:17 PM
Dead Space 2 is Unbalanced in Multiplayer Fragman Video Games 4 29-01-2011 02:04 AM
Dead Space 2 PC release control issue NathanDS Video Games 4 29-01-2011 12:56 AM
Dead Space 2 - Register EA Account With Iphone Dead Space App and get power node question Brunoz Video Games 4 28-01-2011 10:03 PM


All times are GMT +5.5. The time now is 03:42 PM.