Results 1 to 8 of 8

Thread: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

  1. #1
    Join Date
    May 2010
    Posts
    8

    Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    hey fellas , i had completed assassin's creed 2 with the help offline server emulater n updated values.db file. as my exams r over now i want to play this game again . now i'm facing a weird problem. i Formated my PC a week ago, n yesterday i installed AC 2 again . i installed this game in D drive. problem is , at first UBISOFT folder was not installed automatically in c:/programfiles . so i installed it manually from d CD. and now d offline SERVER.EXE is not working . i'm getin an error message sayin "application failed to start because d application configuration is incorrect " . please help me out .. THANK YOU
    Reply With Quote

  2. #2
    Join Date
    Apr 2008
    Posts
    2,470

    Re: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    I think that you need to install the microsoft visual c++ 2005. Download it from here. At the time of installation, you will need to disable any antivirus software that you might be using at your computer. Also install the latest Microsoft .Net Frameworks.

  3. #3
    Join Date
    Feb 2009
    Posts
    455

    Re: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    Thats correct Hitman22. I was also having the same problem on my system and after installing Redistributable Package Microsoft Visual C + + 2005 SP1, it just sorted out. It installs runtime components of Visual C + + Libraries required to run applications developed in Visual C + + on a computer on which Visual C + + 2005 is not installed.

  4. #4
    Join Date
    May 2010
    Posts
    8

    Re: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    thanks for ur replys... but problem still exist , i have d game ,but not able to play it's like hell on earth
    Last edited by pradeepoojary; 20-05-2010 at 10:54 PM.

  5. #5
    Join Date
    Mar 2010
    Posts
    20

    Re: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    Alright, did you install the microsoft packages? If you did install it then what error are you getting, can you post it here? I remember one thing that you have to edit some files to play Assassin's Creed 2 offline, its path was - C:\Windows\system32\drivers\etc - here you have to copy paste the below things:

    Code:
    2.127.0.0.1       static3.cdn.ubi.com
    3.127.0.0.1       ubisoft-orbit.s3.amazonaws.com
    4.127.0.0.1       onlineconfigservice.ubi.com
    5.127.0.0.1       orbitservice.ubi.com
    6.127.0.0.1       ubisoft-orbit-savegames.s3.amazonaws.com

  6. #6
    Join Date
    May 2010
    Posts
    8

    Re: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    yeah , i tired Redistributable Package Microsoft Visual C + +, it couldn't solve my problem. n i have followed d each n every step precisely while installing coz i have played this game before on d same PC. ERROR msg is "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem". i Freshly downloaded d emulator, but again , problem remains same.:
    Last edited by pradeepoojary; 21-05-2010 at 04:25 PM.

  7. #7
    Join Date
    May 2010
    Posts
    8

    Re: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    This is my Hosts file...
    Last edited by pradeepoojary; 21-05-2010 at 05:32 PM.

  8. #8
    Join Date
    Apr 2008
    Posts
    2,569

    Re: Assassin's Creed 2 error "application failed to start because application configuration is incorrect"

    You can fix this issue by going into the "application/bin/debug" and deleting all files there, again go into "application/bin/release" and delete all the files there as well, then just rebuild the project via rebuild application, and hopefully that will solve the issue for you.

Similar Threads

  1. Replies: 7
    Last Post: 07-04-2012, 07:25 PM
  2. Replies: 4
    Last Post: 07-04-2012, 07:19 PM
  3. Replies: 5
    Last Post: 31-12-2010, 03:53 PM
  4. Replies: 5
    Last Post: 23-03-2010, 06:58 PM
  5. Error "Application failed to start" by AVG on Windows XP
    By KAMAL60 in forum Networking & Security
    Replies: 3
    Last Post: 05-11-2009, 10:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •