Go Back   TechArena Community > Technology > Video Games
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Just Cause 2 lagging due to V Sync

Video Games


Reply
 
Thread Tools Search this Thread
  #1  
Old 25-03-2010
Member
 
Join Date: Feb 2006
Posts: 176
Just Cause 2 lagging due to V Sync
  

I have Windows 7 Home Premium installed on my pc and a good rig as well. Yesterday I bought Just Cause 2 from my local market. I installed in on my machine, all was well, but as soon as I try to play this game I get a tremendous lag on my setup. I think this render lag is caused by V Sync and I happen to figure this out that I had to fps set to 55 so that I can avoid the lag. How can I start this game with 55 fps automatically on my pc?

__________________
the longest journey begins with a single step
Reply With Quote
  #2  
Old 25-03-2010
Member
 
Join Date: Dec 2007
Posts: 2,260
Re: Just Cause 2 lagging due to V Sync

If you can search on google then you will def. get an idea about how to set the Maximum FPS for a game and there is a command line for it, try the below ones:

/frameratecap=<target_fps>, default: disabled
/failsafe Run in failsafe mode (ignore settings)
/fullscreen Fullscreen mode
/windowed Windowed mode
/width=n Width in pixels (fullscreen/windowed)
/height=n Height in pixels (fullscreen/windowed)
/widthFS=n Width in pixels (fullscreen)
/heightFS=n Height in pixels (fullscreen)
/widthW=n Width in pixels (windowed)
/heightW=n Height in pixels (windowed)
/msaa=n MSAA sample count
/vsync=b Enable/disable V-sync
/aniso=n Anisotropic filter (0-7, default: 7)
/shadows=n Shadow quality (0-2, default: 1)
/shadowres=n Shadow resolution (0-1, default: 0)
/ssao=b Enable/disable SSAO (default: disabled)
/hbao=b Enable/disable HBAO method for SSAO (default: enabled)
/plspec=b Enable/disable pointlight specular (default: disabled)
/posteffects=b Enable/disable posteffects (default: enabled)
/lodfactor=n Geometric detail (0-3, default: 0)
/decals=b Enable/disable decals
/edgefade=b Enable/disable edge fade effect
/filmgrain=b Enable/disable film grain effect
/fovfactor=, typical values 1.0 - 2.0 Changes the field of view, default is 1.0
/dxbuffers=, default: 1
/frameratecap=, default: disabled Allows you to cap your framerate at what every value you want.
/dxadapter= Allows those with multiple GPUs to force JC2 to use a specific device.
Reply With Quote
  #3  
Old 25-03-2010
Member
 
Join Date: Dec 2007
Posts: 1,719
Re: Just Cause 2 lagging due to V Sync

Try the Maximum FPS: Three Tips for Faster Code:

If you downloaded and looked at the sample code that accompanied the column, you may have noticed that I did some tricky stack allocations in the UpdateWorld function. This month I'm going to give details about cache alignment concerns which resulted in that code. Afterwards, we'll look briefly at something called 'store forwarding' and 'fast string moves' to round off the number of tips in this column to three. As usual, if you have comments or suggestions for topics you'd like to hear about in the future please drop me a line. Now let's get started with a little bit of alignment background information.

For more information, go to this original intel site: http://software.intel.com/en-us/arti...r-faster-code/
Reply With Quote
  #4  
Old 25-03-2010
Member
 
Join Date: Apr 2008
Posts: 2,459
Re: Just Cause 2 lagging due to V Sync

Below are the slash commands that can be used to limit maximum frames per second. Usually the maxfps command cannot change hardware with new speed rates. It is meant to put an upper limit on frame rate, if your machine can't generate more than 20FPS for a certain scene, changing the maxfps to 75 won't change that fact.

/console maxfps 75
/console maxfpsbk 20
Reply With Quote
  #5  
Old 25-03-2010
Member
 
Join Date: May 2008
Posts: 2,458
Re: Just Cause 2 lagging due to V Sync

Well basically, the maximum fps all depends on the display cause most of the displays these days go upto a max of 60hz which is actually 60 frames per second. However there are some monitors that you can get which supports display upto 85 HZ and there are also some old CRT monitors that supports 120HZ refresh rates. If you have 75hz display then it will not benefit 120 frames per second, it will only display 75 frames per second only.
Reply With Quote
  #6  
Old 25-03-2010
abishek
 
Posts: n/a
Re: Just Cause 2 lagging due to V Sync

It's probably an issue with the your graphic card (it can be with your system as well because it can be the only game that has this problem, or it calls something particularly special that others do not). You will have to wait for its patch to release then only you might be able to play this game without any issues. Try to update your video driver to the latest.
Reply With Quote
Reply

  TechArena Community > Technology > Video Games
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Just Cause 2 lagging due to V Sync"
Thread Thread Starter Forum Replies Last Post
Unable to Sync Contacts with Outlook 64bit using HTC Sync Manager The:afrodita Windows Software 5 23-07-2013 05:59 PM
Unable to sync iphone 4 due to sync session failed to finish Nabhanyu Portable Devices 2 03-09-2011 03:56 AM
Windows Live Sync beta blends the best of Sync and Mesh Fox28 Windows Software 3 17-08-2010 06:26 AM
Sync Center won't sync to Windows Mobile PDA/cell phone Bruce Wilkinson Vista Help 5 13-03-2007 02:46 PM


All times are GMT +5.5. The time now is 10:41 PM.