Go Back   TechArena Community > Technology > Video Games
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 08-07-2009
Member
 
Join Date: Jan 2009
Posts: 84
8-bit paletted textures problem while playing Final Fantasy 7

I read somewhere in the blogs that the most recent drivers, along with Dx8 finally support 8-bit paletted textures, this is because I recently installed the computer version of Final Fantasy 7 on my computer. After I tried to run the game, it immediately closed itself and brought up the FF7 Configuration tool. but i am getting an error message that the test for "8-bit paletted textures" failed. When I start game, I only able to see black screen. when I click enter I can see this starting screen with Cloud's sword and "New Game" and "Continue", but if I select "New Game" it's just a black screen again.

Does anybody know how to resolve this problem so I can start playing the game?
Reply With Quote
  #2  
Old 08-07-2009
Member
 
Join Date: Nov 2008
Posts: 63
Re: 8-bit paletted textures problem while playing Final Fantasy 7

I have also the same problem but i solve the same by asking all others who have already completed that game on some forums and the solution to that is installing the Direct Media... it comes with FF7 installer. It's the only way I found to be able to see the movies encoded with some no longer supported codec.
Reply With Quote
  #3  
Old 08-07-2009
Member
 
Join Date: Apr 2009
Posts: 51
Re:Custom resolutions and 8-bit paletted textures fix (patch)

I have played FF7 game but it isn't my favorite game, but some patches are there which is great. Great job Aalim.

I have x800XT, FSAAx16 and AFx8 it works very well. but the problem occurs here where i met with some corrupted graphics displayed on the black bands on the upper and lower part of the screen during movies and the backgrounds show some little cuts here and there, but nothing very noticeable.
Reply With Quote
  #4  
Old 08-07-2009
Member
 
Join Date: Feb 2006
Posts: 90
Re: 8-bit paletted textures problem while playing Final Fantasy 7

You need to download the FF7 or you would need to download the TNT patch from eidos to get hardware acceleration to work. But then FF7 doesn't work on Win2k. I don't need the support to play the game, but the graphics suck even more than they do with a Voodoo 3.I don't think FF8 need the 8bit pallet, anyway.And the Problem with FF8 is that it doesn't layer the backdrops correctly with today's video drivers/cards. You'll probably see black squares around everything. or it will just look freaky. Software mode is the only thing that works in FF8.
Reply With Quote
  #5  
Old 13-08-2010
Member
 
Join Date: Aug 2010
Posts: 4
Re: 8-bit paletted textures problem while playing Final Fantasy 7

Quote:
Originally Posted by Aalim View Post
I have also the same problem but i solve the same by asking all others who have already completed that game on some forums and the solution to that is installing the Direct Media... it comes with FF7 installer. It's the only way I found to be able to see the movies encoded with some no longer supported codec.
Could you tell me how to solve the sound and palette problem on FF VII for PC? I think I installed direct media or whatever you called it, but the graphics still look worse than the one on Playstation 1. and the sounds and music don't sound very good.
Reply With Quote
  #6  
Old 13-08-2010
Member
 
Join Date: Jun 2009
Posts: 413
Re: 8-bit paletted textures problem while playing Final Fantasy 7

First of all make sure that your system meets the following requirements to make FF7 work perfectly:
  • Video Memory: 2 MB VRAM
  • Sound Card: DirectX 5.0 compatible
  • Video Card: 3dfx Voodoo, 3dfx Voodoo 2, 3dfx Voodoo Rush, 3Dlabs Permedia 2, ATI Rage Pro, Intel i740, Power VR Extreme
  • Graphics Type: SVGA
  • Graphics Resolution(s): 320 x 200, 640 x 480
  • Software (DirectX 5.0, etc.): DirectX 5.0

This is the minimum requirements for the game. If it is not than there is possibilities to get problems you are facing.
Reply With Quote
  #7  
Old 13-08-2010
Member
 
Join Date: Aug 2010
Posts: 4
Re: 8-bit paletted textures problem while playing Final Fantasy 7

I don't think i hvae the exact sound or graphics card you listed, but i bet mine beat the ones you listed. I think the issue is that you need the EXACT one to make the sound and graphics look better. And i mean that the sound is fine, but probably not as good as the ps1 sound.
Reply With Quote
  #8  
Old 13-08-2010
Member
 
Join Date: May 2008
Posts: 2,453
Re: 8-bit paletted textures problem while playing Final Fantasy 7

What is your computer specfications? You can try disabling Direct 3d in directX It Should Show 8-bit paletted textures test A Pass And everthing else a fail.. but Dont worry SHould Work Perfectly for in Game Play. You can also try downloading the Final Fantasy VII Patch from here which will def. resolve the issue that you are facing.
Reply With Quote
  #9  
Old 13-08-2010
Member
 
Join Date: Aug 2010
Posts: 4
Re: 8-bit paletted textures problem while playing Final Fantasy 7

Quote:
Originally Posted by mario2 View Post
What is your computer specfications? You can try disabling Direct 3d in directX It Should Show 8-bit paletted textures test A Pass And everthing else a fail.. but Dont worry SHould Work Perfectly for in Game Play. You can also try downloading the Final Fantasy VII Patch from here which will def. resolve the issue that you are facing.
How do i disable direct 3d in directx? I mean the exact steps to do that. I am running the game under Windows XP, if that information is important.
Reply With Quote
  #10  
Old 14-08-2010
Member
 
Join Date: May 2008
Posts: 2,453
Re: 8-bit paletted textures problem while playing Final Fantasy 7

Quote:
Originally Posted by OmegaWeapon View Post
How do i disable direct 3d in directx? I mean the exact steps to do that. I am running the game under Windows XP, if that information is important.
Click Start choose Run and type regedit to open your registry and find or create the key below:
HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ DirectDraw

Create a new DWORD value for each optional item from the list below and set it to "1" to enable the setting or "0" to disable it.

?DisableAGPSupport - Disable AGP support
?DisableMMX - Disable MMX processor extensions
?DisableWiderSurfaces - Disable Wider Surfaces support
?DisableInactivate - Disable dual-head video card debugging
?EnablePrintScreen - Enable Print Screen capture
?ModeXOnly - Use Mode-X for older video cards
?ShowFrameRate - Display the frame rate (if supported)
?DisableNoSysLock - Disable long-duration locks on video memory
?ForceNoSysLock - Force use of long-duration locks on video memory
?EmulationOnly - Enable software emulation layer for older video cards

Open the [ HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Direct3D ] key and change the value of DisableDP2 to "1" to disable Direct3D
Reply With Quote
  #11  
Old 15-08-2010
Member
 
Join Date: Aug 2010
Posts: 4
Re: 8-bit paletted textures problem while playing Final Fantasy 7

Quote:
Originally Posted by mario2 View Post
Click Start choose Run and type regedit to open your registry and find or create the key below:
HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ DirectDraw
Quote:
Originally Posted by mario2 View Post
Create a new DWORD value for each optional item from the list below and set it to "1" to enable the setting or "0" to disable it.

?DisableAGPSupport - Disable AGP support
?DisableMMX - Disable MMX processor extensions
?DisableWiderSurfaces - Disable Wider Surfaces support
?DisableInactivate - Disable dual-head video card debugging
?EnablePrintScreen - Enable Print Screen capture
?ModeXOnly - Use Mode-X for older video cards
?ShowFrameRate - Display the frame rate (if supported)
?DisableNoSysLock - Disable long-duration locks on video memory
?ForceNoSysLock - Force use of long-duration locks on video memory
?EmulationOnly - Enable software emulation layer for older video cards

Open the [ HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Direct3D ] key and change the value of DisableDP2 to "1" to disable Direct3D
I don't even know how to create the key. can u break it down for me and explain it in simple terms? Also, are you sure doing this won't damage my computer?
Reply With Quote
Reply

  TechArena Community > Technology > Video Games
Tags: , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "8-bit paletted textures problem while playing Final Fantasy 7"
Thread Thread Starter Forum Replies Last Post
Do you think Remakes of Final Fantasy is include the music of Final Fantasy VI midi tracks Kaesini Video Games 9 08-12-2011 11:06 AM
GTX 470 lags in Final Fantasy XI Isdel Video Games 5 17-05-2010 10:38 AM
Need some tips for playing Final Fantasy VIII Sandroo Video Games 5 18-03-2010 12:05 PM
Need some information on Final Fantasy X Maranello Video Games 3 06-10-2009 10:29 PM
Problem with Final Fantasy VIII TheDude01 Video Games 3 16-09-2008 03:31 PM


All times are GMT +5.5. The time now is 05:49 AM.