Results 1 to 2 of 2

Thread: Cisco Router Configuration Commands

  1. #1
    Join Date
    Nov 2005
    Posts
    2,327

    Cisco Router Configuration Commands

    Here is a compiled list of Cisco Systems router configuration commands you may use for later reference. If you know of more commands related to this list, please share.

    Set a console password to cisco
    Router(config)#line con 0
    Router(config-line)#login
    Router(config-line)#password cisco

    Set a telnet password
    Router(config)#line vty 0 4
    Router(config-line)#login
    Router(config-line)#password cisco

    Stop console timing out
    Router(config)#line con 0
    Router(config-line)#exec-timeout 0 0

    Set the enable password to cisco
    Router(config)#enable password cisco

    Set the enable secret password to peter.
    This password overrides the enable password and is encypted within the config file
    Router(config)#enable secret peter

    Enable an interface
    Router(config-if)#no shutdown

    To disable an interface
    Router(config-if)#shutdown

    Set the clock rate for a router with a DCE cable to 64K
    Router(config-if)clock rate 64000

    Set a logical bandwidth assignment of 64K to the serial interface
    Router(config-if)bandwidth 64
    Note that the zeroes are not missing

    To add an IP address to a interface
    Router(config-if)#ip addr 10.1.1.1 255.255.255.0

    To enable RIP on all 172.16.x.y interfaces
    Router(config)#router rip
    Router(config-router)#network 172.16.0.0

    Disable RIP
    Router(config)#no router rip

    To enable IRGP with a AS of 200, to all interfaces
    Router(config)#router igrp 200
    Router(config-router)#network 172.16.0.0

    Disable IGRP
    Router(config)#no router igrp 200

    Static route the remote network is 172.16.1.0, with a mask of 255.255.255.0, the next hop is 172.16.2.1, at a cost of 5 hops
    Router(config)#ip route 172.16.1.0 255.255.255.0 172.16.2.1 5

    Disable CDP for the whole router
    Router(config)#no cdp run

    Enable CDP for he whole router
    Router(config)#cdp run

    Disable CDP on an interface
    Router(config-if)#no cdp enable

  2. #2
    Join Date
    Jul 2009
    Posts
    1,179

    Re: Cisco Router Configuration Commands

    You might need to sometime configure hyperterminal. First, you need a console cable (RJ-45 to Serial) connecting the serial port of your computer to the RJ-45 marked "console" on your router. Next, open Hyper Terminal from Start Menu > All Programs > Accessories > Communications > Hyper-Terminal and enter a name for your new connection, select the serial port which is connected the console cable and click Default Settings then ok. Now you are connected to the router and from here you can configure.

Similar Threads

  1. "Cisco connect" cannot find Cisco Linksys E1200 router
    By $Iain$ in forum Networking & Security
    Replies: 5
    Last Post: 25-03-2012, 07:41 PM
  2. Cisco 1921 router vs. Cisco 1941 router
    By gMALI in forum Networking & Security
    Replies: 6
    Last Post: 22-07-2011, 07:29 PM
  3. How to restore default configuration of Cisco PIX 501 firewall
    By GeforceUser in forum Networking & Security
    Replies: 3
    Last Post: 15-05-2009, 12:18 PM
  4. Problem of Cisco 7920 VoIP phone on Cisco 870 router
    By Wguy2008 in forum Networking & Security
    Replies: 4
    Last Post: 30-11-2008, 11:35 AM
  5. Cisco router configuration?
    By envo diverter in forum Networking & Security
    Replies: 3
    Last Post: 22-11-2008, 12:20 AM

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Page generated in 1,714,111,256.14472 seconds with 17 queries