Go Back   TechArena Community > Software > Tips & Tweaks
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



"Registry editing has been disabled by your administrator" when you open the Registry Editor in Windows Vista Error Fix

Tips & Tweaks


Reply
 
Thread Tools Search this Thread
  #1  
Old 19-08-2008
Member
 
Join Date: Aug 2005
Posts: 434
"Registry editing has been disabled by your administrator" when you open the Registry Editor in Windows Vista Error Fix
  

When you try to edit the registry editor you may receive the following error:

Registry editing has been disabled by your administrator

This is because of some spyware program not allowing you to edit the registry or because of group policy. It is also possible that the DisableRegistryTools policy had been enabled by a third-party tweak program which you may be using. It's highly advisable to follow up with a complete system checkup for Virus and Malware, especially when you're unsure about the cause.

Note: If your system is connected to a domain, your network administrator may have enabled the DisableRegistryTools Policy setting. In that case, you'll need to contact the network administrator to relax this restriction, if need be.


Method 1 - Using Group Policy Editor
If you are using an edition of Windows Vista (Windows Vista Business, Enterprise and Ultimate editions) which includes the Group Policy Editor, follow these steps:
  • Click Start, type gpedit.msc in the Search box, and press ENTER
  • Go to the following branch:

User Configuration | Administrative Templates | System
  • Double-click Prevent access to registry editing tools
  • Set it as Not Configured

Important: If it's already set to Not Configured, set it to Enabled and click Apply. Then repeat the steps and revert the setting back to Not Configured. This removes the registry based policy if set already.


Method 2
This method should work in all editions of Windows Vista.
  • Download reg_enable.vbs attached at the end of this article, and save it to Desktop
  • Open an elevated command prompt. To do this, click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow.
  • Switch to your Desktop directory by typing the following command, and then pressing ENTER:

cd /d %userprofile%\desktop
  • Then, type the following command and press ENTER

wscript.exe reg_enable.vbs
  • Type EXIT to close the Command Prompt window.

If everything worked fine, the DisableRegistryTools policy should have been removed by now. See if you're able to launch Regedit.exe now.

Source: winhelponline.com

Reply With Quote
  #2  
Old 19-08-2008
Member
 
Join Date: Sep 2005
Posts: 1,443
Another solution for Registry editing has been disabled by your administrator
Reply With Quote
Reply

  TechArena Community > Software > Tips & Tweaks
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: ""Registry editing has been disabled by your administrator" when you open the Registry Editor in Windows Vista Error Fix"
Thread Thread Starter Forum Replies Last Post
Disable Registry Editor Editing Tool manishdk Tips & Tweaks 0 23-12-2008 06:24 PM
Enable the Registry Editor When Disabled by Administrator Flaco Tips & Tweaks 1 23-12-2008 12:47 PM
Editing the Registry for "other" Users Navman Tips & Tweaks 1 31-10-2008 01:44 PM
Cause of "Error: Registry Recovery. One of the files containing the system's Registry data had to be recovered maratha Windows XP Support 3 18-07-2008 12:09 PM
Registry editing has been disabled by your administrator Jahbriel Windows XP Support 2 18-04-2007 10:41 PM


All times are GMT +5.5. The time now is 12:06 PM.