Results 1 to 4 of 4

Thread: Removing websearch.homesearch-hub from google chrome

  1. #1
    Join Date
    Feb 2011
    Posts
    16

    Removing websearch.homesearch-hub from google chrome

    I am using Google Chrome as default web browser since long time. I have very few extensions installed in the browser, only the one i require much. Everything was working fine but dont know what happened, i got websearch.homesearch.hub installed in the chrome. Whenever i open any new tab, this is the page that loads. I tried to change it to Google.com which was set earlier, but when i restart the browser again it gets changed automatically from google to websearch.homesearch.hub.

    I even tried setting another blog page as home page, but the same thing happens, it gets changed on the restart. I have no idea left to get rid of this. Already tried everything i know about. Hope any of you guys can tell me the working method to get rid of websearch.homesearch.hub.

    Thank you.

  2. #2
    Join Date
    May 2009
    Posts
    1,611

    Re: Removing websearch.homesearch-hub from google chrome

    First of delete/uninstall the latest extension which you have downloaded because that might have bring some toolbar along with it as well. You need to check Windows Add and Remove as well as Chrome's extension as well. Remove all unknown installations. Restart the system and see if it still exists.

    Apart from this also follow these steps to change the default search Engine:
    • Open Chrome browser and click Menu > Settings.
    • Here click on "Manage search engines" under Search section.
    • Check if (Default) is displayed next to your preferred search engine. If not, mouse over it and click Make default.
    • Before saving the settings just delete any other search engines you can see in this list.
    • Save and restart the browser.

  3. #3
    Join Date
    Apr 2009
    Posts
    587

    Re: Removing websearch.homesearch-hub from google chrome

    I have been through this scenario earlier with my Chrome Browser. After lots of troubleshooting and research finally I found that the problem was due to an extension named as “FreeMake”. I don’t know from where it came but it was the culprit. I kept searching for stuffs named websearch.homesearch-hub but dint found anything. This is why we keep on troubleshooting but the problem remains with the browser. So what you need to do it go to Chrome > menu > Extension. Here you may find multiple listings of FreeMake. Just disable (uncheck) all. Now go to settings, under “Onstartup” section you will see websearch.homesearch-hub set as the option in “Open a Specific Page”. You need to click Set Pages > remove websearch.homesearch-hub > and type www.google.com.

    That’s it. Save the settings and restart the browser. You wont see websearch.homesearch-hub again.

  4. #4
    Join Date
    Feb 2011
    Posts
    16

    Re: Removing websearch.homesearch-hub from google chrome

    Quote Originally Posted by Santy View Post
    So what you need to do it go to Chrome > menu > Extension. Here you may find multiple listings of FreeMake. Just disable (uncheck) all. Now go to settings, under “Onstartup” section you will see websearch.homesearch-hub set as the option in “Open a Specific Page”. You need to click Set Pages > remove websearch.homesearch-hub > and type www.google.com.
    Wow, that did the trick. Where you have been so long. Thank you very much for sharing this useful info.

Similar Threads

  1. Removing isearch.avg.com from google chrome
    By Lustrous in forum Technology & Internet
    Replies: 5
    Last Post: 22-06-2013, 11:10 AM
  2. Replies: 5
    Last Post: 25-05-2011, 07:46 PM
  3. Replies: 4
    Last Post: 01-02-2011, 06:14 PM
  4. Replies: 2
    Last Post: 17-01-2011, 05:13 PM
  5. Google chrome error:chrome.exe Corrupt File
    By Camillee in forum Technology & Internet
    Replies: 5
    Last Post: 11-02-2010, 02:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •