Go Back   TechArena Community > Technology > Technology & Internet
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12

Technology & Internet


Reply
 
Thread Tools Search this Thread
  #1  
Old 29-04-2012
Member
 
Join Date: Apr 2012
Posts: 32
'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12
  

I am using the Firefox 12 now. From the past one hour I have been try to access the sites and every time it is showing me the same error. The error is ssl_error_rx_record_too_long. I have heard this error is getting on most of the browsers on all platforms with some particular site. There is no way I can reproduce the problem. The server is located in USA and I am trying to access it from India. When I search into Google I have found that the main reason for this problem is SSL port is speaking in HTTP. Does anyone know how to fix this problem and how can I reproduce it.

Reply With Quote
  #2  
Old 29-04-2012
Member
 
Join Date: Jan 2012
Posts: 84
Re: 'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12

It seems to me that you or your Firefox web browser has a misconfigured local proxy! What it indicates that the implementation of SSL on your server is improper. This is the server side problem, not the client side and you donít have to worry about it much. It is the serverís administrator job to find and fix this issue. You can try below things for now.
  • Make sure that the port 443 and enabled on server side because it is a standard port for https communications.
  • If the SSL needs to use non-standard port in that case FireFox shows error sometime. So you always have to make sure that SSL is running on port 443.
  • If you are using Apache2, then also make sure the same port. You can change this setting in ports.conf file
  • Also make sure that there is not more than one SSL certificate sharing the same IP. Each and every one SSL certificates use their own dedicated IP.
  • SSL certificate should not be expired
Reply With Quote
  #3  
Old 29-04-2012
Member
 
Join Date: Jan 2012
Posts: 112
Re: 'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12

Anyone who tries to make his Apache SSL-capable may encounter the above error message. The error message and then look at Mozilla brings one there on the wrong track. There, it states that: "SSL received a record that exceeded the maximum permissible length." This gene rally indicates that the remote peer system has a flawed implementation of SSL, and is violating the SSL specification. But the fault lies mostly in the configuration of Apache. We assume that a valid certificate with the appropriate Key meinZertifikat.crt meinKey.key in / etc/apache2/ssl lies.
Reply With Quote
  #4  
Old 29-04-2012
Member
 
Join Date: Oct 2011
Posts: 89
Re: 'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12

In fact, I had not read the original question. SSL is properly configured for the IP of the other 2 names via dedicated VH. But, like apache listening on port 443 for all IP (Listen = 443 listens on port 443 on all Server IP), including that for which it should not, Apache accepts the connection but not HTTPS, HTTP or SSL conf with incomplete, that Firefox does not expect to encounter. The correction is simple: instead of putting a single Listen 443 is put
  • Listen IP2: 443
  • Listen IP3: 443
Reply With Quote
  #5  
Old 29-04-2012
Member
 
Join Date: Jan 2011
Posts: 172
Re: 'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12

This problem should be "File does not exist: / htdocs" with the messages "Invalid method in request \ x16 \ x03 \ x01" pair in the logs, there is a vhost mapping problem and the vhost configuration shown here helps zero. It is not very meaningful, but seeing as I struggled to find where the problem was, I try to benefit others. My problem was that in my conf virtualhost with SSL I put the public IP, since it is the only server in the DMZ and that any returns above. I thought the firewall transparent with respect to apache. I was wrong. We must put the IP on the LAN, as seen by the NIC itself. After, it will immediately better.
Reply With Quote
  #6  
Old 03-05-2012
Member
 
Join Date: May 2011
Posts: 95
Re: 'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12

Test switch in the settings of the webs first web ssl-free and then have a new ride at the ssl. Since then everything will be queried. But remember for ssl website need ne extra-ip. You can easily create the certificate on ISPConfig as nothing more needs to be signed. The above error occurs if the certificate were entered characters that could not handle opensl. Make sure please that you are using any special characters and then re-create the certificate in ISPConfig. That takes a little way, then wait again for a few minutes before.
Reply With Quote
Reply

  TechArena Community > Technology > Technology & Internet
Tags: , , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "'ssl_error_rx_record_too_long' error while opening Google+ in Firefox 12"
Thread Thread Starter Forum Replies Last Post
Google Search pages not opening in Firefox 12 Mahinder Nagarkar Technology & Internet 1 27-04-2012 06:08 PM
Getting run error while opening Firefox 6 crook Technology & Internet 5 20-08-2011 11:27 PM
Website not opening with Firefox but open with Google chrome Tees Mar KH Technology & Internet 4 10-04-2011 08:25 AM
Error ssl_error_rx_record_too_long when accessing default SSL page Nimmi Mathen Networking & Security 4 17-06-2010 05:50 PM


All times are GMT +5.5. The time now is 03:20 PM.