Go Back   TechArena Community > Technology > Technology & Internet
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Silverlight is installed but not running on web pages

Technology & Internet


Reply
 
Thread Tools Search this Thread
  #1  
Old 17-04-2011
Member
 
Join Date: Mar 2011
Posts: 49
Silverlight is installed but not running on web pages
  

Hi I am running windows vista in my computer with silverlight installed in my system. I have noticed this particular problem whenever I visit few webpage on internet using Internet Explorer. If the webpage requires silverlight to run a particular video then I am unable to run that. I always get a prompt to ?download Silverlight? and when I follow the instructions to install it, I get the message ?Unable to Install Silverlight?. This thing is really annoying me now. Does anyone have got any idea regarding this problem? Please help me.

Reply With Quote
  #2  
Old 17-04-2011
Member
 
Join Date: Nov 2009
Posts: 862
Re: Silverlight is installed but not running on web pages

Check whether you are facing the same problem when you visit those web pages using some other web browsers like Google Chrome, Mozilla Firefox. If you face the same problem then you must probably uninstall the Silverlight from your system and reinstall a fresh setup of it. Download the latest available version of Silverlight from the official website of Microsoft and install it in your system. Restart your system once you have completed reinstallation of Silverlight. And if the problem is only with Internet Explorer than you should uninstall the current version of it from your system and install the latest available version of Internet Explorer. These are the two possibilities according to me which can solve your problem.
Reply With Quote
  #3  
Old 17-04-2011
Member
 
Join Date: Jun 2009
Posts: 758
Re: Silverlight is installed but not running on web pages

You can solve the issue by manually deleting the following old Typelib registry keys from the registry.

HKCR, Typelib\{283C8576-0726-4DBC-9609-3F855162009A}.8
HKCR, Typelib\{283C8576-0726-4DBC-9609-3F855162009A}.8.5.0
  • Go to Start > Run.
  • Type regedit on the text field and hit enter.
  • Go to the following locations and delete these two registry entries. You can enter the directory by clicking on the plus (+) sign next to the name of the folder:
    HKLM, SOFTWARE\Classes\Typelib\{283C8576-0726-4DBC-9609-3F855162009A}.8
    HKLM, SOFTWARE\Classes\Typelib\{283C8576-0726-4DBC-9609-3F855162009A}.8.5.0
  • Once you are done deleting them, close the registry editor and restart your system.
Reply With Quote
  #4  
Old 17-04-2011
Member
 
Join Date: Feb 2008
Posts: 624
Re: Silverlight is installed but not running on web pages

According to me you are having some add-ons issue with your Internet Explorer. Start the Internet Explorer and go to Tools and then click on Manage Add-ons. You should disable all the add-ons and check whether you are still facing the same problem or not. If after disabling add-ons your problem is solved, then it is confirmed that some add-on must be hampering the silverlight performance. Now enable add-on one by one and keep checking on which add-on the problem arises. Once you are confirmed about the particular add-on creating trouble for you, enable the others except that one and restart your browser as well as your system.
Reply With Quote
  #5  
Old 17-04-2011
Member
 
Join Date: Nov 2009
Posts: 620
Re: Silverlight is installed but not running on web pages

I had also faced this problem few times back. I tried solving the problem in every possible ways, by applying every other solution given above an on other web sites but nothing worked for me. Then after searching the Internet for many days to search for a perfect solution to solve this issue I came across this small step, which did the magic for me and payed off all my efforts. What I did was just set my Security settings in Internet Explorer to the default level. You can do that by navigating to the following path.
  • Start your internet Browser.
  • Select Tools and click on Options.
  • Now under Security tab click on ?Reset all zones to default level?.
  • This would disable the ActiveX controls.
Reply With Quote
  #6  
Old 19-04-2011
Member
 
Join Date: Nov 2009
Posts: 610
Re: Silverlight is installed but not running on web pages

I also had this irritating problem a while back and nothing seems to have worked for me. But then after reading and searching for the proper solution on Internet, I came across the fact that Silverlight is not supported by 64 bit version of Internet Explorer and it works only with the 32 bit version of Internet Explorer now. So you should probably check out which version of Internet Explorer you are using and if you are using the 64 bit version then you should uninstall it and install the 32 bit version of Internet Explorer in your system. Check if the problem still exists when you are using the 32 bit version of Internet Explorer.
Reply With Quote
Reply

  TechArena Community > Technology > Technology & Internet
Tags: , , , , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Silverlight is installed but not running on web pages"
Thread Thread Starter Forum Replies Last Post
How to get sub domains to work for PHP pages running IIS 7 Eseld Technology & Internet 6 19-06-2011 10:17 PM
Website keeps saying- Silverlight not installed Y-Maker Windows Software 5 28-04-2011 10:28 AM
While installing Silverlight I get "Silverlight is already installed" message Raja Ram Windows Software 5 28-04-2011 10:27 AM
Internet Explorer fails to recognize installed Silverlight Atticus Windows Software 5 20-04-2011 10:15 AM
Not able to print multiple pages in Silverlight 4 Feng Windows Software 6 05-08-2010 11:55 PM


All times are GMT +5.5. The time now is 10:59 AM.