Go Back   TechArena Community > Technology > Technology & Internet
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



IE8 won't allow to change my Default Search Provider

Technology & Internet


Reply
 
Thread Tools Search this Thread
  #1  
Old 12-02-2011
Member
 
Join Date: Jan 2011
Posts: 66
IE8 won't allow to change my Default Search Provider
  

I do not know why like this happening in my system. Actually when I was using internet explorer7 so at that time I do not have any issue in this. But at the time when I have install the internet explorer so from that I am going through this issue. And the main issue is that how come Windows Internet Explorer 8 will not allow me to modify my Default Search Provider? I am acquainted with this that I am in the right place and I have tried several times but, it will not allow me to modify the search provider? So regarding this if you guys have any suggestion then please help me.

Reply With Quote
  #2  
Old 12-02-2011
Member
 
Join Date: May 2009
Posts: 532
Re: IE8 won't allow to change my Default Search Provider

Here actually I want to know that what accurately happening in your case when you try this and in this is there any kind of error message which you are getting at that time? And here I also want to know that Other than not being default is yahoo search engine is installed and also working correctly? And the last thing which I want to know here that did you install the MSN customized version of internet explorer8?
Reply With Quote
  #3  
Old 12-02-2011
Member
 
Join Date: May 2009
Posts: 501
Re: IE8 won't allow to change my Default Search Provider

I am also going through the same issue and in this I am also not getting this why I am getting like this kind of issue after installing the internet explorer8 on to my system. And recently I have Google which is set as my default search provider and when I asked during setup if I would like to keep it that way I respond with yes. It still distorted my default to bing. If I go into the "Manage Search Providers" area I am able to modify the sort order, move them up and down, enable/disable search suggestions, etc. But the matter is that when I tick Google and choose "Set as default" not anything happens. And it also does not give me any error message so if anybody has any suggestion related to this then please help us.
Reply With Quote
  #4  
Old 12-02-2011
Member
 
Join Date: Apr 2009
Posts: 481
Re: IE8 won't allow to change my Default Search Provider

There is a way through which you will be able to get fix for your issue. Actually in this you have to just follow the steps which I have introduced over here.
  1. So first you have to open IE
  2. And in that under Tools located on the menu bar > choose Internet Options
  3. And in that under Search (Change Search Defaults) > choose Settings
  4. n "Manage Add-ons" window
  5. At the bottom of the page you have to tick " More Search providers"
  6. And then after doing this you just go to Google Search Suggestions and tick Add to IE
  7. Add Search Provider so after that you will get popup message
  8. So in this you just confirm to check "make use of search suggestion from this provider"
  9. Click Add
  10. And in the last you have to confirm that in the "Manage Add-ons" that Google is "set to default"
Reply With Quote
  #5  
Old 17-05-2011
Member
 
Join Date: May 2011
Posts: 3
Re: IE8 won't allow to change my Default Search Provider

Reset Live Search to Google and resolve ‘A program has corrupted your default search….

This worked for me!

Reset Live Search:
1. Go to http://www.microsoft.com/windows/ie/.../default.mspx#
2. Select “Google Google Web Search” from the ‘Web Search’ list on the left.
3. In “Add Search Provider” dialog box: Check ‘Make this my default search provider’ & ‘Use search suggestions from this provider’. Then click on “Add”.
4. Open the now famous ‘Live Search’ drop-down menu (To the right of the Spyglass) and you should now see ’Google’ added to your search options.
5. From this drop-down menu select ‘Manage Search Providers’
6. This opens ‘Manage Add-ons’. Select ‘Search Providers’ from list of “Add-on Types”.
7. You should now see ‘Google’ added and enabled in the list of search providers; Click on Google and then click the ‘Set as default’ button. Google should now appear as your default search provider.
8. Now close your browser and reopen it, checking to ensure that Google remains as your Default Search Provider.
9. Now, if like me, you don’t want the dreaded ‘MS Live Search/Bing’ at all, you can repeat steps 4; 5 & 6. But this time ‘Right click’ on Live Search and select ‘Remove’

Job – Jobbed? Well nearly!

This resolved my inability to reset Live Search to Google on six accounts out of seven, over three machines, all running XP SP3 & IE8. However, in the remaining account I was still unable to make any changes to the ‘Live Search/Bing’ default search scenario and that account was also producing an error:
“A Program on your computer has corrupted your default search setting for Internet Explorer.
Internet Explorer has reset this setting to your original search provider.
Internet Explorer will now open Search Settings, where you can change this setting or install more search providers.”

So, reluctant to go thru the ‘Open New Account process, on this account I carried out the recommended RegEdit as follows:

Close all open Internet Explorer windows. Change the following registry keys
Note: Changing registry key can make your system unstable; make sure you create a backup of registry and save it.
1. Click on Start -> Run, type regedit.exe and click OK.
2. In the Registry editor, on the left pane locateHKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders
3. Add a new Expandable String value inside ‘User Shell Folders’ with a value name of AppData and a value data of %USERPROFILE%\Application Data.
4. Close the registry editor and reboot the computer.

That did the trick and I was now able to complete steps 1 thru 9 of the ‘Reset Live Search’ procedure. I now have all seven accounts with ‘Google’ set as default Search Provider and the dreaded ‘Live Search/Bing’ removed.

(Sighs with relief and goes to bed) Another very late one!

Keep safe and be lucky.

Gerry
Reply With Quote
Reply

  TechArena Community > Technology > Technology & Internet
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "IE8 won't allow to change my Default Search Provider"
Thread Thread Starter Forum Replies Last Post
How to get rid of error "a program has corrupted your default search provider" Suhasini Technology & Internet 8 17-05-2011 11:02 PM
Default search provider error while opening Internet Explorere 8 Colten Windows Software 5 26-12-2009 07:47 PM
How to Change Default Search Engine in Firefox Justin23 Technology & Internet 3 12-09-2009 05:03 PM
How can i change the default search in Flock Zacharia Technology & Internet 3 13-06-2009 09:50 PM
Error message: Default search provider corrupted JamesB Technology & Internet 4 13-04-2009 11:59 PM


All times are GMT +5.5. The time now is 12:40 PM.