Go Back   TechArena Community > Software > Software Development
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 31-08-2009
Member
 
Join Date: Nov 2008
Posts: 88
execution of the asp page caused the response buffer to exceed its configured limit.

I was creating some web reports for a remote site and I get this error when the number of records are returning more data.(above 3000 records)
Quote:
Response object, ASP 0251 (0x80004005)
Execution of the ASP page caused the Response Buffer to exceed its configured limit.
The page loads 3000+ rows of data to drop down menu. When I added Reponse.Flush() to the drop-down loop the page loaded fine, though it took several minutes to load the page, how do i can rectify this? Any body help me?
Reply With Quote
  #2  
Old 31-08-2009
Member
 
Join Date: Dec 2008
Posts: 183
Re: execution of the asp page caused the response buffer to exceed its configured limit.

You need to Change the AspBufferingLimit setting in Metabase.xml to a larger size. The default value is 4194304, which is about 4 MB. it may be a good option to look into something other then the dropdown and or a method of reloading the drop down based on the user events. Change this to whatever limit is reasonable for the types of files your users will be attaching.
Reply With Quote
  #3  
Old 31-08-2009
Member
 
Join Date: Feb 2009
Posts: 105
Re: execution of the asp page caused the response buffer to exceed its configured limit.

Open the IIS Manager on your Reporting Point. Double-click on the local computer and then drill down to and open the Default Web Site properties. Web listboxes are for small sets - several hundreds of items tops. For anything above that, it is better to find alternative ways like checking after submit (when acceptable) or data picker with popup/modal window or that XMLHTTP/AJAX thing. You do not need to stop IIS for the metabase.xml editing, but to make the Metabase.xml file write-able.
Reply With Quote
  #4  
Old 31-08-2009
Member
 
Join Date: Oct 2008
Posts: 107
Re: execution of the asp page caused the response buffer to exceed its configured limit.

you need to go to the IIS control panel, right click the server, select properties, and check off the box that says ?allow changes to MetaBase configuration while IIS is running. Select the Home Directory tab and click on the Configuration button and then the Options tab. In the Application Configuration section increase the Asp Script Timeout value to 180 sec. The default is 90.
Reply With Quote
Reply

  TechArena Community > Software > Software Development
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "execution of the asp page caused the response buffer to exceed its configured limit."
Thread Thread Starter Forum Replies Last Post
Time limit advertising on home page of boxee box AmardeepG Portable Devices 6 14-10-2011 08:07 AM
A malicious or malfunctioning add-on caused to close this web page Gyusing Technology & Internet 3 10-02-2011 03:55 PM
Setting depth buffer (z buffer) size (16bit / 24bit) NewComer Monitor & Video Cards 4 08-04-2010 05:47 AM
Explorer caused an invalid page fault in module Kernel32.dll roshan45 Operating Systems 5 19-01-2010 08:26 PM
Sims has caused an invalid page fault in ~DF394B.TMP roshan45 Video Games 6 09-01-2010 08:47 PM


All times are GMT +5.5. The time now is 07:01 AM.