Go Back   TechArena Community > Software > Software Development
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 29-05-2009
Member
 
Join Date: Apr 2009
Posts: 107
Unable to configure virtual directory as an application in IIS

I have an .NET WebApplication running on my machine smoothly. I did an XCOPY to have it run on another location on my machine. I have created a new Virtual directory also for this purpose.An error occurred during the processing of a configuration file required to service this request.It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.

What would be the problem.
Reply With Quote
  #2  
Old 29-05-2009
Member
 
Join Date: Mar 2008
Posts: 227
Re: Unable to configure virtual directory as an application in IIS

I think you need to try changing authentication mode to 'None' in web.config, and for that Go to your web.config file and change following line from

< authentication mode="Windows" />

to

< authentication mode="None" />

if all goes proper then this may solve your problem.
Reply With Quote
  #3  
Old 29-05-2009
Member
 
Join Date: Dec 2008
Posts: 202
Re: Unable to configure virtual directory as an application in IIS

If you are able to find the IIS on your machine and search for your project folder on the server, right click to go to Properties, you will find an tab called Application Settings click Create. You may choose any authentication mode to use with a web project, IIS will not allow it to run as Web Site. It's configured to be a Web App.
Reply With Quote
  #4  
Old 29-05-2009
Member
 
Join Date: Mar 2008
Posts: 192
Re: Unable to configure virtual directory as an application in IIS

If you get this message in your browser, then perform the following steps:
  1. Select start go to control panel select AdminTools search for IIS/(this computer)-> select WebSites check for DefaultWebSite/(your branch dir)
  2. Right-click on the folder which would be the project folder
  3. Right click and Select Properties
  4. Click the ?Create? button for ?Application Name?
  5. To take considerable effects need to Restart IIS
  6. Now you are allow to Re-request for your page
Reply With Quote
Reply

  TechArena Community > Software > Software Development
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Unable to configure virtual directory as an application in IIS"
Thread Thread Starter Forum Replies Last Post
Should I create a virtual directory Lashawn Software Development 5 19-01-2010 09:28 PM
Virtual Directory does not allow contents to be listed Sachit Networking & Security 3 11-07-2009 09:54 AM
Virtual directory in IIS 7 yogeshap Software Development 4 30-04-2009 01:42 PM
Configure Microsoft Active Directory for SSL Access Isaivalan Active Directory 3 14-11-2008 08:53 AM


All times are GMT +5.5. The time now is 07:17 AM.