Go Back   TechArena Community > Software > Software Development
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 01-05-2009
Member
 
Join Date: Apr 2009
Posts: 26
Webserver is not executing CGI files.

Hello,

I try to install Bugzilla on my machine and before getting an installation it gives me an error message. On the second installation it done very well but when I run testserver.pl, the following error appears: TEST-FAILED Webserver is not executing CGI files. I have attached my httpd.conf file because I thought conf file may resolve the issue.

Please suggest someone how do I solve this problem.

Thanks
Reply With Quote
  #2  
Old 01-05-2009
Member
 
Join Date: Oct 2008
Posts: 167
Re: Webserver is not executing CGI files.

You need to add to the registry the following:
Create a key HKEY_CLASSES_ROOT\.cgi\Shell\ExecCGI\Command with the default value of the full path of perl.exe with a -T parameter. For example C:\Perl\bin\perl.exe -T

I have talk to many people on the internet regarding installing Bugzilla on Microsoft Windows it has problem like crashing down most of the time.

The reason is that all bugzilla cgi scripts use \user\bin\perl -wT and in order to execute -T, it needs to be added to the command line.
Reply With Quote
  #3  
Old 01-05-2009
Member
 
Join Date: Dec 2008
Posts: 183
Re: Webserver is not executing CGI files.

DocumentRoot, The directory out of which you will serve your purpose as per me you should get Search.pm and BugMail.pm, By default, all requests are taken from this directory, but These two files, they're included with Bugzilla but make sure to cd to the Bugzilla directory before calling either collectstats.pl, whine.pl or whineatnews.pl. This is because the scripts are looking in '.' for Bugzilla/BugMail.pm and Bugzilla/Search.pm.
Reply With Quote
Reply

  TechArena Community > Software > Software Development
Tags: , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Webserver is not executing CGI files."
Thread Thread Starter Forum Replies Last Post
Cisco 1841 Router Help with Webserver beigemonkey Networking & Security 2 30-12-2011 07:34 AM
Backup for webserver divya_r Networking & Security 1 05-09-2011 12:02 PM
Executing exe files in Ubuntu Benjhonson Operating Systems 3 27-12-2010 03:20 AM
Apache not executing .php files, directly downloads it Roakman Technology & Internet 4 27-12-2010 02:40 AM
Flv files not executing on k-lite CAILYN Windows Software 3 01-12-2009 10:31 PM


All times are GMT +5.5. The time now is 11:17 PM.