Go Back   TechArena Community > Technical Support > Computer Help > Windows Server > Server Update Service
Become a Member!
Forgot your username/password?
Register Tags Active Topics RSS Search Mark Forums Read

Sponsored Links



Clients not downloading patches

Server Update Service


Reply
 
Thread Tools Search this Thread
  #1  
Old 11-04-2012
srd srd is offline
Member
 
Join Date: Apr 2012
Posts: 2
Clients not downloading patches

First let me apologize for the length but wanted to include as much info as possible.
I installed a new WSUS server version 3.2 running on Server 2008 R2 SP1 64bit. This server does not have Internet capability so I exported using wsusutil from a server that does, copied the WSUSContent folder and then imported to this server. This worked great.
Setup group policies for clients to Auto download and notify for install.
Applied policies and clients appeared in assigned computer groups.
Clients also downloaded patches.
I installed the downloaded patches.
Now the clients will not download any more approved patches. WSUS console is reporting the clients need patches but clients won't download.
Clients are running XP or Windows 2003 Server
These clients were configured to to get patches from the server I exported from but due to regulations I am required to remove all IE access. So switched them to the new server.

I have begun troubleshooting with one client (Windows 2003 Server SP2 domain controller) I ran the client diagnotistic tool

WSUS Client Diagnostics Tool

Checking Machine State
Checking for admin rights to run tool . . . . . . . . . PASS
Automatic Updates Service is running. . . . . . . . . . PASS
Background Intelligent Transfer Service is not running. PASS
Wuaueng.dll version 7.4.7600.226. . . . . . . . . . . . PASS
This version is WSUS 2.0

Checking AU Settings
AU Option is 3 : Notify Prior to Install. . . . . . . . PASS
Option is from Policy settings

Checking Proxy Configuration
Checking for winhttp local machine Proxy settings . . . PASS
Winhttp local machine access type
<Direct Connection>
Winhttp local machine Proxy. . . . . . . . . . NONE
Winhttp local machine ProxyBypass. . . . . . . NONE
Checking User IE Proxy settings . . . . . . . . . . . . PASS
User IE Proxy. . . . . . . . . . . . . . . . . NONE
User IE ProxyByPass. . . . . . . . . . . . . . NONE
User IE AutoConfig URL Proxy . . . . . . . . . NONE
User IE AutoDetect
AutoDetect not in use

Checking Connection to WSUS/SUS Server
WUServer = http://U1Sec.pplmcs1.local
WUStatusServer = http://U1Sec.pplmcs1.local
UseWuServer is enabled. . . . . . . . . . . . . . . . . PASS
Connection to server. . . . . . . . . . . . . . . . . . PASS
SelfUpdate folder is present. . . . . . . . . . . . . . PASS

Press Enter to Complete

I'm not seeing anything in the log that gives me a clue...

Triggering AU detection through DetectNow API
Triggering Online detection (non-interactive)
#############
## START ## AU: Search for updates
#########
<<## SUBMITTED ## AU: Search for updates [CallId = {133A53BB-E857-43BE-B56E-0911CA7F76AE}]
*************
** START ** Agent: Finding updates [CallerId = AutomaticUpdates]
*********
* Online = Yes; Ignore download priority = No
* Criteria = "IsHidden=0 and IsInstalled=0 and DeploymentAction='Installation' and IsAssigned=1 or IsHidden=0 and IsPresent=1 and DeploymentAction='Uninstallation' and IsAssigned=1 or IsHidden=0 and IsInstalled=1 and DeploymentAction='Installation' and IsAssigned=1 and RebootRequired=1 or IsHidden=0 and IsInstalled=0 and DeploymentAction='Uninstallation' and IsAssigned=1 and RebootRequired=1"
* ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
* Search Scope = {Machine}
Validating signature for C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wuident.cab:
Microsoft signed: Yes
Validating signature for C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wuident.cab:
Microsoft signed: Yes
Validating signature for C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wsus3setup.cab:
Microsoft signed: Yes
*********** Setup: Checking whether self-update is required ***********
* Inf file: C:\WINDOWS\SoftwareDistribution\SelfUpdate\Default\wsus3setup.inf
Update NOT required for C:\WINDOWS\system32\cdm.dll: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuapi.dll: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuapi.dll.mui: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuauclt.exe: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuaucpl.cpl: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuaucpl.cpl.mui: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuaueng.dll: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuaueng.dll.mui: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wucltui.dll: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wucltui.dll.mui: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wups.dll: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wups2.dll: target version = 7.4.7600.226, required version = 7.4.7600.226
Update NOT required for C:\WINDOWS\system32\wuweb.dll: target version = 7.4.7600.226, required version = 7.4.7600.226
* IsUpdateRequired = No
+++++++++++ PT: Synchronizing server updates +++++++++++
+ ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://U1Sec.pplmcs1.local/ClientWebService/client.asmx
+++++++++++ PT: Synchronizing extended update info +++++++++++
+ ServiceId = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7}, Server URL = http://U1Sec.pplmcs1.local/ClientWebService/client.asmx
* Found 0 updates and 54 categories in search; evaluated appl. rules of 702 out of 1204 deployed entities
*********
** END ** Agent: Finding updates [CallerId = AutomaticUpdates]
*************
>>## RESUMED ## AU: Search for updates [CallId = {133A53BB-E857-43BE-B56E-0911CA7F76AE}]
# 0 updates detected
#########
## END ## AU: Search for updates [CallId = {133A53BB-E857-43BE-B56E-0911CA7F76AE}]
#############
Featured notifications is disabled.
AU setting next detection timeout to 2012-04-12 08:44:40
REPORT EVENT: {D507A045-A36D-47C0-B03E-9D7C63D306A9}
REPORT EVENT: {4FFFB1AB-473B-4C66-8047-37E87C690DBF}
Uploading 2 events using cached cookie, reporting URL = http://U1Sec.pplmcs1.local/Reporting...ebService.asmx
Reporter successfully uploaded 2 events.

Things I have tried
1. Stopped Update service, Removed SUSClientID and Validation from registry, started Updated service, ran wuauclt.exe /resetauthorization /detectnow client reports but will not download patches.
2. Stopped update service, removed Software Distribution folder, restarted service, ran wuauclt.exe /resetauthorization /detectnow client reports but will not download patches
3. Removing client from WSUS and running wuauclt.exe /resetauthorization /detectnow client reappears in console but will not download patches.

Does anyone have any suggestions?

Reply With Quote
  #2  
Old 11-04-2012
Member
 
Join Date: Dec 2007
Posts: 2,260
Re: Clients not downloading patches

What you can do is, in distribution point properties enable "Allow clients to connect anonymously (Required for mobile device clients)". This should fix your problem.
Reply With Quote
  #3  
Old 12-04-2012
srd srd is offline
Member
 
Join Date: Apr 2012
Posts: 2
Re: Clients not downloading patches

Thanks for the reply. I think I may have discovered the issue. The patches were not downloaded. Some of the patches were ones that were previously downloaded. I'm not sure I understand what happened but after downloading patches, it seems to be working. I will have to try an update again and see what I am missing.
Reply With Quote
Reply

  TechArena Community > Technical Support > Computer Help > Windows Server > Server Update Service
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Clients not downloading patches"
Thread Thread Starter Forum Replies Last Post
wlan clients unable to ping lan clients with WAG320N connoisseur Networking & Security 3 25-06-2012 06:46 PM
Need help: Game downloading stops when downloading from steam Farzana Video Games 6 04-07-2011 10:43 PM
After downloading Z4root decreased downloading speed Anjan1990 Portable Devices 3 20-06-2011 09:59 AM
Patches and DLC on borderlands Ilampirai Video Games 4 24-05-2011 10:14 AM


All times are GMT +5.5. The time now is 11:55 AM.