Go Back   TechArena Community > Technology > Technology & Internet > "the version of Live Meeting client is not compatible with the Server" error when I try to join a Microsoft Meeting
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Thread: "the version of Live Meeting client is not compatible with the Server" error when I try to join a Microsoft Meeting Send Page to a Friend
Your Username: Click here to log in
Recipient Name:
Recipient Email Address:
Email Subject:
Message:

All times are GMT +5.5. The time now is 09:32 AM.