TechArena Community

TechArena Community (http://forums.techarena.in/)
-   Windows XP Support (http://forums.techarena.in/windows-xp-support/)
-   -   Net Use LPT1: command - Help! (http://forums.techarena.in/windows-xp-support/894767.htm)

Eric 17-01-2008 09:55 PM

Net Use LPT1: command - Help!
 
We are mapping a DOS program to use LPT1 printing from a windows XP
workstation through a Windows 2003 server. The mapping is working, the print
jobs are going through to the printer from the server. We are using the
generic/text driver and in the "Begin Print Job" field putting in the PCL
code for a tray call. When sending a Test Page down to the printer from the
driver on the server the test page prints from the correct tray. After
mapping the LPT port using NET USE LPT1: \\servername\printername
/persistent:yes the dos program prints to the device but does not pull from
the correct tray. It pulls the paper from the default tray designated in the
printer. Does the NET USE command bypass the driver settings all together or
is it possible for the print job to use the Driver Default settings...both
under the "Printing Preferences" and under the advanced tab "printing
defaults" all have been selected to go to the correct tray when using the
PCL5e driver and that did not fix it either..thanks


Alan Morris [MSFT] 18-01-2008 01:24 AM

Re: Net Use LPT1: command - Help!
 
Your just sending raw data from the DOS application. It's not using any
windows driver settings.

There might be a 3rd party application that could send this data. There's
someone who regular posts information about printing from DOS applications.
Check some of the other posts for information about that product. Unsure
what it does or if it would meet your needs.

You do not have to have any printers nor print drivers installed to send
data to a mapped LPT port.
--
Alan Morris
Windows Printing Team
Search the Microsoft Knowledge Base here:
http://support.microsoft.com/search/?adv=1

This posting is provided "AS IS" with no warranties, and confers no rights.

"Eric" <Eric@discussions.microsoft.com> wrote in message
news:1664C272-F369-4C09-9E5D-0AE4B29E6697@microsoft.com...
> We are mapping a DOS program to use LPT1 printing from a windows XP
> workstation through a Windows 2003 server. The mapping is working, the
> print
> jobs are going through to the printer from the server. We are using the
> generic/text driver and in the "Begin Print Job" field putting in the PCL
> code for a tray call. When sending a Test Page down to the printer from
> the
> driver on the server the test page prints from the correct tray. After
> mapping the LPT port using NET USE LPT1: \\servername\printername
> /persistent:yes the dos program prints to the device but does not pull
> from
> the correct tray. It pulls the paper from the default tray designated in
> the
> printer. Does the NET USE command bypass the driver settings all together
> or
> is it possible for the print job to use the Driver Default settings...both
> under the "Printing Preferences" and under the advanced tab "printing
> defaults" all have been selected to go to the correct tray when using the
> PCL5e driver and that did not fix it either..thanks
>





All times are GMT +5.5. The time now is 05:43 PM.