TechArena Community

TechArena Community (http://forums.techarena.in/)
-   Office Setup (http://forums.techarena.in/office-setup/)
-   -   Unable to open Office 2007 under Vista Ultimate 32bit (http://forums.techarena.in/office-setup/665173.htm)

Badgel^gar 23-01-2007 02:38 PM

Unable to open Office 2007 under Vista Ultimate 32bit
 
Need urgent help guys to get rid this frustrating problem. I am having Windows Vista Ultimate 32Bit OS and Office 2007 Enterprises RTM installed. This is the fresh system and the CD used for installing Office on this PC has been used on 4 more PCs earlier where Office is running smoothly. But on my new system whenever I open any Office program instead of launching the app it comes with Office installer saying ?Windows is now configuring Office 2007 Enterprises?..?

After running the installer for about 30 seconds, it gives me an error saying stdole32.tlb is missing, though the file stdole32.tlb is right in my system32 folder. When I click Yes on this message the Installer Runs again and last for about 5 to 7 minutes. And later I can use that application. This happens with all Office applications including Word, Excel, PowerPoint or anything and everytime I launch the program.

I don?t what could be the problem, also am sure there is no problem with my disk as I said above it has installed already on four systems and all are working. Can anyone help me out with this ?

tyrone1963 19-06-2009 09:13 PM

Re: Unable to open Office 2007 under Vista Ultimate 32bit
 
I was having exact problem couple of months ago but in my case it was Office Professional 2007. After lost of research finally I managed to fix it with a registry tweak. What I did was I went to the following registry locations:

HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options

And created a new key named NoRereg. Double clicked and set its value to 1. Now rebooted the computer and problem was solved. Not it was Office Professional where this tweak helped. You can try the same but backup your registry and system before you make any changes in the registry.

oldscroat 08-11-2010 11:53 PM

Re: Unable to open Office 2007 under Vista Ultimate 32bit
 
Try this link

http://blogs.msdn.com/b/astebner/arc...04/739820.aspx .

I had the same problems with office 2007 and 2010 on my 32 bit vista installation (HP G7000 laptop with intel Core 2 Duo inside) where I got the stdole32 nonsense in excell and the never ending "please wait while windows configures ... etc." when opening the other applications in the office suite.

It is a very easy method to follow and it worked perfectly for me. I have both office 2007 Home office and Student and Office 2010 Proffesional installed side by side and they both run perfectly now. It was down to the registry not allowing permissions to be set but this proceedure fixed it straight away. I can't recommend it enough. Here is the link again.

http://blogs.msdn.com/b/astebner/arc...04/739820.aspx

I hope you have the same success it gave to me.

Regards

Oldscroat


All times are GMT +5.5. The time now is 11:12 AM.