TechArena Community

TechArena Community (http://forums.techarena.in/)
-   Motherboard Processor & RAM (http://forums.techarena.in/motherboard-processor-ram/)
-   -   Blank Screen on first boot in MSI 970A-G45 Motherboard (http://forums.techarena.in/motherboard-processor-ram/1464497.htm)

Tritanic 17-05-2012 11:54 AM

Blank Screen on first boot in MSI 970A-G45 Motherboard
 
I had assembled a new system by purchasing each and every hardware piece by piece. Each component is new and is under warranty. I had assembled the same properly, but on first boot I cannot see any bios message. It is a blank screen. Computer Power is on, Case fan and CPU fan both are working. HDD Led and DVD Rom LED power indicator looks fine but still there is no message on screen. Nothing happens if I left it for sometime. Neither there is any beep sound.

AmdUser 17-05-2012 11:54 AM

Re: Blank Screen on first boot in MSI 970A-G45 Motherboard
 
Sometimes this kind of problem is appears because of RAM as it is not responding properly and it is fitted properly. Check your RAM, is it fitted perfectly or not? And if ram is fixed properly and still same issues then check your RAM one by One in another motherboard. And also check your all DIMM slots are working well. If you don?t have extra motherboard then get one proper working RAM and attach it to your computer. And Check if your computer is working or not with single. And tell me if any BEEP sound comes from motherboard Speaker.

Logan.M 17-05-2012 11:54 AM

Re: Blank Screen on first boot in MSI 970A-G45 Motherboard
 
I checked everything and finally got a solution. I made just silly mistake. When I am checking the CPU is fitted properly or not at that time I saw that 4-pin peripheral power connector is not attach to motherboard. So, I connect it with motherboard and problem is solved. But thanks for your help. Now all is working fine.


All times are GMT +5.5. The time now is 02:52 PM.