TechArena Community

TechArena Community (http://forums.techarena.in/)
-   Operating Systems (http://forums.techarena.in/operating-systems/)
-   -   Not able to install Ubuntu Natty on Vmware (http://forums.techarena.in/operating-systems/1429603.htm)

VazV 13-09-2011 08:06 PM

Not able to install Ubuntu Natty on Vmware
 
I am not able to run my Virtual Machine. I have getting a error saying unable to open vmdk. I do know the exact error message. Another line says that not able to configure the disk. This is simply crashing of vmware. I tried reconfiguring but faced the same error. I am not able to figure out what is the actual cause behind that.

Elieis 13-09-2011 08:06 PM

Re: Not able to install Ubuntu Natty on Vmware
 
When you run the vmware setup the product verifies the product integrity of the disk you are using. The virtual disk is the one which is needed to verify. So if that fails yo get that error. Many time the tool repairs the virtual disk and fix the same. Right now there is no tool which can repair the virtual disk so the product do the same via installation only. This is somewhat similar to backup process which works in Windows in case of disk failure. The task here is simple when you are working on virtualization. You have to create an copy of virtual machine files. Keep that safe in some area which can used to restore back at the time of crash. This can be done by adding a second virtual disk and copying data1/win2004.vmd to the file. This is the configuration data of virtualization. This data can be used in future to restore back your virtal operating system.

mesterio 13-09-2011 08:06 PM

Re: Not able to install Ubuntu Natty on Vmware
 
The vmdk file crash is the cause of system failure. At start many users do not take back up of the same. So next when you can fix back your machine surely keep a backup of the same.

mv 14-09-2011 05:18 PM

Re: Not able to install Ubuntu Natty on Vmware
 
You can only recover the VMDK files if you are using VMWare ESX3 and when you are running nested vms. Or else in older version there is no such kind of options. Till yet I had not seem anything like that. Vmdk file are vmware files which keeps the record of important system configuration. It is possible that the file can be corrupted which will give you error when you launch the virtual machine. You cannot load your virtual operating system without this fiiles. Also sometime virtual center fails to load. But there are possibilities by which you can recreate the vmdk files. The .vmdk file has meta data record of your virtualize os. First you hvae to find the original size of hard drive you were using on vmware. Now create a new vm and also virtual center. You have to create the same with similar hard drive size that you had used before. The size should be exact.

There is an tool called Putty which you can find on ESX server. Run it. Copy your vmdk file to the vm directory. Once files are move you have to edit those file with vmdk text editor. Replace the olf file names on them and then save. Load vm in virtual center.

WajeehT 15-09-2011 11:57 AM

Re: Not able to install Ubuntu Natty on Vmware
 
It is not really good to find that the above process is just for ESX3 version of Vmware. What about the old one. I had also tried to found some tools which can restore vmware but there is nothing much provided. Better recreated your virtual machine back again and then check back.


All times are GMT +5.5. The time now is 02:50 AM.