TechArena Community

TechArena Community (http://forums.techarena.in/)
-   Operating Systems (http://forums.techarena.in/operating-systems/)
-   -   Why CentOS is reading one key press as held down key press? (http://forums.techarena.in/operating-systems/1407319.htm)

pREMAsAGAR 13-05-2011 12:28 PM

Why CentOS is reading one key press as held down key press?
 
I have installed CentOS on the computer of mine. I have noticed a particular problem with the computer of mine. Sometimes I have noticed when I press M from the keyboard it seems to be typing ?hhhhhhhhh?. I am unable to figure out whether there is an hardware issue or software issue on the computer of mine. Let me know if you are knowing anything which I can use to fix the problem of mine. Any help would be highly appreciated. Thanks a lot in advance

Elijah 13-05-2011 12:30 PM

Re: Why CentOS is reading one key press as held down key press?
 
Looking at the problem which you have mentioned over here it hard to figure out the root cause of the problem. Can you tell me which version of the CentOS do you have installed on the computer? Let me know which keyboard brand do you using? Do you having PS2 or USB keyboard? Can you tell me about the hardware configuration of the computer? Do you have updated all the drivers on the computer? Let me know the answers of the above mentioned question as early as possible.

Luis234 13-05-2011 12:30 PM

Re: Why CentOS is reading one key press as held down key press?
 
I am highly suspecting that the problem which you have mentioned over here is happening due to clock issue. Hence I am suggesting that you should change the clocksource acpi_pm and it can make the clock speed faster. In order to check the current clock source you can use the following command on the terminal.
Code:

# cat /sys/devices/system/clocksource/clocksource0/available_clocksource
tsc acpi_pm
# cat /sys/devices/system/clocksource/clocksource0/current_clocksource
tsc

Also you should put clocksource=acpi_pm into /boot/grub/menu.lst.

Aleksandra 13-05-2011 12:31 PM

Re: Why CentOS is reading one key press as held down key press?
 
Let me know whether you are typing through the command line or GUI. If you are using GUI then I am suggesting that you should try with adjusting repeat speed. You should go for System and then go for Preferences and then go for Keyboard. Here you will get the option for the adjusting the speed of the keyboard on the computer of yours. So go through the steps which I have mentioned over here and let me know about the results.

kraal 13-05-2011 12:31 PM

Re: Why CentOS is reading one key press as held down key press?
 
In order to change the keyboard repeat rate you need to use the following command and see whether it is working or not.
Code:

! set the keyboard repeat rate to the max

        mov    ax,#0x0305
        xor    bx,bx          ! clear bx
        int    0x16

you should paste the above mentioned command into /usr/src/linux/[arch/i386/]boot/setup.s. So try the above mentioned thing and I am hoping that it will help you out.

Ernesto4 13-05-2011 12:32 PM

Re: Why CentOS is reading one key press as held down key press?
 
I think the problem which you have mentioned over here is happening due to driver issue. So I am suggesting that you should go for the official website of the keyboard manufacturer and look for the latest version of the keyboard driver. You should download and install the drivers on the computer. After installing the drivers you should reboot the computer of yours.

Deep123 14-05-2011 10:29 AM

Re: Why CentOS is reading one key press as held down key press?
 
Do you have tried with any other keyboard? Well it will help you out to figure out whether there is an issue with the keyboard or computer? If other keyboard is working then I am sure that there is an issue with the keyboard which you are using currently. You are having two options that is you can claim for the replacement warranty if you are having with you or you can get the brand new keyboard from the market.


All times are GMT +5.5. The time now is 03:11 PM.