Results 1 to 6 of 6

Thread: Getting blackscreen on MSI GE620

  1. #1
    Join Date
    Jan 2012
    Posts
    59

    Getting blackscreen on MSI GE620

    I have been using MSI GE620 and I did not had any issues with the same. I have recently reinstalled Windows 7 on the same. Since then I am getting black screen on boot. I did not had any issue with the installation and I had made sure that I am installing all the required drivers as well. It all happened when I rebooted the laptop after installing Windows 7 along with the required drivers. Is there anyone who has faced the same?? Is there anything I can try out?

  2. #2
    Join Date
    Jan 2012
    Posts
    92

    Re: Getting blackscreen on MSI GE620

    Your issues seems to be weird, I just wanted to know that have you tried resetting the laptop?? If not then you can try it out and see if it is making any difference. You can also try booting in to safe mode and see if you are able to enter windows. If you donít get any help from it then you will have to try reinstalling windows. I donít think there is anything else that you can try out other than these. Just try out these things and let me know if you are getting any help from it.

  3. #3
    Join Date
    Jan 2012
    Posts
    59

    Re: Getting blackscreen on MSI GE620

    In that case I will like to inform you that I have tried resetting the laptop several times and have reinstalled windows a couple of times as well. I am not having any issues with the fresh installation of windows but after installing the latest and missing driver when I am rebooting the system then I am getting a black screen. I have checked about the same on the web and have found some people mentioning that there might be some issue with the ram, so I have not tested it out in other working machine and it is working fine there. I donít think there is anything wrong with the ram in my case. I am really running out of ideas and I just want to get it working somehow. Further help regarding the same will be appreciative.

  4. #4
    Join Date
    May 2011
    Posts
    1,869

    Re: Getting blackscreen on MSI GE620

    Since you have mentioned that you are getting black screen after installing latest driver and just not after making a fresh installation of the driver. I think that you might be installing corrupted drivers?? If you are installing the drivers from the cd then try installing them from windows update and see if it is making any difference. I am not very sure but then I think it is some kind of driver issue. Just try out what I have suggested and post back what you get so that I can have a better idea of your issue.

  5. #5
    Join Date
    Jan 2012
    Posts
    59

    Re: Getting blackscreen on MSI GE620

    Yes I was installing the drivers from the cd that I had got with the board. Anyways after your suggestion I have tried installing the latest driver via windows update and even after that I am getting the same black screen error after rebooting the system. I am just not able to track out the cause of the issue in my case. I have tried out all the possible solution that I could have and the suggested ones as well but none of them has made any difference in my case. Is there anything else that I can try out rather than simply taking it to the service center???

  6. #6
    Join Date
    Mar 2011
    Posts
    1,341

    Re: Getting blackscreen on MSI GE620

    I think there is something wrong with your hard drive, I will suggest you to better run a CHKDSK in Windows 7 before installing the driver and let me know what you get. CHKDSK command will basically repair bad sectors, lost clusters, directory errors and will remove corruption in the system files as well. If you are not aware of running CHKDSK command then you can refer to the below steps:
    Go to start> Computer> just right click on the drive that you want to scan a click on Properties> Tools tab > Click on “Check Now” and click on ok. After that the scan process will start and will repair the problems found. If you want then you can try doing a deeper scan as well and for that you have to Check mark “scan for and attempt recovery of bad sectors” option and click on Start Button.

Similar Threads

  1. Looking for MSI Ge620-021 Custom Bios
    By Mitchell-Y in forum Motherboard Processor & RAM
    Replies: 2
    Last Post: 22-05-2012, 02:27 PM
  2. Replies: 3
    Last Post: 22-04-2012, 08:15 PM
  3. Is it good to buy MSI GE620
    By Baisakhi in forum Portable Devices
    Replies: 6
    Last Post: 12-08-2011, 09:52 AM
  4. XP Sony VAIO can't boot:BlackScreen
    By queenz_royale in forum Windows XP Support
    Replies: 9
    Last Post: 11-06-2011, 06:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •