Results 1 to 6 of 6

Thread: Not able to connect to the TPM (security device) after installing windows Vista on Lenovo ThinkPad R52

  1. #1
    Join Date
    Feb 2012
    Posts
    79

    Not able to connect to the TPM (security device) after installing windows Vista on Lenovo ThinkPad R52

    I have recently installed Windows Vista Business on my Lenovo ThinkPad R52 and the problem that I am facing is that the Client Security Solution has stopped working and I am getting an error message saying the following:
    "There was a problem connecting to the TPM (security device) on this computer. It is possible that anti-virus or firewall software is blocking the connection. A missing or disabled device driver could also cause this problem. Please refer to the online documentation for more information."
    I donít have much idea about the same is there anyone who has an idea of resolving the issue??

  2. #2
    Join Date
    May 2011
    Posts
    1,869

    Re: Not able to connect to the TPM (security device) after installing windows Vista on Lenovo ThinkPad R52

    I have recently installed Windows Vista Business on my Lenovo ThinkPad R52 and the problem that I am facing is that the Client Security Solution has stopped working and I am getting an error message saying the following:
    "There was a problem connecting to the TPM (security device) on this computer. It is possible that anti-virus or firewall software is blocking the connection. A missing or disabled device driver could also cause this problem. Please refer to the online documentation for more information."
    I donít have much idea about the same is there anyone who has an idea of resolving the issue??
    I just wanted to know that have you tried checking your firewall is not blocking the connection and so or if there is any disabled device drivers??? Other than this make sure that you are having the latest updates via the System Update and the chip is also enabled in the bios and all, these are some basics things that needs to be checked, just check it out and then let me know what you get.

  3. #3
    Join Date
    Feb 2012
    Posts
    79

    Re: Not able to connect to the TPM (security device) after installing windows Vista on Lenovo ThinkPad R52

    I have checked all of the above things and I have installed the latest updates through System Update and other than this the chip is also enabled in the bios, I have checked out on the device manager and there were no missing drivers the firewall does not seems to be blocking the connection, there is something else that is stopping it, I am not able to track out the actual cause of this issue, is there anything else that I can try out???

  4. #4
    Join Date
    Aug 2011
    Posts
    1,948

    Re: Not able to connect to the TPM (security device) after installing windows Vista on Lenovo ThinkPad R52

    Were you having the latest version of Client Security Solution if not then get it from the below link and then let us know if it is helping:


    Also get the latest Trusted Platform Module (TPM) driver from the below link:

    Juts check these things out and then post back the result that you get.

  5. #5
    Join Date
    Jul 2011
    Posts
    1,483

    Re: Not able to connect to the TPM (security device) after installing windows Vista on Lenovo ThinkPad R52

    I was just checking out a solution for the same and I have found one mentioning that the below solutions was helpful to him, so you can just try out the same and see if it is helping:
    • First reboot the machine and then press F1 to enter the BIOS setup menu.
    • After that From the Security menu check out for an option for clearing the security device in some cases it is referred to as the TPM or TCG feature.
    • When you are done with the same then just save and exit the BIOS setup menu and then Reboot the machine and then enroll in Client Security Solution.

    Juts perform the above solution and then let me know if it is helping.

  6. #6
    Join Date
    Feb 2012
    Posts
    79

    Re: Not able to connect to the TPM (security device) after installing windows Vista on Lenovo ThinkPad R52

    I have tried following the solution that you mentioned but then in the BIOS security/Security Chip I did not found any option for clearing the security device I just had the Current setting with the basic three options Active, Inactive and Disabled. Other than this there was Security Reporting Option having the below items to report but then they were disabled:
    • BIOS ROM
    • ESCD
    • CMOS
    • NVRAM
    • SMBIOS

    What should I do know?? Any further help for the same will be appreciated.

Similar Threads

  1. Replies: 4
    Last Post: 11-02-2012, 06:42 AM
  2. Replies: 4
    Last Post: 10-02-2012, 10:27 PM
  3. Installing windows 8 drivers on Lenovo ThinkPad x220t
    By Edie Adams in forum Portable Devices
    Replies: 3
    Last Post: 27-11-2011, 10:54 AM
  4. No Webcam device on BIOS of Lenovo ThinkPad T404
    By Naotau in forum Portable Devices
    Replies: 8
    Last Post: 25-10-2011, 11:34 PM
  5. Replies: 6
    Last Post: 24-06-2010, 11:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •