Results 1 to 11 of 11

Thread: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

  1. #1
    Join Date
    Oct 2011
    Posts
    87

    Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    I just upgrade a few of our devices to IOS 5 and wifi stopped up functioning. We are use by means of WPA2 Enterprise with EAP-TLS and all the devices through IOS 4 still work fine. Is anyone experiencing this type of difficulty?

  2. #2
    Join Date
    Jul 2011
    Posts
    1,799

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    I'm almost certainly having the similar difficulty. Have a working wi-fi on my ipad 2, the internet was working well. Then I updated to IOS5 and it says that I canít connect to the wifi. But the wifi-icon it in the top left and tells me I am connected and I can locate the network in general-settings-network-menu and tap in the password without any difficulty. My other device that it is working ok on the same wifi, and I have restores the ipad to factory defaults, and it doesnít make any difference.

  3. #3
    Join Date
    Oct 2011
    Posts
    89

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    So, whatís md5 and what be supposed to I do to obtain it working again? Iím having the similar difficulty too on my iPod Touch. How do you fix it?

  4. #4
    Join Date
    Oct 2011
    Posts
    87

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    The difficulty is I was speaking about happens only if your wifi network is using WPA2 Enterprise with EAP-TLS; in that case ask you network administrator to test that the certificates of the radius server are SH1 sign and not MD5 signed, since the latter signature process has been deprecate in IOS 5.If you are not using WPA2 Enterprise and can't connect to the wifi network you have a different difficulty and I don't know how can I get a help.

  5. #5
    Join Date
    Jul 2011
    Posts
    1,577

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    I am use a TeliaSonera Homerun at work and in town. TeliaSonera is the most important Incumbent telecom and internet operator in the Nordics, mainly in Sweden and Finland. I suppose the WiFi to work with their repair regardless of how the certificates are sign. At residence the wifi device (an ADSL access device from TeliaSonera) uses WPA2 and I'm not concerned in how it's signed.

  6. #6
    Join Date
    Oct 2011
    Posts
    665

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    I give the impression to be having the difficulty as well. My Certificate has SHA-1 with RSA Encryption as the signature algorithm. Is that the similar as the SH1 you reference? If so, I'm still having the issue for a different reason.

  7. #7
    Join Date
    Aug 2011
    Posts
    2,186

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    Yes, while I changed the radius server certificate from MD5 signed to SHA-1 signed the network started to work. Maybe you contain a different problem...

  8. #8
    Join Date
    Oct 2011
    Posts
    90

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    The means of WPA2 Enterprise network using with PEAP (MSCHAPv2), similar difficulty, do not work any longer (whereas iOS 4 did it fine). Look like Apple requirements to fix this immediately, how can we transfer this information to Apple Development?

  9. #9
    Join Date
    May 2011
    Posts
    1,741

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    I am having the same subject matter. For me I have to reconfigure wpa enterprise on my school's mschap-v2 every time I wish for to make use of it. This is enormously frustrating since it used to reconnect just fine on iOS 4.

  10. #10
    Join Date
    Nov 2011
    Posts
    1

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    I am having the same issue, we use freeradius to authenticate wireless users. IOS 4.X users work without issue. If I delete the profile on an IOS 5.X device and add it back it works fine for that instance, once they disconnect they are not able to reconnect. I have changed the self signed cert to use SHA-1. Has anyone found a fix/workaround?

  11. #11
    Join Date
    Jan 2006
    Posts
    4,545

    Re: Wifi with wpa2 enterprise stopped working after upgraded to IOS 5

    Quote Originally Posted by jomedusa View Post
    I am having the same issue, we use freeradius to authenticate wireless users. IOS 4.X users work without issue. If I delete the profile on an IOS 5.X device and add it back it works fine for that instance, once they disconnect they are not able to reconnect. I have changed the self signed cert to use SHA-1. Has anyone found a fix/workaround?
    I think apple released the IOS 5.1 version which includes many of the fixes, so have you tried updating it to that version. Other solution which i read somewhere was:
    - set a static IP number on the iPod/iphone
    - set the static IP also on the router (a Netgear RP614)
    => avoid DHCP for the iPod/iphone.
    In The Absence Of Light
    Darkness Prevail's

Similar Threads

  1. Replies: 6
    Last Post: 07-08-2011, 10:14 PM
  2. WPA2/Enterprise wireless connection is not working
    By Damned 2 in forum Networking & Security
    Replies: 5
    Last Post: 24-02-2011, 08:05 PM
  3. Replies: 4
    Last Post: 15-06-2010, 03:45 AM
  4. Replies: 5
    Last Post: 11-12-2009, 01:04 PM
  5. WPA2 Enterprise authentication not working
    By Saphire in forum Windows Vista Network
    Replies: 3
    Last Post: 01-02-2008, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •