Results 1 to 6 of 6

Thread: Lenovo g560 windows 7 pro Error "ACPI\VPC2004 Unknown Device"

  1. #1
    Join Date
    May 2011
    Posts
    110

    Lenovo g560 windows 7 pro Error "ACPI\VPC2004 Unknown Device"

    I have owned the Lenovo g560 in which windows vista was installed and my laptop was working fine. Now after some days I have upgraded my operating system with windows 7 and after installing the windows 7 I have installed all the drivers in my laptop. After installing the driver my laptop gives me the massage that one unknown device found and device ID is like Acpi\Vpc2004. now I donít know what is that but I am not able to remove this massage and my power management option is also not working. Any help will be appreciated.

  2. #2
    Join Date
    Jul 2009
    Posts
    969

    Re: Lenovo g560 windows 7 pro Error "ACPI\VPC2004 Unknown Device"

    To solve this problem I have one suggestion for you first of all you have to first open the windows 7 solution center and then check there whether there is any kind of message is displayed or not? As far as I know you must be having massage regarding this problem. First check that message and then let me know what the message is this. If that message is asking for any drivers then I think you should install first install that and after that you will not get any issue.

  3. #3
    Join Date
    Nov 2009
    Posts
    1,075

    Re: Lenovo g560 windows 7 pro Error "ACPI\VPC2004 Unknown Device"

    I think you can solve this problem by installing the ACPI Driver in your laptop. As you have said that in your laptop you are getting the message of this Acpi\Vpc2004 then it means ACPI driver is missing from your laptop and you have to install it. You can download this driver from internet and after that install it in your laptop and then you have restart the laptop. After doing that your laptop will not give you that message again and again. I hope this trick will fix your issue.

  4. #4
    Join Date
    Oct 2005
    Posts
    725

    Re: Lenovo g560 windows 7 pro Error "ACPI\VPC2004 Unknown Device"

    My sister was using the same laptop and laptop and also facing the similar kind of problem and then she gave her laptop to me to fix this issue and after that I have tried to search the solution for that problem. I have downloaded the ACPI driver from here ACPI DRIVER. Now after downloading that driver I have installed it in my system. After installing that driver I have restart the laptop and from that time I am not facing any issue with my laptop. I think you should also try this trick.

  5. #5
    Join Date
    Nov 2005
    Posts
    930

    Re: Lenovo g560 windows 7 pro Error "ACPI\VPC2004 Unknown Device"

    Only installing the ACPI driver will not fix this issue. you have to do the following steps to fix this issue. After installing ACPI driver you have to download the ATK Hotkey Driver and System Interface driver in your laptop and after that install both the driver in your system. Now after doing that open that folder where Energy utility is installed and then you will find the DPInst.exe file in that folder double click on that. After doing that you will not get any issue with your laptop.

  6. #6
    Join Date
    May 2011
    Posts
    110

    Re: Lenovo g560 windows 7 pro Error "ACPI\VPC2004 Unknown Device"

    I am agree with your above post I have first tried ti fix this problem by downloading the ACPI driver and installing ACPI driver only. But after that also I didnít get any help. Now after that I read your all the post and I have downloaded the ATK Hotkey Driver and System Interface driver and I have installed it in my laptop. Now after that I jave open the file which you have mentioned in your post and then when I restart the laptop from that time I am not getting any issue. Thank you.

Similar Threads

  1. Replies: 4
    Last Post: 12-02-2011, 06:10 AM
  2. "Unknown Base System Device" in Device Manager
    By Ameeryan in forum Hardware Peripherals
    Replies: 3
    Last Post: 22-12-2009, 09:00 PM
  3. Replies: 3
    Last Post: 21-07-2009, 10:15 AM
  4. ACPI error and "unkown device" in Device Manager
    By HAYES in forum Vista Hardware Devices
    Replies: 2
    Last Post: 04-02-2008, 11:33 PM
  5. Replies: 2
    Last Post: 17-01-2008, 09:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •