Go Back   TechArena Community > Hardware > Portable Devices
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 05-05-2009
Member
 
Join Date: May 2009
Posts: 4
question Stop external drive from truncating long file names

Hi, I'm new to this forum. Here's my problem:

I'm using the Maxtor OneTouch4 250GB external drive and when I try to copy files from my hard to the external drive via Windows Explorer (drag & drop) the external drive truncates the names. Some of the files have long names e.g. more than 100 characters long including the file extension. I am copying MS Word, MS Excel, MS Access, PDF, files, etc. to the external drive. I have a Dell Precision 490 computer with Windows XP as the operating system. Has anyone else experienced this? What can I do to correct this problem? I've tried everything. It even does it when I copy the files from a CD or flash drive. I've done a straight copy by opening the folder, highlighting the files and dragging them to the root on the external hard drive in Windows XP. I've also tried to copy from folder to root drive, folder to folder and every other way I could think of. It's totally frustrating!
Reply With Quote
  #2  
Old 05-05-2009
Member
 
Join Date: Jan 2006
Posts: 4,545
Re: Stop external drive from truncating long file names

Apparently this is related to a bug with Windows. After doing some reading I think the solution is to use the command prompt's XCOPY command. Since DOS ignores long files (by renaming them to short names) it just goes ahead and copies.
__________________
In The Absence Of Light
Darkness Prevail's
Reply With Quote
  #3  
Old 05-05-2009
Member
 
Join Date: Feb 2008
Posts: 214
Re: Stop external drive from truncating long file names

Your Harddrive must be in NTFS file format while your external drive must be in FAT file format. In such case, it is possible that long file names cannot copy in the external drive. You must be cognizant of the of the destination partition table if it is NTFS or FAT. You should also not use names greater than 64 chars. and in folders that have very long names stored in deep directory trees.

You need a tool like ROBOCOPY which can help you copy files easily at any location. You need to examine the way you name files and create folder trees and conform them to the media partition type you copy them too.
Reply With Quote
  #4  
Old 05-05-2009
Member
 
Join Date: Mar 2009
Posts: 599
Re: Stop external drive from truncating long file names

Hey!
By default long file names are disabled in Windows XP untill any software enables it. You can enable it by a registry tweak. Run "regedit" and navigate to the following key :
Code:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Filesystem
Now on the right side you will find a key with name : "NtfsDisable8dot3NameCreation", Right-Click on it and change the value box to "0" [Zero without quotes]. Now click OK and exit Registry Editor. Restart Windows and try again. This is valid only for NTFS File System. All the best...
Reply With Quote
  #5  
Old 05-05-2009
Member
 
Join Date: May 2008
Posts: 5,790
Re: Stop external drive from truncating long file names

hello HSACDM,

First of all, Welcome to the Techarena Forums !!!!

I think your problem of copying the files between the hard-drives is due to the long names of the files. Try renaming those files with the shorter names and check whether you can copy the files smoothly.....All the best..
Reply With Quote
  #6  
Old 05-05-2009
Member
 
Join Date: May 2008
Posts: 487
Re: Stop external drive from truncating long file names

See if this : How to take ownership of a file, helps you .

You must have ownership of a protected file in order to access it. If another user has restricted access and you are the computer administrator, you can access the file by taking ownership.

To take ownership of a file, follow these steps:

1. Right-click the file that you want to take ownership of, and then click Properties.
2. Click the Security tab, and then click OK on the Security message (if one appears).
3. Click Advanced, and then click the Owner tab.
4. In the Name list, click Administrator, or click the Administrators group, and then click OK.

The administrator or the administrators group now owns the file.

To change the permissions on the file that you now own, follow these steps:

1. Click Add.
2. In the Enter the object names to select (examples) list, type the user or group account that you want to have access to the file. For example, type Administrator.
3. Click OK.
4. In the Group or user names list, click the account that you want, and then select the check boxes of the permissions that you want to assign that user.
5. When you are finished assigning permissions, click OK.
6. You can now access the file.
Reply With Quote
  #7  
Old 05-05-2009
Member
 
Join Date: May 2009
Posts: 4
Re: Stop external drive from truncating long file names

Thanks Everyone! I see several options that I'm going to try.

Bon-Z, I don't know how to use the XCopy command. Can you show me how?
Reply With Quote
  #8  
Old 07-05-2009
Member
 
Join Date: May 2009
Posts: 4
Re: Stop external drive from truncating long file names

Thanks everyone! Smirnoff, I checked the registry and the key was already set to zero. My files are on the C: drive in one folder. They aren't nested. The folder name is only 32 characters long including the path length. I forgot to say that when I was trying to copy the files from the external drive and trying to burn them on a CD-R and CD-RW, the names were also truncated. I erased the CDs and reformatted them and the same thing still happened. My system is NTFS and so is the external drive according to Seagate. None of my files go beyond the character limit of 255 including the path length. I would say that the longest file name is 200 characters long which includes the path length. All of the spaces and special characters have been removed. Why would they appear truncated on the CD? Also it doesn't happen everytime. Sometimes they copy over intact.

Bon-Z, Haven't tried X Copy yet because I have to find another medium to back the drive up on.

Aikonik, I checked the properties and I am the owner with full control.

Thanks for all of your help!
Reply With Quote
  #9  
Old 07-05-2009
Member
 
Join Date: Mar 2009
Posts: 599
Re: Stop external drive from truncating long file names

Hey!
You should have mentioned that you want file names longer then 255 characters. Well that isn't supported in Windows nor in Linux/Unix. You can call this as limitations of the OS. All the best!
Reply With Quote
Reply

  TechArena Community > Hardware > Portable Devices
Tags: , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Stop external drive from truncating long file names"
Thread Thread Starter Forum Replies Last Post
Long Domain names Vs. Short Domain names for website $Daiwik$ Technology & Internet 4 17-01-2011 05:04 PM
External Hard Drive with no File system CACTUS101 Hardware Peripherals 3 26-11-2009 01:22 AM
cannot stop external hard drive using 'safely remove hardware' option prakash_s Hardware Peripherals 3 12-11-2008 12:00 PM
Windows XP Pro SP3 & Long File Names NIcaBoy Windows XP Support 5 05-09-2008 08:45 PM


All times are GMT +5.5. The time now is 09:55 PM.