Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 19-04-2012
Member
 
Join Date: Mar 2012
Posts: 60
WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

I have been using mac and I have recently upgraded the same to lion and the problem that I am facing is that WiFi is not autoconnecting when resuming from sleep mode, I was not having the same issue before when I was using Snow Leopard, I have tried adding the connection as a preferred connection in the Networks/Advanced but that does not seems to be making any difference, is there anyone who has faced the same after updating their mac to lion and has an idea about resolving this issue??
Reply With Quote
  #2  
Old 19-04-2012
Member
 
Join Date: Nov 2011
Posts: 93
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

Before I suggest you something about the same just answer me the following so that I can have a better idea of the issue that you are facing and will try to help you with the same:
  • Access point that you are using ?
  • Had you made a clean install of Lionor you have just migrated the setup from Snow Leopard?
  • Have you tried using No Security strictly for debugging the wireless issue ?
  • Have you tried using a known DNS server like Google's DNS for checking out if it is a DNS issue.
  • Have you tried using WPA2-Personal security t ?
  • Have you tried disabling the firewall help ?
  • Try disabling any 3'rd party antivirus app's if you are using.
Just try check out these things and then let me know the response that you are getting for it.
Reply With Quote
  #3  
Old 19-04-2012
Member
 
Join Date: Mar 2012
Posts: 50
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

You are not alone here as I am having the same issue, in my case I am running Have you tried using and I am running 10.7 on a MacPro 1,1 (2.0GHz)m, the weird thing that I have found is that when I am running Network Assistant/Diagnostic then I am getting all the green lights but then the Airport Extreme (Dual-Band) is not getting displayed in the Airport Utility list, it seems as if something is not computing properly, even I was not having the same issue before it just started prior to upgrading to Lion, other than this I am also having issues with track pad, they does not seems to be working when I am scrolling up and down or going back on some pages, I am using WPA2 ? Personal and I am not having any type of VM on my Mac, I have tried all the possible solution that I could have but then they have just not helped and now I am waiting for next software update but then if anyone finds out a solution for fixing this issue then please share it will be highly appreciated.
Reply With Quote
  #4  
Old 19-04-2012
Member
 
Join Date: Mar 2012
Posts: 63
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

I was facing the same issue before where there was no more autoconnection to my home network but then later after trying out a number of solutions I was finally able to fix it out if you want then you can try out the same and see if it is helping you out as well or not.In order to solve the issue you will just have to delete plist file corresponding to aiport which is /Library/Preferences/SystemConfiguration/com.apple.airport.preferences.plist you just have to follow three simple steps:
  1. Disabling the airport
  2. Deleting the plist file
  3. Enabling the airport and then selecting the network that you might be using.
I was having some other issues as well but then since after deleting the related plist files I was able to solve them out, so if you are probably having the same case then the above solution should help, just check it out and then let me know what you get.
Reply With Quote
  #5  
Old 19-04-2012
Member
 
Join Date: Mar 2012
Posts: 58
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

I was running in to the same issue but then the below changes have solved it out, so if the above solutions are not helping then you can try out what I have tried:
  • I had removed everything related to the wireless from the net work connections by going on to the network page and had also unchecked the ?ask to join new networks box? and had left out the menu bar as checked.
  • Now on the advanced page I had the following:
  • I had checked mark the ?ask to join new networks? box on the Wi-fi tab
  • Have set the ?IPv4 configure using dchp? to ?Configure IPv6 automatically? on the TCIP tab
  • Nothing is checked in the Proxies tab
  • Have set the Hardware tab configure automatically
After making the above changes now when the system is waking up then I see the wi-fi icon going through the connect routine and then I get a connection, previously it was showing as if was connected but then I have to connection for reconnecting, just try to make the above changes and then post back the result that you get for this solution.
Reply With Quote
  #6  
Old 19-04-2012
Member
 
Join Date: Oct 2011
Posts: 108
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

I have checked about the same and have found the below solution to be helping out a no of people having the same issue so even you can give it a try:
  1. First Renew DHCP lease by going in to System Preferences>Network>Advanced>TCP/IP and then just Set the Service order with Wi-Fi which will be on top.
  2. After that just Remove all the prefered networks from the prefered networks by going in to System Preferences>Network>Advanced>Wi-Fi and make sure that you are including the home network as well
  3. When you are done with the same then Remove all the saved wifi passwords from keychain access by going in toUtilities>Keychain Access.I will like to inform that the Wi-Fi passwords are denoted as Airport Network Passwords so perform this step if you are aware of the network key that is provided to you by your ISP.
  4. Now after completing the above steps just Remove the System Configuration folder to the desktop from Macintosh HD>Library>Preferences> and you are done.
Hope that helps.
Reply With Quote
  #7  
Old 19-04-2012
Member
 
Join Date: Nov 2011
Posts: 124
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

You all can try out new lion update (10.7.3) as it is found to be mentioning "Resolve a Wi-Fi connection issue when waking from sleep" in the fix list, it is fixing out the below things as well, so if you are having any of the below mentioned issues as well then you should surely try new lion update (10.7.3):
  • Includes Catalan, Croatian, Greek, Hebrew, Romanian, Slovak, Thai, as well as Ukrainian language support
  • It addresses the issues when using smart cards for logging into the OS X
  • It addresses the compatibility issues with Microsoft Windows file sharing
  • It addresses the issue with printing Microsoft Word documents which uses markup
  • It addresses graphics performance issue after sleep
  • It fixes the Wi-Fi connection issue after sleep
  • It addresses the issue where Safari was getting prevented from opening before joining a wireless network
  • It Fixes the potential issue for authenticating to an SMB DFS share
So just try it out and then post back the result for the new lion update (10.7.3).
Reply With Quote
  #8  
Old 19-04-2012
Member
 
Join Date: Mar 2012
Posts: 60
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

I don?t know how come the above solutions have worked out for some of you I have tried out installing the new lion update (10.7.3) but then it is really not helping and I am still having the same issue, other than this I have tried out the below solution but then they have not made any difference as well and I am still left with the same:
  • I have tried deleting all the preferred networks
  • I have tried creating a home network profile
  • I have deleted all the WIFI keys from the keychain and have re-entered the ones that are required for my Wireless N network
  • I have deleted the network setting folder and have rebooted the system for recreation of it
  • I have tried changing the IPv6 settings to local link only instead of keeping it automatic
  • I have reset the Netgear router in my case
  • I have tried Disconnecting and turning off all the wired and wireless network devices in the environment and have restarted the router and connecting the Macbook after that
  • I have turned off the B/G network as well as B/G and N Guests networks
  • I have tried using different channels and signals for my wireless N network
  • I have tried Resetting the SMC
I have tried all the possible solutions that I could have including the ones that has been mentioned here but then I have not yet got any avail, is there anything else that I can try out rather than visiting the service center for the same??
Reply With Quote
  #9  
Old 19-04-2012
Member
 
Join Date: Mar 2012
Posts: 92
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

I am not sure but then if anyone has not been able to solve out their issue from the solution that has been mentioned above then they can try out the following the below shell script:
Checking out network information-
Here you will have to first find out the name of your Wi-Fi connection it is called "Wi-Fi” by default but then some of you might have renamed the same for performing network troubleshooting steps, so just go in to the Network system preferences and make a note of the your Airport connection, it will be listed in the connection list which will be just next to Ethernet, FireWire, VPNs, Bluetooth etc.

Creating the script file-
  • In order to create a script file first open the TextEdit and then create a new document and then press Shift-Command-T for making a "Plain Text" document you can so the same in the Format menu as well, when you are doing this then make sure that you are copying and pasting the below text in the document:
#!/bin/bash
/usr/sbin/networksetup -setnetworkserviceenabled Wi-Fi off
/usr/sbin/networksetup -setnetworkserviceenabled Wi-Fi on
sleep 10
  • When you are done with the same then just save the file as connectairport.sh in /Macintosh HD/Library/Scripts/ folder, if you place it in to that folder then it will be accessible to other accounts as well and it will also keep Airport connected no matter if you log out from it.

Checking out if the script is executable-
  • You will need to make the script executable as the Programs and scripts does not run in OS X if they are not executable, so just open the Terminal and then run the below command to make sure that you the file can be run:
  • chmod +x /Library/Scripts/connectairport.sh
  • If you get an error saying "permission denied" or "access denied," then just enter "sudo" without the quotes followed by a single space and then type the same command after that and then enter the password when you will be prompted.

Now the script is ready to run in a globally accessible area, when you will run the same for the first time then it will be turning off the Wi-Fi radio and will turn it back on and when this happened then the Wi-Fi network should re-establish its connection automatically, when you are done with the same then you will have to create a launch agent file for running this script when the system might not be having an active network connection and you can do that by opening TextEdit and then setting the new document as plain text and then copying and pasting the below text in to it:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Label</key>
<string>local.connectairport</string>
<key>ProgramArguments</key>
<array>
<string>/Library/Scripts/connectairport.sh</string>
</array>
<key>KeepAlive</key>
<dict>
<key>NetworkState</key>
<false />
</dict>
</dict>
</plist>
  • After pasting the script just save the file as "local.connectairport.plist" in /Macintosh HD/Library/LaunchAgents/ folder and after that you can activate the same by running the below command in the Terminal or restarting:
  • sudo launchctl load /Library/LaunchAgents/local.connectairport.plist
  • Once you are done with this then the script is all set up and ready to go and now the launch agent will be running the script that you had created previously and will keep it active when the "NetworkState" will be false, I mean that if your system does not automatically connect after waking from sleep then the system will just turn the airport radio off and then back on and this will be spurring a connection to your preferred Wi-Fi network.
Reply With Quote
  #10  
Old 19-04-2012
Member
 
Join Date: Mar 2012
Posts: 78
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

Quote:
I don?t know how come the above solutions have worked out for some of you I have tried out installing the new lion update (10.7.3) but then it is really not helping and I am still having the same issue, other than this I have tried out the below solution but then they have not made any difference as well and I am still left with the same:

I have tried deleting all the preferred networks
I have tried creating a home network profile
I have deleted all the WIFI keys from the keychain and have re-entered the ones that are required for my Wireless N network
I have deleted the network setting folder and have rebooted the system for recreation of it
I have tried changing the IPv6 settings to local link only instead of keeping it automatic
I have reset the Netgear router in my case
I have tried Disconnecting and turning off all the wired and wireless network devices in the environment and have restarted the router and connecting the Macbook after that
I have turned off the B/G network as well as B/G and N Guests networks
I have tried using different channels and signals for my wireless N network
I have tried Resetting the SMC

I have tried all the possible solutions that I could have including the ones that has been mentioned here but then I have not yet got any avail, is there anything else that I can try out rather than visiting the service center for the same??
I was facing the same issue where the wifi was not autoconnecting after upgrading to Mac OS 10.7.3 on my iMac and I had tried out all the below solutions but then they had not helped:
  • I had tried changing my network location and had also created a new network location using WPA2 - Personal...
  • I had Deleted ?com.apple.airport.preferences.plist? file.
  • I had tried running Ran Onyx and performing thorough cleanup as well
  • I had tried deleting all the access passwords through the keychain.
  • I had tried removing all my preferred network as well as Home network.
  • I had tried Resetting the Netgear router and using different signal channels and settings
  • I had tried Turned off the firewall.
As I have already mentioned that they had not helped but then later just going through some more trouble shooting I found that I was having FT.com active in a Safari window and that was the culprit stopping the wifi from autoconnecting but then as soon as I changed the homepage to Google.com the issue was solved, you seem to be having the same case as you have tried out the solutions that I did, just try out changing the homepage to Google.com and let me know if your issues is getting solved or not.
Reply With Quote
  #11  
Old 19-04-2012
Member
 
Join Date: Jan 2012
Posts: 122
Re: WiFi not autoconnecting when resuming from sleep mode after updating mac to lion

You can follow the below solutions as well for fixing the same issue, you will first have to install the latest iMac Wi-Fi Update and after that you will have to remove your preferred network from the network setting as well as stored network passwords from KeyChain Access Utility and after that you will have to Restart the system for rebuilding he preferred network with password, when you are done with the same then follow the below instruction in the same manner:
  • First Download iMac Wi-Fi Update v1.0 as it has resolved the same issue
  • If that does not help then just select the Wi-Fi tab and check out the network and then remove all from the Preferred Networks list and then just click and then close the Network preferences.
  • Now just remove stored network passwords using the Keychain Access Utility and for that you will have to open the Keychain Access which will be in /Applications/Utilities, here your window should like the bellow image:
  • So just select the "login" keychain and then click on "Kind" to sort out the list of keychain items as per their type and then remove all the entries that belongs to the "AirPort network password".
  • After removing the AirPort network passwords from the login keychain you will have to remove the AirPort network passwords from the System keychain and for that just select System in the Keychain sidebar and then follow the same procedure in the previous step for removing the "AirPort network password".
  • When you are done with all this changes then just Restart your computer and then go in to network settings / preferred networks and then just click on the + sign for adding preferred network and then join the Wi-Fi network, here you will have to renter the password for your network so make sure you are aware of the same or else you will have to contact the network administrator.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "WiFi not autoconnecting when resuming from sleep mode after updating mac to lion"
Thread Thread Starter Forum Replies Last Post
Intel DP67BG is entering "power loop" when resuming from sleep after updating bios Gulbulay Motherboard Processor & RAM 4 28-03-2012 03:41 PM
Losing Internet connection when resuming from sleep-mode IJAYA Vista Help 10 23-06-2011 08:37 PM
After resuming from sleep mode Network adapter does not work mADiRAkSHii Networking & Security 4 11-01-2011 07:30 PM
DP45SG - Problem resuming from sleep mode in Windows 7 Talish Motherboard Processor & RAM 7 04-07-2010 07:24 AM
Macbook Air gives beachball after resuming from Sleep mode Chasey Portable Devices 5 27-04-2010 01:52 PM


All times are GMT +5.5. The time now is 04:55 PM.