Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 14-04-2012
Member
 
Join Date: Mar 2012
Posts: 72
Some apps are appearing in German language in Windows 8 Consumer Preview

I have installed Windows 8 Consumer Preview few hours ago and everything seem to went well and I did not had any issues during the installation process but then the problem that I am facing now is that when I am trying to configured my input method to Spanish (Spain) then I don?t know why but Microsoft apps like People, Messaging, Calendar are getting displayed in German language, in the beginning only few word were in german but then after rebooting the system everything on the apps is appearing in to German language, I have checked out the Control Panel and it has been setted up correctly and I am not able to track out the cause of this issue, is there anyone who can help me out dealing with it??
Reply With Quote
  #2  
Old 14-04-2012
Member
 
Join Date: Dec 2011
Posts: 117
re: Some apps are appearing in German language in Windows 8 Consumer Preview

Quote:
I have installed Windows 8 Consumer Preview few hours ago and everything seem to went well and I did not had any issues during the installation process but then the problem that I am facing now is that when I am trying to configured my input method to Spanish (Spain) then I don?t know why but Microsoft apps like People, Messaging, Calendar are getting displayed in German language, in the beginning only few word were in german but then after rebooting the system everything on the apps is appearing in to German language, I have checked out the Control Panel and it has been setted up correctly and I am not able to track out the cause of this issue, is there anyone who can help me out dealing with it??
I will like to share that this has been a common issue with some apps as they are not available in the language you might be looking for, in order to get the apps displayed in the language you are willing get then you can just add your language as a secondary language in the Language list, once you do the same then the apps will appear in the language that you might have set, for adding the secondary language just follow the below steps:
  • First check out for ?? in the Start screen and after that just change the scope to be Settings on the search pane rather than for the apps
  • After that Click on Add a language and then check out for language of your choice and then select add, you can use the Move up and Move down options for making sure that you are managing the languages order as per the preference.
I also wanted to add that the apps like People, Messaging, and Calendar are just available in English, German, Japanese, French and Chinese by now and you will have to close and then open them again for applying the changes.
Reply With Quote
  #3  
Old 14-04-2012
Member
 
Join Date: Mar 2012
Posts: 72
re: Some apps are appearing in German language in Windows 8 Consumer Preview

Hey thanks for the same, I have just followed the above solution and it has fixed the issue now, actually it was my bad, I mean that I had just changed the input language to Spanish and had left the display language as it is, in my case I am using windows in English and I am just having the notebook keyboard in the Spanish language, I am not very sure but then I think that it is a bug. I have found another solution for the same as well and it is setting up English as the only language and then adding Spanish as input language inside the option, so if anyone has the same issue then they can try out the other solution as well. I was really getting pissed off with this issue before and I was thinking of reinstalling the windows but then your quick reply saved my time.
Reply With Quote
  #4  
Old 14-04-2012
Member
 
Join Date: Dec 2011
Posts: 117
re: Some apps are appearing in German language in Windows 8 Consumer Preview

I don?t think that the other solution that you have said is making sense and it might be working as well ? ?I have found another solution for the same as well and it is setting up English as the only language and then adding Spanish as input language inside the option? as far as I am aware one cannot add Spanish as input language in the English language options, I think that you might have just added a second keyboard layout for the English language, in short you have just end up with English language in your profile but then having two keyboard layouts. To drag the same thing further if you will be adding spanish keyboard layout to the English language and after that if you will type "yo cantaba" in a context which might be supporting the spell checking then you will get a spelling error because English spell checking rules will be applied to it, it does not matter which layouts you are using but if the layout is associated with the English then the English spelling will be applied to it, if you will add English in your profile and Spanish as a second language then you will be able to type in English and get English spell check as well, if you want then you can just switch to Spanish for getting the Spanish spell check, if you want then you can just try out switching to Spanish with the help of Win+Space and after that if you will type "yo cantaba" then you will not get any spelling error, the reason behind the application appearing in German language is because they have been localized to five languages and the Spanish is not among them. Hope that helps.
Reply With Quote
  #5  
Old 14-04-2012
Member
 
Join Date: Nov 2011
Posts: 215
re: Some apps are appearing in German language in Windows 8 Consumer Preview

Even I will like to add something to the above, the Spell checking and auto-correction are basically determined by the input language which you might be entering, The languages that are listed in ones profile just determines the set of language available for the input, one can just switch the currently active input with the help of Win+Space hotkey combination as mentioned above, I will like to share that there is a clickable / touchable indicator which is in the Settings pane and once can access the same from the Settings charm, the currently activated input does not have any preference with the list of the languages that might be there in the ones profile rather than just determining the default for the first login, just to explain the same in detail if you are having English and Spanish in your profile and you start a email where email has been selected as input language and when you enter "ciudaad" and then hit space then it will get auto-corrected to "ciudad" and if you will type "catnaba " then you will get an spelling error and when you will right click on the same then "cantaba" will be offered as a correction , now after switching the input language to English when you will enter "freind" and give a space then it will get auto corrected to friend, I just wanted to explain here that you can just get the spell checking support for English as well as Spanish using the language for the speller which is actually determined by currently active input language, hope that was clear to you.
Reply With Quote
  #6  
Old 14-04-2012
KJo KJo is offline
Member
 
Join Date: Feb 2012
Posts: 125
re: Some apps are appearing in German language in Windows 8 Consumer Preview

I am not very sure but then I think that English is the only language in which the preview is available for now, is it?? I have found that the whole setup runs in English and since my language is not English I have chosen another keyboard layout and it works fine but then it messes up with changing the language for the People, Messaging, Calendar but then I have found a solution for the same and it is choosing Override the Windows Display Language rather than adding English to the preferred languages list by going in to the control panel and then in the Advanced Settings, I wont say that this solution is a perfect one as it is working nicely in the start but then loosing the same after sometime.
Reply With Quote
  #7  
Old 14-04-2012
Member
 
Join Date: Mar 2012
Posts: 72
re: Some apps are appearing in German language in Windows 8 Consumer Preview

I need some help regarding the same as well. I have recently installed Windows 8 Consumer Preview and I have set my account with Microsoft account and things are appearing fine, today I have added a user account for my brother but then after setting the user account setup I found that all the apps like Mail, Photos, Xbox LIVE, Calendar, Messaging, Camera, Music, Videos as well as the Xbox Companion are appearing to be in Chinese, I have tried going in to the General settings and then in to the Language control in Control Panel and have removed the other language except English and have also made the English the override but then I am still getting some app in Chinese, later after trying out the solution that has been mentioned here that we have to open and close the application for applying the changes I did the same and I got Mail and Photos showing in English but then Xbox LIVE, Calendar, Messaging, Camera, Music, Videos are still appearing in Chinese, so here I just wanted to know that what all solution I have to try out to get the above ones for getting displayed in English. Any help regarding this will be highly appreciated.
Reply With Quote
  #8  
Old 14-04-2012
Member
 
Join Date: Jan 2012
Posts: 102
re: Some apps are appearing in German language in Windows 8 Consumer Preview

In that case I will like to inform you that the Consumer Preview is available with Windows UI in five languages and no matter which one you install you can install the add-on language packs later for changing the Windows UI display language, actually the UI display language is not tied to the Windows UI display language directly, so here when you will go in to the Advanced Settings and after that change the Override the Windows Display Language option then it won?t be affecting a Metro style app, they will be affected in terms of their UI display language, In sort if you are having English in your preferred language list and if you set the same as the top preference then the app will have support for English and you will see the app in the same language.
Reply With Quote
  #9  
Old 14-04-2012
Member
 
Join Date: Feb 2012
Posts: 76
re: Some apps are appearing in German language in Windows 8 Consumer Preview

If anyone is willing to type/edit content in English then they can just add English into their language, they can just go through the below details steps for the same:
  • Check out for ?language? in the Start screen and then go in to the settings and then select Add a language, now you will get Language control panel and it will be showing up your language preference.
  • So if you do not find out English in the list of languages then select Add a language option and then move down and check out for English, you will get a stack of tiles as there are regional variants of English and when you will Double click on the English tile stack then you will get a list of regional variants.
  • Now just select the variant that you are willing to add and then you will be dragged back to the language preferences and you will find out the English to be added to your preferences.
  • When you are done with the above steps then English will be one of your languages, and that means:
You can now type/edit content in English.
  1. English will be reported as one of your language preferences by IE when you will browse
  2. The store will now be recommending you apps supporting English
  3. Metro apps that might be supporting English will be displayed in the same language.
  • If at all English is one of your languages in your profile and if Metro apps are still being displayed in some other language and you want them to see in English then you should check out and make sure that English is your first language preference by going in to the control panel and if it is not then move it to the top and then restart the application.
  • If English is one of your languages in your profile and if you are willing to type in English but the if a different language is appearing to be selected for the keyboard input then as it has been already mentioned in the above solutions you just have to press Win + Space and if you are having multiple input options then you can use the space button for stepping over then while keeping the Win key pressed down.
  • If you have by mistakenly installed Consumer Preview in some other language and you are willing to see the Windows UI display language in English then you can just get the English language pack and then set the same for Windows display language. In order to do that follow the below steps:
Go in to the Language control panel and check out if English is in your language profile, if it is in the language preference list then you will get a label beside the tile for English saying the below thing ( will differ in other languages)
Quote:
"Windows display language: Enabled" ? English is already your Windows display language
"Windows display language: Available" ? the English language pack is already installed
"Windows display language: Available for download" ? the English language pack is not yet installed
  • If you are getting the 2nd option here then change the same and move English up and make it your first language preference, when you do the same then the label will read "Windows display language: Will be enabled on next sign-in" and now after Log off / on you will get the Windows UI in English.
I
  • f you are getting the third option then you will have to install the English language pack and after that make English your first preference, for downloading the language pack, just go in to Options page for English and then click on the link for downloading and installing the language pack, when you are done with the same then just make it as a primary language. If you are not willing treat English as your primary language then you will have to install the package again and this time you should set Windows display language as an override rather than English as your top preference by going in to the advanced settings page.
I hope that I have covered all the issues that has been mentioned above and some that can take place.
Reply With Quote
  #10  
Old 17-04-2012
Member
 
Join Date: Jan 2012
Posts: 186
re: Some apps are appearing in German language in Windows 8 Consumer Preview

If the above solution is not working out for anyone then can let me know the language configurations that they have set in their machine so that I can have a better idea of the issue that they are facing, I have checked out for the same and have found that the recently released update for the Photos, SkyDrive, Mail, Messaging, Calendar and People app have fixed the issues that has been mentioned above, so just make sure that you are installing the latest version and if you still have an issues with it then report back for further help, I have found many people having similar issues where the apps were defaulting to German language but then the recently released update to the apps that I have mentioned has solved out that issues.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Some apps are appearing in German language in Windows 8 Consumer Preview"
Thread Thread Starter Forum Replies Last Post
All the Main metro apps are not working in Windows 8 Consumer Preview Bajrang Pandey Operating Systems 8 17-04-2012 04:07 AM
Windows 8 Consumer Preview installation getting stuck on Checking apps Achilleas Operating Systems 2 26-03-2012 05:27 PM
Apps installed on Windows 8 Consumer Preview not using Proxy Gopal Shrivastav Operating Systems 4 17-03-2012 03:10 AM
How to capture screenshot of desktop, apps, Metro UI in Windows 8 Consumer Preview $Iain$ Operating Systems 4 16-03-2012 11:27 AM
How to close Apps in Windows 8 Consumer Preview? Macau Pav Operating Systems 1 16-03-2012 12:33 AM


All times are GMT +5.5. The time now is 02:20 AM.