Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 03-04-2012
Member
 
Join Date: Jan 2012
Posts: 50
?update-apt-xapi? eating lots of system resources on Kubuntu

in today morning I noticed update-apt-xapi process which was making my system quite unstable. Does I need to use,
Quote:
sudo apt-get autoremove --purge apt-xapian-index
sudo apt-get autoremove ?purge
for your information I am having a high end computer so I don?t think so it is occurring because of low hardware configuration.
Reply With Quote
  #2  
Old 03-04-2012
Member
 
Join Date: Nov 2010
Posts: 442
Re: ?update-apt-xapi? eating lots of system resources on Kubuntu

Well I think you should go to synaptic and find out the package and lock version which cannot be upgraded. Also you should execute below mentioned command as well.
Code:
sudo aptitude hold package_name
So try it and let me know whether it was useful.
Reply With Quote
  #3  
Old 03-04-2012
Member
 
Join Date: Dec 2010
Posts: 334
Re: ?update-apt-xapi? eating lots of system resources on Kubuntu

I was also suffering from the same problem. however I am having bit older computer. however I managed to resolve the issue by simply disabling,
Code:
sudo chmod 644 /etc/cron.weekly/apt-xapian-index
once I done the above mentioned was not remain executable at all.
Reply With Quote
  #4  
Old 03-04-2012
Member
 
Join Date: Mar 2011
Posts: 489
Re: ?update-apt-xapi? eating lots of system resources on Kubuntu

if above mentioned solution does not work for you then I recommend below mentioned thing which you can give a try.
You should move to /etc/cron.weekly/apt-xapian-index directory.
Here you have to change
Code:
$CMD --quiet
To
Code:
nice -n20 $CMD --quiet
Reply With Quote
  #5  
Old 03-04-2012
Member
 
Join Date: May 2011
Posts: 397
Re: ?update-apt-xapi? eating lots of system resources on Kubuntu

I researched a bit and got below mentioned solution. You have to open /etc/cron.weekly/apt-xapian-index file and simply edit file in following manner.
Code:
#!/bin/sh

CMD=/usr/sbin/update-apt-xapian-index
IONICE=/usr/bin/ionice

# Rebuild the index
if [ -x $CMD ]
then
	if [ -x $IONICE ]
	then
		nice -n 19 $IONICE -c 3 $CMD --update --quiet
	else
		nice -n 19 $CMD --update --quiet
	fi
fi
we know that update-apt-xapian-index help us to keep a track of index of the packages and it also help to searching of the packages into Synaptic. Also you can do the same with the other package managers available in the market.
Reply With Quote
  #6  
Old 04-04-2012
Member
 
Join Date: Jul 2011
Posts: 231
Re: ?update-apt-xapi? eating lots of system resources on Kubuntu

there should be call made to update-apt-xapian-index located into the /etc/cron.daily/apt.
Code:
if [ -x /usr/sbin/update-apt-xapian-index ]; then
            nice ionice -c3 update-apt-xapian-index -q
        fi
it will not have nice value and xapian index not having--update option. Rather than it should be as follow.
Code:
if [ -x /usr/sbin/update-apt-xapian-index ]; then
            nice -n 19 ionice -c3 update-apt-xapian-index --update -q
        fi
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "?update-apt-xapi? eating lots of system resources on Kubuntu"
Thread Thread Starter Forum Replies Last Post
HTC One X sense feature is eating lots of RAM memory Sanaka Portable Devices 5 04-04-2012 06:36 AM
Dock is eating memory and CPU after Lion update 10.7.2 Nearer Windows Software 7 03-02-2012 06:02 PM
Need compatible web browser for Kubuntu Operating System Aandaleeb Operating Systems 5 26-12-2009 09:08 AM
Update to KDE 4.3.2 on Kubuntu 9.04 Jaunty? KuBuntU Operating Systems 4 11-12-2009 11:52 AM
Firefox eating lots of RAM Samsher Technology & Internet 4 08-01-2009 11:23 AM


All times are GMT +5.5. The time now is 03:37 PM.