Go Back   TechArena Community > Software > Operating Systems
Become a Member!
Forgot your username/password?
Tags Active Topics RSS Search Mark Forums Read

Reply
 
Thread Tools Search this Thread
  #1  
Old 31-03-2012
Member
 
Join Date: Jan 2012
Posts: 54
Suspend, Hibernate unable to work in ubuntu 10.04

As I can find some threads which had the similar problem , but as my version differs from their version, I am posting this new thread in this section and as per the title I am facing issues with Suspend and Hibernate options, and both don?t tend to work. Can you fix my issue in some means , please assist me in this case. I am having Ubuntu 10.04 installed in my laptop.
Reply With Quote
  #2  
Old 31-03-2012
Member
 
Join Date: Jun 2011
Posts: 482
Re: Suspend, Hibernate unable to work in ubuntu 10.04

I need to say that the Windows-based Ubuntu Installer (Wubi) lets you to install as well as uninstall Ubuntu from within Microsoft Windows so is this a wubi install in your case. and what happens when you attempt to suspend and when you attempt to hibernate?
Reply With Quote
  #3  
Old 31-03-2012
Member
 
Join Date: May 2008
Posts: 246
Re: Suspend, Hibernate unable to work in ubuntu 10.04

I was also having t the same issue and there was the same case as suspend and hibernate were not working on my Presario V5000 laptop. And after suspend, you have to shut down the laptop and then gain turn it back on. And in the case of suspend, networking is interrupted additionally. And to fix the networking issue , I have to permit Networking once more.but after trying with some check with the bios settings all was well and I think you should try with this thing.
Reply With Quote
  #4  
Old 31-03-2012
Member
 
Join Date: Jun 2011
Posts: 380
Re: Suspend, Hibernate unable to work in ubuntu 10.04

I was also having same issue and did an upgrade from Karmic 9.10 where both hibernation along with suspend worked very well on Lenovo X61s . as I have also find some sources that the it will work fine if you could attempt booting a livecd and observe if suspend works there. If it does, then a new install might treat it, but I wouldn?t have too high hopes.
Reply With Quote
  #5  
Old 31-03-2012
Member
 
Join Date: Jul 2011
Posts: 348
Re: Suspend, Hibernate unable to work in ubuntu 10.04

It was solved finally. after enabling extra alternatives, i attempted to update by making use of update-manager, then it showed me some packages to be downloaded and then I made an installation . Its updated, and then i tried this resume thing, and it worked and there were no further issues , then i switched back that visual thing to normal mode, which i was making use of it previously. And still its working!
Reply With Quote
  #6  
Old 31-03-2012
Member
 
Join Date: Jul 2011
Posts: 347
Re: Suspend, Hibernate unable to work in ubuntu 10.04

I found some more solution form net and this will definitely work in your case. so all you need is to modify the permissions along with the attributes of your system sleep files which will assist you for doing this suspend or else hibernate task on your ubuntu system. And perform this process you require to run below mentioned code on your terminal windows of the ubuntu method. It assists you to set the attributes along with permissions to its desired way. And in addition, with this code, you are able to carry out usual hibernate or else suspend task on this Ubuntu without any further problems .

Code:
sudo chmod 755 /etc/pm/sleep.d/20_custom-ehci_hcd
Reply With Quote
  #7  
Old 31-03-2012
Member
 
Join Date: Jul 2011
Posts: 319
Re: Suspend, Hibernate unable to work in ubuntu 10.04

This work about effectively fixed hibernate along with suspend on both of my laptops as I had with me Dell Inspiron 710m along with Compaq/HP TC4400 as there were issues on both.

I did have to adjust the settings to some extent in a different way so as to get the "searching for drivers" dialogue window.In my case both laptops were at first set to Normal. There was no effect after switching to Extra other than enabling the extra features. By toggling between None along with Normal I was able to raise the "Searching for drivers" dialogue. by means of Normal selected I closed Appearance Preferences and then rebooted my system . and it was all ok after rebooting both suspend as well as hibernate .
Reply With Quote
  #8  
Old 31-03-2012
Member
 
Join Date: Aug 2011
Posts: 393
Re: Suspend, Hibernate unable to work in ubuntu 10.04

It was working fine after I made the below mentioned settings.
1. You need to move in the System and then in the Preferences and then to the Appearance
2. Make a selection for the Tab "Visual Effects"
3. You need to make sure option "None" is chosen, if not choose it
4. you need to make some changes to "Extra", this makes the system searching for drivers routinely
5. finally you need to make some changes back to the configuration you favor.
Reply With Quote
  #9  
Old 31-03-2012
Member
 
Join Date: Aug 2011
Posts: 315
Re: Suspend, Hibernate unable to work in ubuntu 10.04

As you are referring ubuntu , hibernating only seems to be working apparently until you attempt to resume the system. Then you require to Press the Hibernate button in Kickoff and then in the Leave and at last the Hibernate. This procedure will be work to do your suspend or else hibernate procedure in safe manner with this ubuntu system. therefore attempt it along with make sure its valuable result on your system. You will be solved with this issue.
Reply With Quote
  #10  
Old 31-03-2012
Member
 
Join Date: Aug 2011
Posts: 375
Re: Suspend, Hibernate unable to work in ubuntu 10.04

I found an Ubuntu help page which provided instructions for installing the open source drivers along with it also suggested to remove the proprietary drivers. It was working fine then . ATI Control Center along with ATI Control Center Admin no longer showed up in System and then in the preferences after I made some check. I was able to switch appearance to moreover Normal or else Extra. on the other hand, the video appeared garbled in parts of the screen. I made some tried with running the update, but the suspend issues still existed . But then once more, my suspend issues start with suspend. specifically, the system doesn't completely suspend in the first place. I get a black back lit screen through a flashing underscore cursor in the upper left section.

So in this case, you need to check to see if ATI Control Center along with ATI Control Center Admin show up in System and then in the Preferences. If so, you have proprietary drivers in place as well as you almost certainly want to switch to the open source drivers. This will solve the issue.
Reply With Quote
Reply

  TechArena Community > Software > Operating Systems
Tags: , , , ,



Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads for: "Suspend, Hibernate unable to work in ubuntu 10.04"
Thread Thread Starter Forum Replies Last Post
Laptop won?t suspend or hibernate after installing Ubuntu 9.10 Scottish Operating Systems 2 30-05-2012 01:14 PM
Performing sleep / standby / hibernate / suspend operations from command line in Linux Ubuntu Python$ Operating Systems 8 01-04-2012 04:34 PM
Ubuntu 10.10 cannot resume from suspend YPD Operating Systems 10 19-12-2011 10:46 PM
Suspend or hibernate not working on Kubuntu 11.10 Mactron Operating Systems 6 30-11-2011 07:28 PM
Suspend doesn't work properly with ubuntu leshaspar Operating Systems 5 18-11-2010 07:31 AM


All times are GMT +5.5. The time now is 02:19 AM.