Results 1 to 6 of 6

Thread: S-1-5-20 Key is missing from registry in windows vista

  1. #1
    Join Date
    Feb 2012
    Posts
    79

    S-1-5-20 Key is missing from registry in windows vista

    I am having windows Home Premium and it is failing WGA test as the whole HKU\S-1-5-20 Key is missing from the registry. I have tried replicating the same from a VM but then I am not able to delete the Key but then I am not having any issues in clearing the Key, is there anyone who has faced the same and has an idea about it??

  2. #2
    Join Date
    Jul 2011
    Posts
    325

    Re: S-1-5-20 Key is missing from registry in windows vista

    I am having windows Home Premium and it is failing WGA test as the whole HKU\S-1-5-20 Key is missing from the registry. I have tried replicating the same from a VM but then I am not able to delete the Key but then I am not having any issues in clearing the Key, is there anyone who has faced the same and has an idea about it??

    Before I suggest you something about the same I just wanted to know that what is the REG QUERY HKU returning??? Other than this also check out the permissions on HKU and see if they are correct or not.

  3. #3
    Join Date
    Feb 2012
    Posts
    79

    Re: S-1-5-20 Key is missing from registry in windows vista

    I have checked out the same below are the things that are appearing in the
    REG QUERY HKU:
    HKEY_USERS\.DEFAULT
    HKEY_USERS\S-1-5-19
    HKEY_USERS\S-1-5-21-vvvvvvvvvvvvvvvvvvvvvvvvvv-1000
    HKEY_USERS\S-1-5-21-vvvvvvvvvvvvvvvvvvvvvvvvvv-1000_Classes
    HKEY_USERS\S-1-5-18
    REG ADD HKU\S-1-5-20 returns
    ERROR: The parameter is Incorrect
    I have also checked out the permissions and it is appearing to be fine, it is followed as below:
    • Everyone- read
    • Restricted- read
    • System- full control, read
    • Administrators- full control, read

    Is there anything else that I have to check????

  4. #4
    Join Date
    Jul 2011
    Posts
    358

    Re: S-1-5-20 Key is missing from registry in windows vista

    I have checked out for the same and have found the below solution to be solving out this issue:
    • First just Run CHKDSK /R so that it fixes the filesystem if there is any
    • After that just delete the NTUSER.DAT file which will be in the Network Service profile.
    • When you are done with the same then just copy the Default userís NTUSER.DAT file from the Network Service profile and then make sure that you are also emending permissions so that the Network Service gets the Full Control.

    Just try out the same and see if it is helping.

  5. #5
    Join Date
    May 2011
    Posts
    398

    Re: S-1-5-20 Key is missing from registry in windows vista

    As far as I am aware these keys rely under "C:\Windows\ServiceProfiles\NetworkService\NTUSER.DAT"
    They are controlled by the key that is missing which is:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList\S-1-5-20
    So you can very well try out the solution that has been mentioned above but then other than this make sure that you are running MGADiag as well.
    Just try out the same and then post back the result that you get.

  6. #6
    Join Date
    Nov 2011
    Posts
    659

    Re: S-1-5-20 Key is missing from registry in windows vista

    If the registry hive might have gone corrupted then you can just try out loading it again and in order to do the same just run the below command in the command prompt.
    ďreg load HKU\Test "C:\Windows\ServiceProfiles\NetworkService\NTUSER.DAT"
    After this just check out if there is any error and see if the subkeys cab be read in Regedit and also test out the security of a random key.
    I think that loading the hive manually will help you out, just try out the same and then let me know if it is helping.

Similar Threads

  1. Windows failed to load for missing or corrupt registry file
    By Jigya L. in forum Operating Systems
    Replies: 5
    Last Post: 22-03-2011, 09:54 AM
  2. How to fix registry in Windows Vista
    By ZeDaX in forum Windows Software
    Replies: 3
    Last Post: 03-06-2009, 12:39 PM
  3. How do i use Windows Registry in Vista
    By Arval in forum Operating Systems
    Replies: 3
    Last Post: 17-03-2009, 02:36 PM
  4. Replies: 1
    Last Post: 19-08-2008, 01:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •